Sensor SelfSwitch

Roguedeus

It's never too late to procrastinate...
Veteran
Joined
Mar 19, 2013
Messages
532
Reaction score
107
First Language
English
Primarily Uses
N/A
I've done everything I can think. Both event note and comment note... etc... The plugin seems to be completely unresponsive.

15_1107a.PNG

15_1107b.PNG

edit:

Something very similar happened when I tried using Ellye's States Damage plugin... The Japanese font was the problem. Ellye removed the Japanese from the plugin and it suddenly worked like normal.

I can't explain it and I honestly have no clue why more people don't have the problem.
 
Last edited by a moderator:

Roguedeus

It's never too late to procrastinate...
Veteran
Joined
Mar 19, 2013
Messages
532
Reaction score
107
First Language
English
Primarily Uses
N/A
Last edited by a moderator:

gamerxp

Veteran
Veteran
Joined
Oct 28, 2015
Messages
30
Reaction score
5
First Language
Russian
Primarily Uses
Huh? It should not freeze you anything if it does not work. Only Switch D page must be autorun. Other page should do nothing, so it will start automatically when switch is changed by plugin.
 

Roguedeus

It's never too late to procrastinate...
Veteran
Joined
Mar 19, 2013
Messages
532
Reaction score
107
First Language
English
Primarily Uses
N/A
Huh? It should not freeze you anything if it does not work. Only Switch D page must be autorun. Other page should do nothing, so it will start automatically when switch is changed by plugin.
What I meant was that I tried the event note and auto run 'D', and comment note with auto run 'D' and even tried auto run on both pages... and all it did was freeze the game.

I have tried every combination I can think of.

edit:

It doesn't help that the plugins instructions make no mention of how the event is supposed to be setup (other than adding the note tags).

Even if this issue wasn't occurring it would have been difficult to know if I was making a mistake.

I used Mog's Sensor event in VXAce extensively. So I am pretty sure I am not doing anything wrong. I understand what this looks like... And I assure you, the plugin simply isn't working at all. As if I never added it.... Which I clearly have.

I'm at a total loss as to what could be the problem... :(
 
Last edited by a moderator:

Lyson

Potholders!
Veteran
Joined
Sep 4, 2012
Messages
91
Reaction score
36
First Language
English
Primarily Uses
Renaming helped me, but...

https://gyazo.com/d40ab87bf8367ba924c475dc5916fc54

I get this when I try to move with some event configurations.

For example, I get it when I got event on the map that does not have unconditional page - no matter is it's sensor or not.
I'll try to take a look when I get home after work. With my computer acting up my ability to test the plugin was limited.

It looks like its a conflict with other plugins, in the list there is SilvStamina and MBS_MapZoom. Interesting. I'll try to check these for incompatibilities, I have an idea what may be the issue. If there are any other map or event plugins please let me know.

Edit: Looking at their plugins, and my own, I see that it has something to do with main and map updates, this seems to be making my comment function lose scope. I'll be checking to confirm this later, and see what can be done about it.

What I meant was that I tried the event note and auto run 'D', and comment note with auto run 'D' and even tried auto run on both pages... and all it did was freeze the game.

I have tried every combination I can think of.

edit:

It doesn't help that the plugins instructions make no mention of how the event is supposed to be setup (other than adding the note tags).

Even if this issue wasn't occurring it would have been difficult to know if I was making a mistake.

I used Mog's Sensor event in VXAce extensively. So I am pretty sure I am not doing anything wrong. I understand what this looks like... And I assure you, the plugin simply isn't working at all. As if I never added it.... Which I clearly have.

I'm at a total loss as to what could be the problem... :(
I never used Mog's script so I'm not sure how that functioned.

I added a little more for clarity in the "How to use" section of the OP. Beyond that, I'm not sure what else I could say.

All the plugin does it flip a switch, events should be set up the same as if you were setting the self switches manually, only they are set by the proximity and range that are set. 

For example, if you wanted to have a message popup automatically when in the range of the event, and you are using the event note box for the tag; you should make the first page of the event blank, with no conditions, (I've only tested with a default blank page, so it would be set to player trigger, but I think the only thing that would get in the way is auto-run, maybe parallel process). The page you want to run automatically should have the self switch condition set appropriately, with Autorun set. In the event contents place the message you want to show.

It seems as though you've tried this to no avail. So I'm really not sure what the issue could be. Are you using any other event affecting plugins?

@Lyson: maybe try changing your plugin parameter grab using this method so user can use any name they want:

http://forums.rpgmakerweb.com/index.php?/topic/47591-how-to-get-plugin-parameters-without-knowing-your-filename/

i use it for all my plugins... :D
Yeah, I'll probably add that so as to reduce issues.
 
Last edited by a moderator:

Lyson

Potholders!
Veteran
Joined
Sep 4, 2012
Messages
91
Reaction score
36
First Language
English
Primarily Uses
Sorry didn't mean to double post, trying to reply on my phone is more difficult than expected.
 
Last edited by a moderator:

Nova Toby

Veteran
Veteran
Joined
Mar 14, 2012
Messages
31
Reaction score
7
First Language
English
Primarily Uses
This plugin is not working for me either. I followed everything but it just wont work.

I even made a new project to test it out with the vanilla MV. Still no luck. I can see it in the plug ins. the instructions are all there but it just doesnt work.
 
Last edited by a moderator:

Lyson

Potholders!
Veteran
Joined
Sep 4, 2012
Messages
91
Reaction score
36
First Language
English
Primarily Uses
@Nova Toby & @Roguedeus

Is this issue occuring with v1.1 or v3.0? I just placed Sensor SelfSwitch, v3.0 copied from my pastebin, in a brand new project and it works as expected.

With Autorun set on the blank event page, and using the Event Note tag it seems to prevent autorun, (you can move around), and toggles appropriately when in range.

With no images set and autorunning a message on the Self Switch condition page, Event and Comment tags operate as expected.

When running Autorun on the blank event page, and using the comment tag, the autorun performed normally and prevented movement, if erase event was used, the event is erased, and will not operate the tag.

All of these tests were done with the regular Sensor: tag and SensorLV: tag

(with no images the line view seems to automatically use the down direction, Also I'll add that changing the direction without having an image does work, as I just tested that as well.)

I cannot seem to reproduce the problem of it just not working. I'm using the latest RMMV (27 OCT 2015 update), so barring that being an issue, the only thing I can think of is a conflict with another plugin that may be blocking my update function.

EDIT1:

@gamerxp

Contrary to what I thought, it has nothing to do with the other scripts, I'm looking into it.

EDIT2:

@gamerxp

I've made a fix for the issue, it turns out that when there is a condition for the first page, it apparently does not have a pageIndex until that condition is met.

This also means that the condition must be met for the comment tag to be evaluated.

EDIT 3: The pastebin has been updated, both the issue with first page conditions and blackout zone switches have been fixed
 
Last edited by a moderator:

Roguedeus

It's never too late to procrastinate...
Veteran
Joined
Mar 19, 2013
Messages
532
Reaction score
107
First Language
English
Primarily Uses
N/A
I just got in... I have 3.0 installed.

I will remove it, save, run project. And re-add after to see if that helps.

edit:

No dice. I even added characters to the event in case it needed a facing.

Blank on page 1, auto-run on page 2 with self switch 'D'...

Nothing.

I'll try earlier versions to see if they work.

edit:

Nope... v1.1 doesn't work either.

Could it possibly be the way that the plugin parameters are defined? The last plugin this happened to, was in Japanese and it was fixed when the author completely stripped the help/description of any text other than what they needed to make the parameter work.

Can you try that?
 
Last edited by a moderator:

Roguedeus

It's never too late to procrastinate...
Veteran
Joined
Mar 19, 2013
Messages
532
Reaction score
107
First Language
English
Primarily Uses
N/A
Here is a clean demo of the problem...

This does not work for me. If it works for you, then we know that whatever the problem is its only effecting a few of us. Question becomes WTH is it?!?

(OneDrive public folder)

SNIP

The file is: DEMO - Sensor Issue.zip
 
Last edited by a moderator:

Lyson

Potholders!
Veteran
Joined
Sep 4, 2012
Messages
91
Reaction score
36
First Language
English
Primarily Uses
So initial run of your project, I'm having the issues. I'll try it without the help.

My first thought is something to do with the core javascript, but I'm not sure.
 

gamerxp

Veteran
Veteran
Joined
Oct 28, 2015
Messages
30
Reaction score
5
First Language
Russian
Primarily Uses
Plugin's name must be "Sensor SelfSwitch.js". You named it "selfswitch.js". That's same issue I had
 

Lyson

Potholders!
Veteran
Joined
Sep 4, 2012
Messages
91
Reaction score
36
First Language
English
Primarily Uses
Ahaha, i didnt even look  ;_;

Yeah that fixed it, I'll update my plugin so that the name isn't an issue in just a moment.
 

Roguedeus

It's never too late to procrastinate...
Veteran
Joined
Mar 19, 2013
Messages
532
Reaction score
107
First Language
English
Primarily Uses
N/A
I am not used to seeing plugin names with spaces in them so I assumed it was Sensor "SelfSwitch.js" not "Sensor SelfSwitch.js"... lol

What a pain in the ass this naming thing is. :D

Now I feel like a moron.

edit:

SUCCESS!!!

Now to go cry a little....
 
Last edited by a moderator:

Lyson

Potholders!
Veteran
Joined
Sep 4, 2012
Messages
91
Reaction score
36
First Language
English
Primarily Uses
Plugin should be name independent now, according to my test.
 

Nova Toby

Veteran
Veteran
Joined
Mar 14, 2012
Messages
31
Reaction score
7
First Language
English
Primarily Uses
Thank you! It works like a dream now. I had it named as sensor_selfswitch.js instead of Sensor SelfSwitch,js
 

SoraNoYosuga

Villager
Member
Joined
Jul 26, 2015
Messages
22
Reaction score
14
First Language
Filipino
Primarily Uses
Sorry, I cant quite understand how the plugin works. Can you please upload a demo thanks
 

DavidFoxfire

Veteran
Veteran
Joined
Feb 28, 2014
Messages
224
Reaction score
44
Primarily Uses
I'm getting an error with Version 3.0:

/C:/Users/David/Documents/RMMV%20Projects/RPG%20Maker%20MV%20Files/Baldursgate/js/plugins/Sensor%20SelfSwitch.js:153

Uncaught TypeError: Cannot read property 'parameters' of undefined

This might be something to do with MV Commons.  I have the filename be "Sensor SelfSwitch.js", by the way.
 

Dallas Robinson

Villager
Member
Joined
Oct 29, 2015
Messages
45
Reaction score
1
First Language
English
i really hate to bother you but can someone do a step by step of how to set this up? my plug in is installed correctly but i just can't seem to get it to work. or submit a sample project so i can see how it's working
 
Last edited by a moderator:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

What does your project folder look like?
I was told that an iPhone can provide a personal internet hotspot...You learn something new everyday!
Will probably never use MZ. Buys it anyway
Been playing Star Ocean: The Last Hope, the remastered version on PS4. I like it. Seems others think it's garbage, but I like these cutesy, silly, and tropey characters. Having waaaay more fun with it than SO: Integrity and Faithlessness.

Forum statistics

Threads
100,458
Messages
976,161
Members
132,082
Latest member
nwr
Top