software window messed up

Discussion in 'Tech Support-All Makers' started by Xuwboss, Aug 19, 2017.

  1. Xuwboss

    Xuwboss Veteran

    Messages:
    30
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    i don't know what i did but the window to my RPG Maker MV is disproportionated .
    the toolbar is not where it should be and when hover directly above a key it does not register it unless i put my mouse either to the side or under it.
    i attached screenshots to show what it looks like
     

    Attached Files:

    #1
  2. taarna23

    taarna23 Marshmallow Princess

    Messages:
    2,080
    Likes Received:
    3,612
    Location:
    Saskatoon, SK, Canada
    First Language:
    English
    What is the resolution of your monitor/screen?
     
    #2
  3. Xuwboss

    Xuwboss Veteran

    Messages:
    30
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    1920x1080
    But it was working fine a while ago. the interface is out of wack
    i put a mark on the screenshot to show where my pointer was when the shadow pen was highlighted
     

    Attached Files:

    #3
  4. taarna23

    taarna23 Marshmallow Princess

    Messages:
    2,080
    Likes Received:
    3,612
    Location:
    Saskatoon, SK, Canada
    First Language:
    English
    Well, I hate to pose the obvious question (but some poor sap has to do it)... have you closed/reopened MV or restarted since you had this issue? If not, try one/both and see if the issue persists?
     
    #4
  5. Poryg

    Poryg Pixie of the Emvee kingdom

    Messages:
    1,829
    Likes Received:
    3,508
    Location:
    Czech Republic
    First Language:
    Czech
    Primarily Uses:
    RMMV
    Something must be fishy though, yesterday there was one post on the same theme... From a different user.
     
    #5
  6. Xuwboss

    Xuwboss Veteran

    Messages:
    30
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    i posted it but it wasn't getting a responses
     
    #6
  7. Xuwboss

    Xuwboss Veteran

    Messages:
    30
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    yea. i closed it then reopened and it was still doing the same thing
     
    #7
  8. Andar

    Andar Global Moderators

    Messages:
    23,779
    Likes Received:
    4,891
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    I remember a topic about one year ago with a similiar problem. That user finally found the solution in his display drivers: his computer had two graphic cards/chips and the editor was set to use the wrong card for display.
    Unfortunately I don't know the details anymore.
     
    #8
  9. Jesterofnios

    Jesterofnios Warper

    Messages:
    4
    Likes Received:
    0
    First Language:
    English
    Bump of hope.
     
    #9
  10. Jesterofnios

    Jesterofnios Warper

    Messages:
    4
    Likes Received:
    0
    First Language:
    English
    I found the solution. Okay so this is assuming you have Nvidia, what you want to do is right click on your desktop, open Nvidia Control Panel, select manage 3d settings, there should be a drop down box asking which graphics chip set you want to use, select Nvidia and restart RPG Maker MV.
     
    #10
  11. Xuwboss

    Xuwboss Veteran

    Messages:
    30
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    I don't have that. I have Intel Graphics settings
     
    #11
  12. Xuwboss

    Xuwboss Veteran

    Messages:
    30
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    #12
  13. mlogan

    mlogan I am not sir, mr., dude or bro

    Messages:
    11,157
    Likes Received:
    5,948
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    @Xuwboss I've merged this last post with this topic. Please do not make one more topic on the same problem. Thank you.

    edit: Have you checked your Intel settings for something similar?
     
    Last edited: Aug 25, 2017
    #13
  14. Xuwboss

    Xuwboss Veteran

    Messages:
    30
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    i don't know where to look
     
    #14
  15. Susan

    Susan Veteran

    Messages:
    2,759
    Likes Received:
    8,381
    Location:
    somewhere on this planet~
    First Language:
    No idea...
    Primarily Uses:
    RMMV
    This is a problem that one of my friends encountered last month when he updated his Intel drivers. However, it wasn't from Intel directly, but from his laptop's manufacturer. There was nothing he could do to make MV's interface display the way that it should. He had to roll back to a previous version in order to use MV without the interface bug.

    Are you using a desktop or a laptop that receives updates from a specific company eg. Dell, Asus, Acer, etc? If that's the case, try to rollback your graphic driver.
     
    #15
    Dalph likes this.
  16. Xuwboss

    Xuwboss Veteran

    Messages:
    30
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    I have Asus. My stuff probably updated when I shut down my laptop like it always does. How do I rollback my drivers?
     
    #16
  17. Dalph

    Dalph Nega Ralph (RM Tyrant - Overlord of Memes)™

    Messages:
    7,640
    Likes Received:
    16,478
    Location:
    Italy
    First Language:
    Italian Curses
    Primarily Uses:
    RMMV
    I have the same problem with my Dell Ultrabook that uses Intel HD 615.
    I can't update the Intel gpu drivers that Dell adapted for their specific ultrabooks because it causes the exact same problem you are experiencing, and makes Rpg Maker MV completely messed up (especially the bar above).
    What I did to make me able to use MV again was re-rolling back my gpu drivers, uninstalling manually and then allowing Windows 10 to download automatically the older ones (I guess it does that by default because sometimes it cannot find the newest but I'm not sure). To avoid issues, just go to your laptop manufacturer website to download the older gpu drivers and install them manually.
    That should solve it.

    I'm interested to know the solution about this problem as well since I cannot update my gpu drivers, I guess MV has some sort of issues with integrated Intel gpus.

    [​IMG]
     
    Last edited: Aug 25, 2017
    #17
    Susan likes this.
  18. Liquidize

    Liquidize Caffeine Overload

    Messages:
    463
    Likes Received:
    433
    First Language:
    English
    Primarily Uses:
    RMMV
    Hello,

    Sorry you are having this problem I would like to get it fix for you all. When Investigating this issue I noticed that in both cases that provided screenshots/video @Dalph and @Xuwboss your window title bar is slightly bigger than it should be, obviously though because that is what you're reporting. However In the video provided by @Xuwboss I noticed that your Taskbar is also slightly bigger than it should be for your standard 1080p display, by about 10 pixels or so. This is controlled by Windows and not MV (however, MV should probably properly adjust for this). What I believe to be happening is when you update your graphics driver, the manufacturer is adjusting this setting on a small level and MV can't properly adjust because it is such a small change (only about 10 or so pixels again). They may be doing this through changing the Windows settings, or behind the scenes. This may be something we can fix, or it may be something that is out of our hands and must be fixed with the GUI API we use for the engine. This is just a theory though and may not be the cause. For the time being though I'd like you to help me verify this though if you don't mind. With the updated drivers, what is the scaling of "Apps,fonts, and other items" set to in Windows Display Settings?

    Thanks,

    - L
     
    #18
    Dalph likes this.
  19. Dalph

    Dalph Nega Ralph (RM Tyrant - Overlord of Memes)™

    Messages:
    7,640
    Likes Received:
    16,478
    Location:
    Italy
    First Language:
    Italian Curses
    Primarily Uses:
    RMMV
    @Liquidize
    Hey Liquidize, thanks for the answer.
    150% for my Dell XPS 13 9365 (it's the scaling that Dell reccomends to use for the screen), exactly like it was before the update.
    Changing it doesn't seem to affect anything.
     
    #19
    Susan likes this.
  20. Magistar

    Magistar Grand Author of Worlds

    Messages:
    8
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    [Solution]

    Most modern laptops actually come with two graphic cards, at least most with the I7 and I5 cores. If you have an Intel HD card then you likely have a second card in there as well. Look for the Device Manager on your laptop, and look at the Display Adapters. In there you will likely see 2 cards, an Intel and a Nvidia. The fix that I found is to Right-Click the Intel card and click Disable Device. This will cause the screen to flash, but the Title bar will be gone and everything will work the correct way.

    Now you might have to re-activate it if you want to play certain games, so do not count this as a permanent solution. I will be working on a better fix when I can.
     
    #20

Share This Page