[SOLVED]Help using YEP_SlipperyTiles

Status
Not open for further replies.

GoodSelf

Zhu Li! Do the thing!
Veteran
Joined
Jul 23, 2016
Messages
540
Reaction score
976
First Language
English
Primarily Uses
RMMV
Hello all! I have the ice slide puzzles in my game (go figure), and I'm using the YEP_Slippery Tiles plugin. However, as my character is sliding, I still can use the arrow keys to change their direction, completely breaking the puzzle.

I tried setting Direction Fix on while the player was moving and resetting it once they arrive at their destination on the ice, however this proved to be cumbersome, as the player can cross this tile and change their direction even if they didn't hit an obstacle.

Does anyone know how to fix this issue while using the YEP plugin? Or does anyone have a way to do it by hand that locks the player while moving? If you have information on the latter, please feel free to message me directly so we can keep this thread in regards to supporting the plugin.

Thanks for your time!

EDIT: Well, it looks like I figured it out. For those who run into this problem, simply set a common event with this text:
$gamePlayer.moveForward();

This common event is being called using YEP_RegionEvents.
 
Last edited:

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
1,352
Reaction score
453
First Language
Dutch
Primarily Uses
RMMV
I dont have any problem with that though. It works without that.
Also if it doesn't work, the way you can use as well is just event it in a parallel process.
that is running on that map only.

I hope you check the params and/or read the helpfile inside that plugin.
 

GoodSelf

Zhu Li! Do the thing!
Veteran
Joined
Jul 23, 2016
Messages
540
Reaction score
976
First Language
English
Primarily Uses
RMMV
I dont have any problem with that though. It works without that.
Also if it doesn't work, the way you can use as well is just event it in a parallel process.
that is running on that map only.

I hope you check the params and/or read the helpfile inside that plugin.
I checked the plugin like 5 times to see if I was missing anything. Maybe I have another plugin that's causing it to act weird? I'm really not sure what was happening. It's working fine now though, so, if it works don't question it! XD
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
6,183
Reaction score
4,301
First Language
Dutch
Primarily Uses
RMXP

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

stock analyst lady
Well, since I'm in lockdown, I guess it's finally time to get serious into rpgmaking... almost 20 years later.
Forbidden - You don't have permission to access /index.php on this server.

Forum statistics

Threads
95,745
Messages
931,527
Members
126,124
Latest member
FIL
Top