[SOLVED] Playtest screen don't show up

Status
Not open for further replies.

Bersjerker

Villager
Member
Joined
Oct 19, 2018
Messages
23
Reaction score
0
First Language
French
Primarily Uses
RMMV
Hi there,

It's been a rough week. :rsad:
Lately, I haven't been able to launch my playtest window anymore while editing my game.
Everything works fine, except when I click on the playtest icon, nothing happens ...
I've been looking in the task manager and it seems that the playstest is launched, but I can't find it anywhere ?

I bought RMMV on the official website, not on Steam, and tried to unistall / reinstall. I have also rebooted my pc, but still the same.

PLEASE HELP
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
1,696
Reaction score
556
First Language
Dutch
Primarily Uses
RMMV
can you still open the consol log (F12), you can try pressing F11 or all Fbutton (except 1)
there is button that disable playtest while it is a windowed version of chrome so far I know.

pressing a button can disable alot of function, so maybe in RPG MV as well.
unless you missing NW.JS?
 

Bersjerker

Villager
Member
Joined
Oct 19, 2018
Messages
23
Reaction score
0
First Language
French
Primarily Uses
RMMV
can you still open the consol log (F12), you can try pressing F11 or all Fbutton (except 1)
there is button that disable playtest while it is a windowed version of chrome so far I know.

pressing a button can disable alot of function, so maybe in RPG MV as well.
unless you missing NW.JS?
I've tried all F buttons, but nothing happens. I work on HP Laptop so not sure if it is because of that.
And where could I verify for NW.JS ? Here's a screen of my root file for RMMV :

1586013410380.png
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
1,696
Reaction score
556
First Language
Dutch
Primarily Uses
RMMV
if you go to NWJS-test folder, and double click the EXE, does it work?

EDIT:
where is the Gamefolder located? does teh index HTML work when clicked on it?

Can yo utry to run rpgMV as admin and see if it works?
 

Bersjerker

Villager
Member
Joined
Oct 19, 2018
Messages
23
Reaction score
0
First Language
French
Primarily Uses
RMMV
if you go to NWJS-test folder, and double click the EXE, does it work?

EDIT:
where is the Gamefolder located? does teh index HTML work when clicked on it?

Can yo utry to run rpgMV as admin and see if it works?
SORRY FOR DOUBLE POSTING !

Okay, so the game folder is located in My Documents, and it has never been a problem so far, it didn't change location. The only big thing I've made recently is updating my Nvidia graphic driver to the latest version. and reboot computer.

When I launch Index.html it does this :

Image
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
1,696
Reaction score
556
First Language
Dutch
Primarily Uses
RMMV
I update my Nvidia drivers too, but no issue though, does it also happen on a clean project?
sometimes it can be the spaces in the title (not that I have trouble with it though)

but if anything else didn't work, than I got no clue, because I got my project on D drive,
game project -> MAIN PROJECT which also has side project, evented menu, event save,
event abs system etc before I impliment them in my main project to troubles.

but if your project is on C drive, it should give any issues, specially if you are "admin",
sometimes run as admin is need to override the software, but I cant say anything else
whats missing or wrong.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,011
Reaction score
7,023
First Language
German
Primarily Uses
RMMV
game folder is located in My Documents
that is not the folderpath.
can you please state the entire folderpath beginning from the drive letter to the index.html?
something like c:\folder\folder\folder\folder\index.html

because there is a number of causes in the filepath that can cause this error.

The only big thing I've made recently is updating my Nvidia graphic driver to the latest version.
how did you update? by using windows driver update or by using the nvidia setup downloaded from the nvidia website?
because the internal driver update from windows tends to prefer the microsoft drivers instead of the nvidia drivers, and the microsoft drivers would be a bad solution especially in case of RMMV. Although they usually result in whitescreen and not a playtest error.


EDIT:
How old is your project, and when did you last update it and your editor?
The 1.6.x editor cannot playtest projects 1.5.x or older, the projects need to be updated to 1.6.2 (current version) or the editor downgraded to 1.5.2 if that is the case.
However that would not cause the failed to load error...
 

Bersjerker

Villager
Member
Joined
Oct 19, 2018
Messages
23
Reaction score
0
First Language
French
Primarily Uses
RMMV
that is not the folderpath.
can you please state the entire folderpath beginning from the drive letter to the index.html?
something like c:\folder\folder\folder\folder\index.html

because there is a number of causes in the filepath that can cause this error.


how did you update? by using windows driver update or by using the nvidia setup downloaded from the nvidia website?
because the internal driver update from windows tends to prefer the microsoft drivers instead of the nvidia drivers, and the microsoft drivers would be a bad solution especially in case of RMMV. Although they usually result in whitescreen and not a playtest error.


EDIT:
How old is your project, and when did you last update it and your editor?
The 1.6.x editor cannot playtest projects 1.5.x or older, the projects need to be updated to 1.6.2 (current version) or the editor downgraded to 1.5.2 if that is the case.
However that would not cause the failed to load error...
I have updatd from the Nvidia official website to the latest graphic driver and everything seemed to be fine, and my project is 4 months old but i have updated RMMV and checked the plugins to be sure there's no problems.

Aniway I finally found a "solution".
I found out that I can download RMMV on Steam if I already bought it on the official website, so I installed the program on Steam instead and removed the other from my computer.
For odd reasons, it works perfectly on Steam, even better.

Aniway, thank you so much guys for taking the time to respond and trying to help me !

I can say the problem is solved.
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
6,483
Reaction score
4,402
First Language
Dutch
Primarily Uses
RMXP

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

I based this on the armor of Actor 1_7 of the RTP. Hair is from Derex and Sythian Bard.
Stream will be live shortly! Going to do another art stream tonight so that I can finish my Fauna Focus piece~ Feel free to drop by!
Humans are fallible creatures, we all know that. It's when we're forced to look at ourselves that we start to disagree. :p
Expectation: Working on boss battle.
Reality: "Look at how awful are these code and database organization. Let me clean this mess", *yet, casually adding more modules that I have no idea if I would use it later*
Trying to learn to read Japanese so I read my manga. I like to buy them without all the edits made during translation.

Forum statistics

Threads
97,865
Messages
947,454
Members
129,087
Latest member
jubacard
Top