Solved: Problems with Galv's Character Frames Plugin?

Discussion in 'Javascript/Plugin Support' started by Andreyla, Mar 1, 2018.

  1. Andreyla

    Andreyla I'm 98% popcorn Veteran

    Messages:
    48
    Likes Received:
    225
    First Language:
    English
    Primarily Uses:
    RMMV
    G'Day,
    Just having an issue that has me confuddled.
    I'm using Galv's Character Frames plugin in RPG Maker MV and I can't seem to get it to work right. Every now and then it seems to drop a frame. I've used 6 frames instead of 8, which I'm sure is complicating matters. I've read up on it and I thought I programmed the sprite sheet correctly though. It's written as $BabyLineWalkTest%(6).png

    Here's the tester sheet:
    [​IMG]


    I filmed to show what I mean. First I filmed it at the default pace, then I went back and slowed the character pace down (which is ultimately what I want to do for this character). It's terribly obvious that there's frames missing there.

    (filmed at half speed to to make it easier to follow)

    I've seen this issue come up a few months ago, but alas I didn't read the solution and I can't for the life of me find the thread. If anyone has any ideas I would be very grateful :kiss:
     
    #1
  2. Plueschkatze

    Plueschkatze Veteran Veteran

    Messages:
    513
    Likes Received:
    1,511
    First Language:
    German
    Primarily Uses:
    N/A
    Have you tried to not use a parallel process to change the players speed? Because it's basically running over and over again and might cause hiccups.
    Do an autorun once, set a selfswitch (and a new blank page with that selfswitch) after the movement route and done. It will stay at that speed until you change that again, so no need to let a parallel process run.

    I can't say anything specific for that plugin tho, because I've not used it before.
     
    #2
    Andreyla likes this.
  3. Andreyla

    Andreyla I'm 98% popcorn Veteran

    Messages:
    48
    Likes Received:
    225
    First Language:
    English
    Primarily Uses:
    RMMV
    @Plueschkatze The reason I was using a parallel process at the moment was because I hadn't yet figured out how to get Autorun to work properly (although that was next on the agenda for sure). Generally when I set up the autorun for walking, when I open the game I can't move (I presume because it's waiting for something to play out before activating?)
    I think I might be misunderstanding your instructions. Do I make page one of the event an Autorun Self Switch A to ON, and make page 2 a conditional page (set to Self Switch A being ON) and put in the movement route? When I do this the movement route speed isn't applied. When I turn the second page to autorun also, it goes back to not being able to move.
    I know it's a little off my main question, but if you have a solution for that too I would certainly welcome it :guffaw: :kiss:
     
    #3
  4. Plueschkatze

    Plueschkatze Veteran Veteran

    Messages:
    513
    Likes Received:
    1,511
    First Language:
    German
    Primarily Uses:
    N/A
    You need to end the autorun, if you don't do that, it will run forever (and you'll be unable to move and your cute little sprite will be stuck forever~).
    I usually do this:
    Page 1 - Set to autorun. Add whatever events shall happen (in this case the movement route). At the end control the self switch (turning self switch A on)
    Page 2 - Blank (no events, nothing). Under the conditions chose self switch A. Leave it on Action Button.

    Maybe test this out and see if it helps with your main problem. If not we can continue the search X3
     
    #4
    Andreyla likes this.
  5. Andreyla

    Andreyla I'm 98% popcorn Veteran

    Messages:
    48
    Likes Received:
    225
    First Language:
    English
    Primarily Uses:
    RMMV
    @Plueschkatze You're a gem! This fixed the problem thank you! Didn't think I was going to get two solutions, this just made my day. Thank you :D

    All working now, I'll mark the thread as solved :D
     
    #5
  6. Plueschkatze

    Plueschkatze Veteran Veteran

    Messages:
    513
    Likes Received:
    1,511
    First Language:
    German
    Primarily Uses:
    N/A
    Great! <3
    Have fun game making!
     
    #6
    Andreyla likes this.

Share This Page