Spritesheet selection box too small, even with $ and proper dimensions.

tumsterfest

Veteran
Veteran
Joined
Aug 11, 2020
Messages
77
Reaction score
19
First Language
English
Primarily Uses
RMMZ
Hi,

I'm trying to use animated lava bubbles, but when I go to create the event the selection box is too small to get the whole frame.

I know there are a million topics out there on this issue, and they've all been a matter of:

  • Not putting "$" in front of the file name, or
  • The spritesheet not being 3x4 scale
But as you can see in the image I've attached, I've done both. Is there something else I'm missing?

Thanks!
 

Attachments

  • why me.PNG
    why me.PNG
    21.5 KB · Views: 36

Hyouryuu-Na

Very very lazy
Veteran
Joined
Jun 15, 2017
Messages
1,102
Reaction score
2,885
First Language
Not English
Primarily Uses
RMMV
Is there a space in front of the $? It looks like it. Maybe try deleting that?
 

tumsterfest

Veteran
Veteran
Joined
Aug 11, 2020
Messages
77
Reaction score
19
First Language
English
Primarily Uses
RMMZ
Thanks, but I thought the same thing and tried that. There was no space -- it's just the indent of the file organization.
 

Quexp

Lifelong Learner
Veteran
Joined
Jun 18, 2018
Messages
552
Reaction score
1,127
First Language
English
Primarily Uses
RMMV
Try !$Firecav_Bubbles
Better?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,850
Reaction score
8,577
First Language
German
Primarily Uses
RMMV
Please show us the spritesheet itself (attach it) so that we can check for other possible errors.
And with the full original filename which is not visible in your tiny cutout - but even that tiny cutout shows several possible problems with the name.

For example the Windows override that forces browsers to accept filenames with spaces is not always working, and usually fails on deployment to other systems. You really should avoid using spaces in your filenames.

That said, you might compare your sprite with the data in this tutorial that explains sprite construction:
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,637
Reaction score
15,278
First Language
English
Primarily Uses
RMMV
Try !$Firecav_Bubbles
The ! has nothing to do with the size of the sprite. The ! only controls whether it's aligned with the grid when drawn, or moved higher.

OP there is something wrong with the filename in your image, but because you have cropped it to be so tiny, you've lost the most important stuff. Please take another screenshot using Alt+PrintScreen and don't crop it.

You might also have issues with resources not being loaded after you deploy, because of all the spaces you have in the file names. If you're not too far into your project, I suggest you go through and rename them all to remove the spaces, then go and modify all your events that use them. Make a backup of your project first.
 

Dev_With_Coffee

Veteran
Veteran
Joined
Jul 20, 2020
Messages
860
Reaction score
432
First Language
PT-BR
Primarily Uses
RM2k3
I managed to recreate the sprite to perform the test, it worked normally:
Firecave_Working.png

From the "Print Screen" (Capture) I noticed that the filename is longer than it looks, so although it doesn't help much for lack of detail I'll just deduce that the filename has a other symbol in the part not visible from the name that conflicts with the "$"

A tip: When requesting support give as much related details as possible.

Good luck
 
Last edited:

Quexp

Lifelong Learner
Veteran
Joined
Jun 18, 2018
Messages
552
Reaction score
1,127
First Language
English
Primarily Uses
RMMV
Thanks, @Shaz! I was taking a shot in the dark on that one (not understanding the symbols) as I've used trial and error to get my stuff to work. Good info. :)
 
Last edited:

tumsterfest

Veteran
Veteran
Joined
Aug 11, 2020
Messages
77
Reaction score
19
First Language
English
Primarily Uses
RMMZ
Thanks for the tip about file naming -- I'll keep that in mind going forward.

In this case, though, even with removing the spaces, it's still giving me the tiny selection box.

why me part 2.PNG

BTW, this is a resource from Avery, not something I created on my own.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,850
Reaction score
8,577
First Language
German
Primarily Uses
RMMV
then please give a link to it, so that we can check it out and see if it is something that can be reproduced.
 

Dev_With_Coffee

Veteran
Veteran
Joined
Jul 20, 2020
Messages
860
Reaction score
432
First Language
PT-BR
Primarily Uses
RM2k3
Thanks for the tip about file naming -- I'll keep that in mind going forward.

In this case, though, even with removing the spaces, it's still giving me the tiny selection box.
Could you clarify if this problem really happens only with this file?
Because really nobody will be able to help you due to lack of information.
If it's just this graphic I can send you what I did and you can check if it works.
If it's all it could be a plugin that you forgot to list too, as it's something relevant.

I kindly ask you to pay attention to details like this for us to try to resolve.
 

tumsterfest

Veteran
Veteran
Joined
Aug 11, 2020
Messages
77
Reaction score
19
First Language
English
Primarily Uses
RMMZ
then please give a link to it, so that we can check it out and see if it is something that can be reproduced.

I'm not sure which of her threads I grabbed it from, but here's what I have.

Also, for the heck of it I tried cloning the file and seeing if a new version would work. Spoiler: It didn't.
 

Attachments

  • $Firecave_Bubbles_avery.png
    $Firecave_Bubbles_avery.png
    16.4 KB · Views: 6

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
9,000
Reaction score
5,887
First Language
Dutch
Primarily Uses
RMXP
Well, that file works fine for me. What version of MZ are you on? I believe there was a bug where if you use folders it wouldn't recognise the $ sign. It's been fixed in the current version.
 

tumsterfest

Veteran
Veteran
Joined
Aug 11, 2020
Messages
77
Reaction score
19
First Language
English
Primarily Uses
RMMZ
Well, that file works fine for me. What version of MZ are you on? I believe there was a bug where if you use folders it wouldn't recognise the $ sign. It's been fixed in the current version.

Thank you so much; this worked!

However ... on the same map, I'm now having a similar issue with a large sprite. The selection box works fine, but when I playtest only half the sprite shows up.

event.PNG

Capture.PNG

I have no "Through," "Below Character," or any other weirdness going on with this event -- just a simple Battle Processing step. I tried moving the event to other tile types, and even other maps, but it's still cut off in playtesting.

Sorry to be a pain; this map must be cursed or something haha
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,637
Reaction score
15,278
First Language
English
Primarily Uses
RMMV
That is very odd. What plugins do you have? Can you use this in a project without any plugins and see if you have the same issue?

Why are there + signs against your image names? Is this a new MZ thing?
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
2,134
Reaction score
1,145
First Language
English
Primarily Uses
RMMV
So you've gotta have something going on with it, because that quadrant that's showing up isn't even from the middle image that you have selected, it's from the left one that doesn't have the purple highlights.

You're sure it doesn't have a setting that's covered up in your screenshot that's making it try to walk or turn or something?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,850
Reaction score
8,577
First Language
German
Primarily Uses
RMMV
Why are there + signs against your image names? Is this a new MZ thing?
yes - MZ can now handle folders inside the resource sections. If there are subfolders they become foldertrees with that +- for displaying the folder contents

when I playtest only half the sprite shows up.
which tiles are you using? it might be that the full sprite shows up, but is partially covered by tiles set to star-passability.

If that is not the case we need to see screenshots of your full plugin manager
 

tumsterfest

Veteran
Veteran
Joined
Aug 11, 2020
Messages
77
Reaction score
19
First Language
English
Primarily Uses
RMMZ
  • I triple-checked the event -- no walking or turning or other weirdness
  • I haven't messed with plugins lately, and I've never had this issue before with a properly sized spritesheet, so I don't think it's a plugin issue. I attached my list just in case.
  • I triple-checked the tileset, and there are no star tiles associated with that part of the map. I'd also moved the event to another map and tried it there, and it was still cut off.
 

Attachments

  • event page.PNG
    event page.PNG
    99 KB · Views: 6
  • plugins 1.PNG
    plugins 1.PNG
    148.7 KB · Views: 6
  • Plugins 2.PNG
    Plugins 2.PNG
    54.9 KB · Views: 6

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,850
Reaction score
8,577
First Language
German
Primarily Uses
RMMV
Please check if the same effect is still there if you disable the three cyclone plugins and start a new playtest (not loading a savegame) after that.

those plugins say that they are changing the layering of the tiles and give other map effects, and that may cause the side-effect with the only partially visible sprite.
 

Latest Threads

Latest Posts

Latest Profile Posts

Can we make it so whenever a banned user tries to use their account whilst banned, the forum should redirect to this
Anyone doing anything for NaNoWriMo this year?
Listening to, "Draum" by Eldrim. If you haven't heard it before, do so. Absolutely lovely, and utterly haunting.
Using Live2D is actually pretty fun once you get familiar with where everything is. :rhappy: And no, I'm not learning because of the Vtuber thing going around, but yes looking at those helps a lot to know what can be done :LZSlol:

Forum statistics

Threads
115,829
Messages
1,093,288
Members
151,021
Latest member
estudiosdefrikis
Top