SRD HUD Maker Bug?

Cuprite

Previously Golden
Veteran
Joined
Feb 6, 2017
Messages
84
Reaction score
34
First Language
English
Primarily Uses
RMMV
So, I was trying to use SRD's HUD Maker, but for some reason, an error popped up telling me my project had to be in v1.3.0 or higher, but my version of RMMV is 1.5.2. Can somebody please explain what's going on here?
Error1.PNG Error2.PNG Error3.PNG
Also, when SRD's Game Upgrade is activated, I get this error.
Error4.PNG

*Update: I've figured out how to make the HUD Maker function again. I just had to delete this line in the plugin file.
Error5.PNG
But now when I use the HUD Maker, I get this error when starting a new game.
Error6.PNG

**Update: Ok, maybe don't do that.
 
Last edited:

SimProse

Veteran
Veteran
Joined
Jul 9, 2016
Messages
364
Reaction score
199
First Language
English
Primarily Uses
Game Upgrade has to be at the very top I think.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
12,964
Reaction score
13,321
First Language
English
Primarily Uses
RMVXA

I've moved this thread to Plug-in Support. Please be sure to post your threads in the correct forum next time. Thank you.

 

Cuprite

Previously Golden
Veteran
Joined
Feb 6, 2017
Messages
84
Reaction score
34
First Language
English
Primarily Uses
RMMV

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,144
Reaction score
12,418
First Language
English
Primarily Uses
RMMV
Your project version and your RPG Maker version are completely independent. Open your rpg_core.js file and see what version number it says at the top. If it doesn't have a version number on the first few lines, it means you have 1.0.0

When you get an error message, please open the developer tools (F8) and go to the Console tab and get a screenshot of that. It provides much more information than what's in your screenshots.


And you didn't find out how to make the hud maker work again. You only found out how to stop it notifying you that you had an earlier version than it requires. You STILL have an earlier version than it requires, which is why when you removed the check, it still crashed. You need to do what the message tells you to do and upgrade your project. The instructions are in every single update thread that's been posted. I suggest if you don't know what you're doing, you don't edit scripts. You should put that back the way it was.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,037
Reaction score
7,031
First Language
German
Primarily Uses
RMMV
*Update: I've figured out how to make the HUD Maker function again. I just had to delete this line in the plugin file.
Deleting a line like that is the programmer's equivalent of saying:
"Oh, my car reports oil problems with a red light. I don't like warning lights, so I paint the LED black. Voila - no more inconvenient warnings that my car is about to fail - it doesn't matter to me that the motor will be wrecked later if I continue to drive with bad oil, the important thing is to get rid of the warning light".

Please redownload the original plugin file to repair all the damage you did to it, and then search for the update topics stickied here on this forum to learn how to update your project correctly.

Additionally, make sure to stay at 1.5.2 and do NOT update to 1.6.1 if you want to use SRD's plugins - SRD hasn't been seen in quite a while and his plugins are no longer fully compatible to the current version 1.6.1
 

Cuprite

Previously Golden
Veteran
Joined
Feb 6, 2017
Messages
84
Reaction score
34
First Language
English
Primarily Uses
RMMV
Your project version and your RPG Maker version are completely independent. Open your rpg_core.js file and see what version number it says at the top. If it doesn't have a version number on the first few lines, it means you have 1.0.0

When you get an error message, please open the developer tools (F8) and go to the Console tab and get a screenshot of that. It provides much more information than what's in your screenshots.


And you didn't find out how to make the hud maker work again. You only found out how to stop it notifying you that you had an earlier version than it requires. You STILL have an earlier version than it requires, which is why when you removed the check, it still crashed. You need to do what the message tells you to do and upgrade your project. The instructions are in every single update thread that's been posted. I suggest if you don't know what you're doing, you don't edit scripts. You should put that back the way it was.
I replaced the edited HUD Maker plugin the original again and then looked at the rpg_core.js. When I did, it didn't show a version number at the top, so I'm assuming its 1.0.0.
Here's a screenshot of the console.
ConsoleError.PNG

Deleting a line like that is the programmer's equivalent of saying:
"Oh, my car reports oil problems with a red light. I don't like warning lights, so I paint the LED black. Voila - no more inconvenient warnings that my car is about to fail - it doesn't matter to me that the motor will be wrecked later if I continue to drive with bad oil, the important thing is to get rid of the warning light".

Please redownload the original plugin file to repair all the damage you did to it, and then search for the update topics stickied here on this forum to learn how to update your project correctly.

Additionally, make sure to stay at 1.5.2 and do NOT update to 1.6.1 if you want to use SRD's plugins - SRD hasn't been seen in quite a while and his plugins are no longer fully compatible to the current version 1.6.1
Yeah, that probably wasn't the smartest decision I've ever made, huh?
And thanks for the advice both of you!
I'll try to find that thread about updating projects, but so far, I haven't found it in the three sticky threads here. .-.
 
Last edited:

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,144
Reaction score
12,418
First Language
English
Primarily Uses
RMMV
not the plugin. The rpg_core.js file is the one that has the version number.
 

Cuprite

Previously Golden
Veteran
Joined
Feb 6, 2017
Messages
84
Reaction score
34
First Language
English
Primarily Uses
RMMV
not the plugin. The rpg_core.js file is the one that has the version number.
Oh, right, that's what I meant to say. My bad.
I've edited my last reply to say what I actually meant to say.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,144
Reaction score
12,418
First Language
English
Primarily Uses
RMMV
How is it that your project is still using the original version of the core files? There have been heaps of updates to improve functionality and fix errors - haven't you taken any of them? Or have you taken the updates to the engine but never, ever updated your projects? The core files is pretty much the main reason updates are provided.

This is where all the update threads are: https://forums.rpgmakerweb.com/index.php?forums/rpg-maker-mv-releases.171/
they will all provide instructions on updating your projects.

However, since yours is so, so old, I wouldn't go with any of those. I would start a brand new project with your current version, and copy over the data folder and any resources you've added. I wouldn't copy over any plugins - I would go and find the latest versions, because the ones you have may not work with the later versions of the engine.
 

Cuprite

Previously Golden
Veteran
Joined
Feb 6, 2017
Messages
84
Reaction score
34
First Language
English
Primarily Uses
RMMV
How is it that your project is still using the original version of the core files? There have been heaps of updates to improve functionality and fix errors - haven't you taken any of them? Or have you taken the updates to the engine but never, ever updated your projects? The core files is pretty much the main reason updates are provided.

This is where all the update threads are: https://forums.rpgmakerweb.com/index.php?forums/rpg-maker-mv-releases.171/
they will all provide instructions on updating your projects.

However, since yours is so, so old, I wouldn't go with any of those. I would start a brand new project with your current version, and copy over the data folder and any resources you've added. I wouldn't copy over any plugins - I would go and find the latest versions, because the ones you have may not work with the later versions of the engine.
I think it might have something to do with the fact that I was originally going to use the FPLE plugin and used the demo project as a base.
I'll try making a new project for it.

*Update: Hey, so I moved everything to a new project and everything works perfectly now (As far as I can tell, anyway). The HUD Maker's working now and I'm not getting any errors! Thanks for the help, Shaz!
:hhappy:
*Insert Final Fantasy victory fanfare here*
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

On the plus side, if all this rioting sparks another Covid outbreak... I will have a whole lot of time to work on my game. Not exactly how I wanted to get that time, but hey I'm a glass is half full... of RM kind of guy. :LZSwink:
A video once in a while won't hurt.
Have a craving for a Nesquik milkshake. No idea why. Haven't had one since I was a kid. lol. I remember them kinda tasting nice, but also leaving a lot of nasty powder at the bottom of the cup.
The more I think about it, the weirdest part of going to work post-virus will probably be getting used to seeing my coworkers' mouths again. :LZYshock:

Forum statistics

Threads
98,068
Messages
949,006
Members
129,340
Latest member
guangdi
Top