State to disable "Basic Attack". (MV)

Discussion in 'Javascript/Plugin Support' started by Blair Pendragon, Jun 29, 2019.

  1. Blair Pendragon

    Blair Pendragon Veteran Veteran

    Messages:
    91
    Likes Received:
    41
    First Language:
    English
    Hello, Ive been looking around google, and here, and I cant seem to find this type of "state".
    I do not wish to remove the attack option entirely, as all of my search results lead me to.

    I want a SINGLE character in my party to be unable to attack, SOMETIMES. Preferably through a state.
    I'm using yanfly pluggins, so if the option already exists somewhere, and i missed it, id be appreciative if someone could point me to it.

    The reason Id like it to be a state, is I plan to disable ALL actions which deal damage in any form. (until removed)

    But an equal alternative would be to remove the ability to even target enemies instead. (Or at least some enemies. Such as the boss cant be targeted, but the adds can be.) but again, this only applies to ONE character. Also, unlike the "taunt" pluggin, the boss still cant be targeted, even if the adds die.

    So either no attack options, or not being allowed to target enemies(or specified enemies) for a single character. (Will wear off after combat, but not by death)

    Sorry in advance if I overlooked it/the answer to my issue. And thank you as well for any information regarding this option.
    (worse case scenario, I'll make it deal 0 dmg, but it HEAVILY ruins the plot, so this is only a last resort.)
     
    #1
  2. Doktor_Q

    Doktor_Q I'm not a real doktor, but I am a real Q Veteran

    Messages:
    624
    Likes Received:
    351
    Location:
    Denial
    First Language:
    English
    Primarily Uses:
    RMMV
    Should just be able to seal it normally without needing any modifications.
    upload_2019-6-28_22-55-0.png
     
    #2
    kirbwarrior and Blair Pendragon like this.
  3. Blair Pendragon

    Blair Pendragon Veteran Veteran

    Messages:
    91
    Likes Received:
    41
    First Language:
    English
    I honestly have no idea how i missed that... lol.
    well, that explains why i couldnt find the answer in searches lol. XD
    ty, and sorry for wasting ur time.
     
    #3

Share This Page