Jrrkein

Insert Witty Title Here
Veteran
Joined
Apr 20, 2014
Messages
251
Reaction score
98
First Language
Indonesian
Primarily Uses
RMMZ
Here's my plugin list.
upload_2018-9-22_17-48-33.png
Octopath is in the very bottom

I'm such a dumbuss, can anyone tell me if I got wrong
 
Last edited:

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,789
Reaction score
14,591
First Language
English
Primarily Uses
RMVXA
You've got a lot of non-Yanfly plug-ins I see. There's no guarantee that they will work. Disable all non-yanfly plug-ins, and see if the problem still occurs. If it doesn't, then add them one by one until it happens again.

Edit: Also you got two Mog plug-ins, and those almost never work with Yanfly. Disable those.
 

Jrrkein

Insert Witty Title Here
Veteran
Joined
Apr 20, 2014
Messages
251
Reaction score
98
First Language
Indonesian
Primarily Uses
RMMZ
I took out all non-yanfly plugins includes mog, I still got the error message

upload_2018-9-22_19-25-56.png
and here's the current plugin.
upload_2018-9-22_19-27-2.png
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,789
Reaction score
14,591
First Language
English
Primarily Uses
RMVXA
Archeia checked your project. It isn't 1.6.1. You MUST use 1.6.1 in your project, or things will not work. That is mandatory.
 

Jrrkein

Insert Witty Title Here
Veteran
Joined
Apr 20, 2014
Messages
251
Reaction score
98
First Language
Indonesian
Primarily Uses
RMMZ
Will copying to a new project will work? I have 1.6.1 and I'm not sure how to check my project version
 

atoms

Veteran
Veteran
Joined
May 31, 2013
Messages
543
Reaction score
337
First Language
English
Primarily Uses
RMMV
@Archeia

This post I've done, I hope will be very clear for you. I also want @Jrrkein to read it so they can "fix" the problem.

First I want to say I am sorry your time has been wasted like this, and I know @Jrrkein is not as helpful as they could be with there replies. I also know it's far too confusing and messy the way it being handled on here for a proper way to give bugs and sort them out easily.

However saying all that, I also knew I tested it thoroughly so I wondering why I was finally able to get the error.

I finally found the "problem". This time I used Archeia's project file from post 901467.

What I did was use the Instant Fire skill first, followed by a normal Thunder skill that consumes a turn.

If Yanfly's default battle system is set to STB, it works fine. See below
Error.png




Error2.png



However if I set it to DTB, which is what @Jrrkein has by default, we get this error.


Error3.png


Error4.png


I must note however I also made a couple of changes to both skills. I gave them a Warrior Type and set it to target All Enemies.

Error5.png


Error6.png


Error7.png

Error8.png



I also tested this without the Steal skill, since there was never any promise it would be compatible with that Plugin. Yet I know Instant skills are meant to be compatible.

I still got the error.

Since it's clear it is meant to requires OTB for it to work, and I am almost certain if it was set to OTB it would work, I almost dismissed this entirely.

However, we are suppose to have the feature to force OTB with Olivia's wonderful Plugin, and this was set on force when I tested it with the DTB setting.

Error9.png


It's your call whether that counts as a bug or not. I personally would say it is a bug as other people could think leaving the default system to DTB yet forcing OTB in the OTB setting should be enough.

Other then the changes shown in these screenshots, I did nothing else to the project. I tested it on the map itself with the event that leads to a battle encounter.

Just doing the Fire skill followed by the Thunder skill should trigger it.

In case you want to quickly test it, here is both your project folders you left us with. One with the steal skill in it, one without it.

I wanted to use DropBox, but for me it came out as a complete mess so I just zipped them using winrar and added them to RMN locker space. Let me know if that is a problem.

Project file Instance Skill with Steal
https://rpgmaker.net/users/boos405/locker/Octopack_Instant_and_Steal.rar

Project file Instance Skill without Steal
https://rpgmaker.net/users/boos405/locker/Octopack_Instant_without_Steal.rar

Hope that is ok for you. Please don't be stressed by all the nonsense going on here, it's not worth that.

Also, forgot to add this.

1.
error10.png


2.
error11.png
 

Jrrkein

Insert Witty Title Here
Veteran
Joined
Apr 20, 2014
Messages
251
Reaction score
98
First Language
Indonesian
Primarily Uses
RMMZ
You're right, I have no issue while switching to STB setting as DTB result in an error.
 

Latest Threads

Latest Profile Posts

Gameboy Tiles, Cure Writer's Block, Animations on Menu, Generate Tasks | RPG Maker News #40

How would you judge a game you played? Art/Graphics? Story? Gameplay?
Learn MV sales goal = 2%
NSFW game sales goal = 2500% (no jokes) :guffaw:
After gathering, sorting out & reconsidering hundreds of enemy battlers over the last two das, finally my favorite part begins: Inventing names and lore for them all :D

Forum statistics

Threads
111,377
Messages
1,060,589
Members
144,706
Latest member
DonTonyPepperoni
Top