Tags doesn't work in YEP_SmartJump

Marius Striker

Villager
Member
Joined
Mar 19, 2017
Messages
5
Reaction score
0
First Language
Portuguese
Primarily Uses
RMMV
Hello, makers! I'm using Yanfly's library in my project and the tilesets tags aren't working in SmartJump, for both tiles and events with the <Illegal Jump: x> and <Illegal Jump> tags, respectively. If I put at some tilesets note <Illegal Jump: 1> and mark the Illegal Jump's tilesets with 1, the player still being able to jump over them. The same happens with events when I put <Illegal Jump> at his note, looks like the game ignore these notetags completely.

It's working fine with regions, but using notetags would be more affordable. Will be very annoying to paint all maps with regions to prevent Illegal Jumps. In Yanfly's video, other people complained about the same problem, but no one answered. Someone already fixed this problem and could share with us? I'm using version 1.03 of YEP_SmartJump.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,262
Reaction score
7,138
First Language
German
Primarily Uses
RMMV
That is most likely either caused by wrong plugin order or by incompatibility, because yanfly's Plugins usually work.

Can you give us a Screenshot of your plugin manager and check the title line of your projects rpg_core.js file for its Version number?
 

Marius Striker

Villager
Member
Joined
Mar 19, 2017
Messages
5
Reaction score
0
First Language
Portuguese
Primarily Uses
RMMV
Sure! Here it is:


I always try to remark the order of the plugins.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,262
Reaction score
7,138
First Language
German
Primarily Uses
RMMV
Your pictures do not display.
Please simply copy the picture of the plugin manager directly into the post, and write out the title line after opening the core file (no need for picture for that)
 

Marius Striker

Villager
Member
Joined
Mar 19, 2017
Messages
5
Reaction score
0
First Language
Portuguese
Primarily Uses
RMMV
rpg_core.js v1.5.0 - Yanfly Version Update

Plugin Manager.PNG
 
Last edited:

TheOddFellow

Overactive Artisan Story Crafter
Veteran
Joined
Jul 3, 2014
Messages
152
Reaction score
67
First Language
English
Primarily Uses
RMMV
Really, late, but I felt I had part of an answer to your question.
I am using (YEP_SmartJump v1.03) on RPG Maker 1.6.1.
I marked my regions with: <Illegal Jump: 2>
For Tilesets; YEP_SmartJump works strangely. On, A4 (Walls) I've marked both the top and bottom "Terrain Tag" with 2; and while YEP_SmartJump works fine on the bottom part (the base), my character will still jump on the top part (the roof).
The only way I've considered fixing this is to change my tileset to make roof part of (the base).
 

Marius Striker

Villager
Member
Joined
Mar 19, 2017
Messages
5
Reaction score
0
First Language
Portuguese
Primarily Uses
RMMV
I still using SmartJump on my project but just to do little jumps, it won't have a button to jump because of these impediments that I had. Hope you get better luck than me using him!
 

TheOddFellow

Overactive Artisan Story Crafter
Veteran
Joined
Jul 3, 2014
Messages
152
Reaction score
67
First Language
English
Primarily Uses
RMMV
Not really. I'll probably just script in the jumps with other events. But, thanks! I hope you're far in your game!
 

FunkyTable

Warper
Member
Joined
May 2, 2019
Messages
1
Reaction score
0
First Language
English
Primarily Uses
RMMV
I was playing around with this last night and discovered the same issue. I guess the best thing to do is to block the illegal jumps with regions. Tedius, but at least it still works. I sent this thread to the creator on *******, though I don't know if they will respond.

Just imagine what the programmers of yore had to do to get their games working and the tedium's affect dampens, a little.
 

ninjatone

Villager
Member
Joined
Feb 12, 2013
Messages
6
Reaction score
0
Primarily Uses
Through a bit of quick debugging I found that in cases where my terrain tag wasn't being respected, the code was never getting past this line of the isSmartJumpIllegalRegion function:

if (Yanfly.Param.JumpEqualRegion.contains(regionId)) {
if (this.regionId() === regionId) return false;
}
Because in the default config the equal region ID is set to 0, I guess this means that the "equal region" check passes and the jump check stops before it has a chance to get to the illegal terrain tag check, if if you don't change the default equal region ID.

I changed my "Equal Regions" config option from 0 to a nonsense number (-6), and now the terrain tag check seems to be properly enforced.
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

Stream will be live shortly with a session of the Interactive text Adventure! Feel free to drop by!
Quick! Someone give me a snake pun about moving.
Meet the crew...Arrrr!
Who knew modern medieval was an actual music genre? I don't know what the youtube algorithms are doing but for once they found something actually fascinating:
Yay! Got 3 new frying pans, its weird, but I'm so happy about it.

Forum statistics

Threads
99,526
Messages
966,401
Members
131,152
Latest member
rai1209
Top