test play no longer working MV

Discussion in 'RPG Maker MV' started by lonewolph, Feb 23, 2018.

  1. lonewolph

    lonewolph Veteran Veteran

    Messages:
    191
    Likes Received:
    14
    First Language:
    English
    I got a message when trying to test-play saying "the core javascript files need to be updated to test play" I clicked okay and it updated something but now I just get a black screen when trying to test play my game, when it worked before, anyone know how to fix this?
     
    #1
  2. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,905
    Likes Received:
    12,023
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    It means you need to update your project to version 1.6. Due to the changes in mv old project files will not run on version 1.6
     
    #2
  3. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,561
    Likes Received:
    978
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    #3
  4. clitvin

    clitvin Veteran Veteran

    Messages:
    91
    Likes Received:
    11
    It's kinda stupid for the program to offer to update it for you and then fail. If it can't do it properly it should say please update your project by following these instructions.
     
    #4
  5. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,564
    Likes Received:
    14,247
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    It only updates the software but not your project to avoid incompatibility issues. If it does it automatically and you didn't backup, you're screwed.
     
    #5
  6. Yaruru

    Yaruru Villager Member

    Messages:
    8
    Likes Received:
    4
    First Language:
    Spanish
    Primarily Uses:
    RMVX
    Hi!

    I updated my projects and it keeps telling me "the core javascript files need to be updated to test play"
     
    #6
  7. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,905
    Likes Received:
    12,023
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    That means you haven't updated them properly. If they are updated fully that message should no longer appear. Check the heading of the .js files you have and make sure all of them say Version 1.6, if not, that is the file you need to update.
     
    #7
    Yaruru likes this.
  8. Yaruru

    Yaruru Villager Member

    Messages:
    8
    Likes Received:
    4
    First Language:
    Spanish
    Primarily Uses:
    RMVX
    You were right! Thank you very much!
     
    #8

Share This Page