Testing Plugin Compatibility

Discussion in 'Javascript/Plugin Support' started by Ossra, Sep 12, 2019.

  1. Ossra

    Ossra Formerly Exhydra Veteran

    Messages:
    841
    Likes Received:
    602
    First Language:
    English
    Primarily Uses:
    RMMV
    Are there packed bundles that contain the test build of NWJS, engine code, and libraries for each version of RPG Maker MV laying around? I have primarily building my newer plugins for the latest version (1.6.1), but I would like to ensure that the plugins could work even on the code from the initial release. Do I have to try and extract each bundle from the installers provided in the 'Software Updates' sub-forum?
     
    #1
  2. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,601
    Likes Received:
    1,007
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    No bundles that I'm aware of, but NWjs is free so you should be able to download whatever version you want. If you have RPG Maker MV on Steam it's pretty easy to toggle between the versions to get the core scripts.

    What exactly are you concerned with supporting? Modern (2015+) Javascript syntax? Functions in the core scripts that may not exist on older versions? Plugin parameters?

    Below v1.5 there's only plain text plugin parameters so if you use the advanced ones it becomes very difficult to support. I think you need to weigh the effort vs. reward of supporting old versions of anything.
     
    #2
  3. Shaz

    Shaz Veteran Veteran

    Messages:
    37,718
    Likes Received:
    11,429
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    There was a pretty significant change to the way tiles were drawn after about 1.3.1 - some of my plugins stopped working and needed to be rewritten. I know of a couple of plugins that will crash on earlier versions, and a couple that no longer work with the latest versions.
     
    #3

Share This Page