The icon of the game looks strange and idk how to fix it, help :'D

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
I tried to use some SRD plugins to customize the title screen, they didn't work but not only that this happened (the icon of the game looks like this) and I don't know how to fix it. Does anyone have any idea how to solve it? ;w;
I already deleted the plugins from the plugin folder and I tried changing the icon with other image but it also doesn't change.
1603120212050.png
The icon in the window itself looks fine.
1603120350570.png
 

Alador

The Mage of Mythix
Veteran
Joined
Apr 16, 2020
Messages
155
Reaction score
121
First Language
English
Primarily Uses
RMMV
Sorry, but I don't see any problems with your icon. Could you provide a picture or describe what exactly is wrong with your icon?
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
Sorry, but I don't see any problems with your icon. Could you provide a picture or describe what exactly is wrong with your icon?
yeah, here it is, it's the first image. The last aplication is the game and it doesn't have the icon of the game 1603124739934.png
 

Alador

The Mage of Mythix
Veteran
Joined
Apr 16, 2020
Messages
155
Reaction score
121
First Language
English
Primarily Uses
RMMV
yeah, here it is, it's the first image. The last aplication is the game and it doesn't have the icon of the game View attachment 164441
Hmmm. This is quite odd. You said you did replace the icon in the icon folder, correct? And it was renamed "icon.png?"
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
Hmmm. This is quite odd. You said you did replace the icon in the icon folder, correct? And it was renamed "icon.png?"
yap, and it didn't solve it so I left it with the default icon again. I think that the only thing that it did change was also mess up the icon in the window of the game.

yap, and it didn't solve it so I left it with the default icon again. I think that the only thing that it did change was also mess up the icon in the window of the game.
I changed it and this happened ;-;
1603125751925.png
This is the icon that I used to test:
icon.png
 

Alador

The Mage of Mythix
Veteran
Joined
Apr 16, 2020
Messages
155
Reaction score
121
First Language
English
Primarily Uses
RMMV
I changed it and this happened ;-;
View attachment 164442
Well, I might be stating the obvious, but it seems that MV is having trouble loading your CommunityBasic plugin. Try turning off all of your plugins, see if that helps, and then turn each one on to see which one is affecting the icon.
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
Well, I might be stating the obvious, but it seems that MV is having trouble loading your CommunityBasic plugin. Try turning off all of your plugins, see if that helps, and then turn each one on to see which one is affecting the icon.
I turned them all off and that error doesn't appear anymore but the icon problem is still unsolved.

I turned them all off and that error doesn't appear anymore but the icon problem is still unsolved.
When I turned them off I noticed that in the plugins folder I don't have the normal plugins that a project has. What.
 

ScorchedGround

Blizzards most disappointed fan
Veteran
Joined
Apr 12, 2020
Messages
328
Reaction score
472
First Language
German
Primarily Uses
RMMV
I had the same issue a long time ago when I used SRD plugins.

I still don't know what exactly is the issue but I DO know that the plugins do something to your "package.json" found in your project folder.

When I had the problem I created a new project and overwrote my package.json with the one from the new project. This restored my icon to normal but I had to abandon the SRD plugins for the time being.
 
Last edited:

Alador

The Mage of Mythix
Veteran
Joined
Apr 16, 2020
Messages
155
Reaction score
121
First Language
English
Primarily Uses
RMMV
When I turned them off I noticed that in the plugins folder I don't have the normal plugins that a project has. What.
I think that @ScorchedGround's solution will work well. Take a new project, replace the pack.json, and you should be good to go.
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
I had the same issue a long time ago when I used SRD plugins.

I still don't know what exactly is the issue but I DO know that the plugins do something to your "package.json" found in your project folder.

When I had the problem I created a new project and overwrote my package.json with the one from the new project. This restored my icon to normal but I had to abandon the SRD problems for the time being.
OH THANK YOU SO MUCH! it works <3

I think that @ScorchedGround's solution will work well. Take a new project, replace the pack.json, and you should be good to go.
Yeah, thank you both for taking the time to help me with this issue :'D

I just noticed something :')
The icon in the window stays with the default icon.
Like, it shows the one I made but then after a few seconds it changes to the default one.
 

ScorchedGround

Blizzards most disappointed fan
Veteran
Joined
Apr 12, 2020
Messages
328
Reaction score
472
First Language
German
Primarily Uses
RMMV
Ah yes... I remember I had that problem afterwards aswell.

I actually did solve it somehow... but I can't remember how I did because that was quite long ago.
But I do remember that the solution was pretty easy... but I just don't remember what exactly I did.

I will tell you how to solve it when I remember again, sorry.
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
Ah yes... I remember I had that problem afterwards aswell.

I actually did solve it somehow... but I can't remember how I did because that was quite long ago.
But I do remember that the solution was pretty easy... but I just don't remember what exactly I did.

I will tell you how to solve it when I remember again, sorry.
Ok, thanks! <3
 

ScorchedGround

Blizzards most disappointed fan
Veteran
Joined
Apr 12, 2020
Messages
328
Reaction score
472
First Language
German
Primarily Uses
RMMV
I just noticed something :')
The icon in the window stays with the default icon.
Like, it shows the one I made but then after a few seconds it changes to the default one.
I think I remember now.
Go to your project folder and then to your "save" folder.

Then you have to delete either "config.rpgsave" or "global.rpgsave".
I can't tell you which one to delete since I deleted both of them, so maybe you should too.

Don't worry, the files will be restored when you save in the game again. The only thing that happened to me is that the options in the game (like the sound-volumes) are reverted to default, which shouldn't be a problem as you can just put them back to what you want afterwards.
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
I think I remember now.
Go to your project folder and then to your "save" folder.

Then you have to delete either "config.rpgsave" or "global.rpgsave".
I can't tell you which one to delete since I deleted both of them, so maybe you should too.

Don't worry, the files will be restored when you save in the game again. The only thing that happened to me is that the options in the game (like the sound-volumes) are reverted to default, which shouldn't be a problem as you can just put them back to what you want afterwards.
I did it but it didn't solve the problem. Maybe I should change the name of the icon? Is it possible?
 

Alador

The Mage of Mythix
Veteran
Joined
Apr 16, 2020
Messages
155
Reaction score
121
First Language
English
Primarily Uses
RMMV
I did it but it didn't solve the problem. Maybe I should change the name of the icon? Is it possible?
I don't think that's something you can do, sadly... I'm pretty sure RPG Maker is hard-coded to only use "icon.png" as it's icon...
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
I don't think that's something you can do, sadly... I'm pretty sure RPG Maker is hard-coded to only use "icon.png" as it's icon...
Oh, ok :')
 

ScorchedGround

Blizzards most disappointed fan
Veteran
Joined
Apr 12, 2020
Messages
328
Reaction score
472
First Language
German
Primarily Uses
RMMV
Well I am really sorry then. I don't know what else to do since I am pretty sure this worked for me.

You could try deleting the entire "save" folder and look if it works then.
Just like before, if you start your game and save it, the folder will reappear.
Other than that, I have no idea how to fix that.
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
Well I am really sorry then. I don't know what else to do since I am pretty sure this worked for me.

You could try deleting the entire "save" folder and look if it works then.
Just like before, if you start your game and save it, the folder will reappear.
Other than that, I have no idea how to fix that.
I guess I'll just accept that this game is going to have the default icon :kaocry:
The next time I should make a git so I can just restore a previous version if something bad happens.
Thanks for the help anyways, it did help me.
 

Alador

The Mage of Mythix
Veteran
Joined
Apr 16, 2020
Messages
155
Reaction score
121
First Language
English
Primarily Uses
RMMV
I guess I'll just accept that this game is going to have the default icon :kaocry:
The next time I should make a git so I can just restore a previous version if something bad happens.
Thanks for the help anyways, it did help me.
Not necessarily. If it doesn't break anything, when the game is deployed, you can manually go into the files and change the icon in there, that'll make it permanent! I think Driftwood has a tutorial about it...
 

Jess_Andz

Estaba mu rico el capuccino (っ˘ڡ˘ς)
Member
Joined
Mar 26, 2020
Messages
16
Reaction score
1
First Language
Español.
Primarily Uses
RMMV
Not necessarily. If it doesn't break anything, when the game is deployed, you can manually go into the files and change the icon in there, that'll make it permanent! I think Driftwood has a tutorial about it...
Oh, ok! I'll try it when I make the build. Thanks, I'll tell you if it works or not :D
 

Users Who Are Viewing This Thread (Users: 0, Guests: 2)

Latest Threads

Latest Profile Posts

being able to transition music seamlessly is amazing. my main character's theme has lyrics and it goes from vocal version to istrumental when he leaves his room. and vice versa. and thanks to a plugin, the transition is seamless. I love it.
All of the auditions for our game are so good, I'm so glad I'm not in charge of choosing completely. lol I just can't with some of them. I listen to them on repeat. XD
Working on a Patch to integrate AlphaABS into random generated Dungeons. Was a bit tricky, but the outcome is a real Life Changer!!

Will release it the next days!
Been pretty busy... but I got a better headset for recording and listening today. Dad says that he'll consider taking me to Great Wolf Lodge for the first time once I finish summer classes (my final semester!) I'll be taking my plushie friends with me: Bendy, Lolbit, and Helen Henny. (I WUV PLUSHIES!)
SF_Monster3,4 added!

Forum statistics

Threads
105,651
Messages
1,015,304
Members
137,327
Latest member
Mezzy
Top