Tiled Plugin (Demo for RMMV 1.3.0+ Released)

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,918
Reaction score
15,111
First Language
Filipino
Primarily Uses
VNM
I don't mean the problem with newer Tiled versions.
I mean this error with the YED_Tiled version 1.30

rpg_managers.js:1949 TypeError: properties.find is not a function
at getProperty (YED_Tiled.js:1200)
at Game_Map._setupCollisionFull (YED_Tiled.js:1393)
at Game_Map._setupCollision (YED_Tiled.js:1368)
at Game_Map._setupTiled (YED_Tiled.js:1277)
at Game_Map.setup (YED_Tiled.js:1258)
at Game_Player.performTransfer (rpg_objects.js:7480)
at Scene_Map.onMapLoaded (rpg_scenes.js:569)
at Scene_Map.isReady (rpg_scenes.js:561)
at Function.SceneManager.updateScene (rpg_managers.js:2018)
at Function.SceneManager.updateMain (rpg_managers.js:1983)

But with version 1.20 it works fine. Thank you.
Don't use it. As mentioned somewhere in this thread, it's a BETA plugin. I'm not supporting it anymore.
 

Simientes

Villager
Member
Joined
Dec 18, 2019
Messages
16
Reaction score
2
First Language
Spanish
Primarily Uses
RMMV
Hi, quick question:

it is possible to map using isometric orientation?

I've failed a lot trying to figure out how to
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,918
Reaction score
15,111
First Language
Filipino
Primarily Uses
VNM
Hi, quick question:

it is possible to map using isometric orientation?

I've failed a lot trying to figure out how to

Short answer: not really
Long answer:
 

Kaligath

Villager
Member
Joined
May 13, 2019
Messages
27
Reaction score
8
First Language
English
Primarily Uses
RMMV
I cant seem to get this to work properly i must be doing something seriously wrong where to start with the issues i currently am plagued with.

1. I cant seem to get collisions to work i've tried multiple ways but i feel as if i am not doing something correctly when i place it on the tileD editor when i play test the collision are not appearing and my character can run around the map as if nothing blocks him.

2.my characters go over a tile when i set a tile zIndex to be above the person so he appears under the tile.

Been at it for almost 3 hours cant seem to fix it...
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,918
Reaction score
15,111
First Language
Filipino
Primarily Uses
VNM
I cant seem to get this to work properly i must be doing something seriously wrong where to start with the issues i currently am plagued with.

1. I cant seem to get collisions to work i've tried multiple ways but i feel as if i am not doing something correctly when i place it on the tileD editor when i play test the collision are not appearing and my character can run around the map as if nothing blocks him.

2.my characters go over a tile when i set a tile zIndex to be above the person so he appears under the tile.

Been at it for almost 3 hours cant seem to fix it...
It means you're using the wrong version of Tiled. We wrote the specific version you have to use in the topic.
 

Kaligath

Villager
Member
Joined
May 13, 2019
Messages
27
Reaction score
8
First Language
English
Primarily Uses
RMMV
ah fair enough thank you for the reply archeia.
 

Featherbrain

Villager
Member
Joined
Jan 12, 2020
Messages
18
Reaction score
10
First Language
English
Primarily Uses
RMMV
I'm just digging into TileD mapping but this seems like an awesome plugin. I apologize if this is already answered elsewhere, but is there a way to handle vehicles, particularly boats, in TileD? Is there a way to identify tiles in TileD as "water" for boat pathfinding/collision purposes? I can set up and use a boat event but it only recognizes the water tiles as placed in the RMMV editor.
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,918
Reaction score
15,111
First Language
Filipino
Primarily Uses
VNM
I'm just digging into TileD mapping but this seems like an awesome plugin. I apologize if this is already answered elsewhere, but is there a way to handle vehicles, particularly boats, in TileD? Is there a way to identify tiles in TileD as "water" for boat pathfinding/collision purposes? I can set up and use a boat event but it only recognizes the water tiles as placed in the RMMV editor.
This plugin doesn't have terrains so you have to use a scripts that allows regions to act like vehicle terrains.
 

Featherbrain

Villager
Member
Joined
Jan 12, 2020
Messages
18
Reaction score
10
First Language
English
Primarily Uses
RMMV
Hello, back again... Thanks for your previous response, using a region script for the vehicles works fine.

Now I'm having an issue with animated tiles, particularly animated tiles that use different animation speeds--is that supported by this plugin?

Here's the issue. I'm using two separate tilesheets, one with the water itself and one with the waterfall, both animated. The waterfall animations are set to 100ms, the water animations are set to 350. The first image shows how they animate in TileD, which is how I'd like it to look. The second image is how it actually looks in RPG Maker. Apologies for the image quality, but hopefully you can see the circled tile from the water tilesheet behaves strangely in-game. It appears to be animating at the 100ms framerate like the waterfall tiles. It does this regardless of where it's placed (you can see another instance of the tile to the left behaving the same way). The second row of waterfall tiles also animates a little weirdly, but it's harder to notice here.

Map5json-Tiled-2020-07-08-19-59.gifRaptor-Revolt-Demo-2020-07-08-20.gif

I'm totally baffled; I've quadruple-checked the tileset animations, all the tiles are set properly to the appropriate framerate, etc. Tile sheets are less than 1024x1024.

The reason I ask whether separate animation speeds are a problem is because the only solution I've found for this is to set all animations in all tilesheets to the same framerate (e.g. 350). Then all the tiles animate properly at that speed. Of course, that gives me really fast water lapping, or really slow waterfalls, but... if it is just a compatibility issue at least I could stop pulling my hair out over it.

If different animation speeds are supported, any idea what I'm doing wrong?
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,918
Reaction score
15,111
First Language
Filipino
Primarily Uses
VNM
Different Animation speeds shouldn't be a problem. It depends on how you implemented it though.
IIRC certain tiles are not rendered immediately animation wise if it's "off camera"
 

Featherbrain

Villager
Member
Joined
Jan 12, 2020
Messages
18
Reaction score
10
First Language
English
Primarily Uses
RMMV
Those tiles were indeed on a big map where they'd be "off camera" when the player enters the map; but I tried repositioning the tiles so that they would appear on-screen immediately, on two different maps, but that didn't seem to make a difference.

I also tried tripling the frames for the slower animation, e.g. every frame is 100ms long on all animations, but on the slower moving tiles there are three of each frame so it should approximate 300ms framerate. That didn't change anything either.

What finally seems to help is having all the animated tiles on the same tileset! Now that I did that it seems to work as expected. The only con to that solution is it implies a limit to the animated tiles I can use to what will fit in a single <1024 x 1024 tileset sheet, but I can probably live with that.
 

JagrySynz

Warper
Member
Joined
Dec 21, 2019
Messages
3
Reaction score
0
First Language
English
Primarily Uses
RMMV
I can get everything to run, but my map is always blank. I'm using default tilesets so I know their not too large and my collision checks out fine when I set it. I've tried to troubleshoot different ways and none have worked. I've also tried it with the Templates that come with the plugin and they also did not work.

I'm using both RMMV 1.6.1 and Tiled 1.0.3
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,918
Reaction score
15,111
First Language
Filipino
Primarily Uses
VNM
I can get everything to run, but my map is always blank. I'm using default tilesets so I know their not too large and my collision checks out fine when I set it. I've tried to troubleshoot different ways and none have worked. I've also tried it with the Templates that come with the plugin and they also did not work.

I'm using both RMMV 1.6.1 and Tiled 1.0.3
There's a sample project that should work.
 

JagrySynz

Warper
Member
Joined
Dec 21, 2019
Messages
3
Reaction score
0
First Language
English
Primarily Uses
RMMV
There's a sample project that should work.
The sample projects somehow works, but that doesn't help me with my game, unless your saying I should just edit that.
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,918
Reaction score
15,111
First Language
Filipino
Primarily Uses
VNM
The sample projects somehow works, but that doesn't help me with my game, unless your saying I should just edit that.
Compare what you're doing with your project and why it doesn't work?
I don't really have time to play tech support.
 

Ronove

♫꒰・‿・๑꒱
Veteran
Joined
Mar 12, 2012
Messages
1,043
Reaction score
354
First Language
English
Primarily Uses
RMMV
I know you're busy Archeia, but I was wondering if you've had problems when using the KEN_TiledFlagsLayer plugin. I've been noticing that the bush tile effect has been showing up where there is no flags layer in TileD at all. Only recently have I been able to replicate it consistently because it dawned on me what the issue might be.

What it seems to be is that when I move from Map A (which has some bush flags) to Map B (which does not), the game doesn't get rid of Map A's bush flags. I tested one of my maps with the flags and a copy of it without flags and it is a 1-on-1 match. I can "solve" the problem by giving the maps with no flag layer a flag layer and have a flag thrown off in a corner, but it seems a little silly to do that.

This does not occur if the KEN_TiledFlagsLayer is turned off.

Definitely not high priority! I can always go back to using regions since those do not have this issue. I just figured I'd mention what I found.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

Would you like a glass of spiders?
Besides my Might and Magic inspired project, I have always wanted to make a Fire Emblem-like game. Time is the culprit... Between life, composing music packs, and working on a game can it be done!? The tactical plugins for MV work quite well based on what I have tested.
Yaaay! My second public script is out and approved! A VX Ace Final Fantasy IX styled Throw Script!

I look forward to all the constructive feedback I get but most importantly I hope everyone who ends up using it enjoys!

Yaaaay! Making scripts is fun lol. :D
When you're lost out therrrrre and you're alllll alone, ahwahwah waitin, to carry you hooooommmme, uhhheverywhere you look! (someone hit me with those backing vocals)
X.X cant focus... too many thing want do... help!

Forum statistics

Threads
100,528
Messages
976,856
Members
132,081
Latest member
Kaezyelnatz
Top