Status
Not open for further replies.

Lucas7eixeira

Villager
Member
Joined
May 1, 2019
Messages
24
Reaction score
3
First Language
portuguese
Primarily Uses
RMMV
Hi everyone and thx in advance for anyone who try to help me! :)
So im developing a game with a time/weather/season system and i need a common event to :
1º - See if im on a external or internal map, if im at internal it stops every tint/weather effects, if not it does the next steps.
2º - Tint the screen to give a night/day look.
3º - Based on season, weather effects are triggered hourly (in game time, not real. I've made a common event to measure time/day/season/year).

Now, the problem... when tint+weather effects are on, the game lags A LOT and after a few seconds it crashes.
My RPGmaker is in portuguese so i dont know if a print will help, but here it is:
Sem título.png
Sem título1.png
I have a Ryzen 5 2400G with 4GB ram and SSD, so I dont think it's a spec issue...
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,305
Reaction score
11,735
First Language
English
Primarily Uses
RMVXA
Just an initial thought - do you have any Wait commands in there? If not, that parallel process is trying to run 60 times a second. Does it need to do that? Try putting a Wait command at the end - even a Wait of 10 frames could make all the difference.
 

Lucas7eixeira

Villager
Member
Joined
May 1, 2019
Messages
24
Reaction score
3
First Language
portuguese
Primarily Uses
RMMV
Just an initial thought - do you have any Wait commands in there? If not, that parallel process is trying to run 60 times a second. Does it need to do that? Try putting a Wait command at the end - even a Wait of 10 frames could make all the difference.
thx, although it still lagging a little, it worked. It was unplayable now its just a little annoying frame drop... :D
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,305
Reaction score
11,735
First Language
English
Primarily Uses
RMVXA
Try a wait of 15 and see if that is any better.
 

Lucas7eixeira

Villager
Member
Joined
May 1, 2019
Messages
24
Reaction score
3
First Language
portuguese
Primarily Uses
RMMV
even if i set it to 60frames it was still happening, found out (with a little help lol) that my AV was causing that lag, now with it disabled or with the playtest executable in the "trusted list" it runs smooth 60FPS! :)
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,305
Reaction score
11,735
First Language
English
Primarily Uses
RMVXA
@Lucas7eixeira Glad it's all running well now. However, it was useful that you had this problem because you've now been alerted to the need to have Wait commands in a parallel process.

If this has fully resolved your query, please Report your post and ask for the thread to be closed.
Thanks.
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
8,385
Reaction score
5,540
First Language
Dutch
Primarily Uses
RMXP

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

After gathering, sorting out & reconsidering hundreds of enemy battlers over the last two das, finally my favorite part begins: Inventing names and lore for them all :D
I'm running a sale for Learn RPG Maker MV on Itch.io, can I compete with NSFW games earning goals?
Another Friday and another Zoom call that could have been an email. Working from home is awesome.
Finished with the semester; finally have some time to play around with MV :kaopride:
Started work on the fishing Mini-Game

Forum statistics

Threads
111,364
Messages
1,060,517
Members
144,694
Latest member
Azel2
Top