Tired of your full screen looking stretchy

Pie4aPie

Developer/Artist
Veteran
Joined
Jan 10, 2013
Messages
65
Reaction score
6
First Language
English
We have all struggled with the fact that the max resolution for an RPG Maker game is 640x480. With wide screen monitors the biggest issue is that it gets all stretchy when you play in full screen.

This may have been discussed before, but I could not find this solution from searching these forums. Well I am here to help you solve this little problem. If you have an nVidia or ATI/AMD video card (you can even do it with onboard Intel Graphics). You can simply force it to maintain the aspect ratio and it will put the black bars on the screen sides and maintain the correct ratio of your game.

The trick is in the scaling options. You must choose "Maintain Aspect Ratio". This keeps the native resolution intact, but when you run RPG Maker games in fullscreen, it actually changes your screen resolution to meet that of your game.

With an Nvidia card, you are going to need to open the Nvidia Control Panel and select the "Adjust Desktop Size and Position" option from the left.

Once selected, you will simply need to choose the option on the right under "Scaling Mode:" for "Aspect Ratio". A similar process applies to the other types of video cards.

See screenie for Nvidia

nvidia_zps27ffbc6d.png
and for ATI

ATI_zps44149aac.png
Can also been done with onboard intel HD graphics (just select "Maintain Aspect Ratio")

intel_zps090e9bb5.png
..and Voila' no more stretched out fullscreen graphics.
 

Engr. Adiktuzmiko

Chemical Engineer, Game Developer, Using BlinkBoy'
Veteran
Joined
May 15, 2012
Messages
14,682
Reaction score
3,006
First Language
Tagalog
Primarily Uses
RMVXA
That is for stretching due to the screen being on widescreen aspect ratio which is 16:9 as opposed to the old 4:3 standard... I actually hope you found a way to actually remove stretching, coz it still looks stretched anyways when fullscreen... :)
 

Pie4aPie

Developer/Artist
Veteran
Joined
Jan 10, 2013
Messages
65
Reaction score
6
First Language
English
If you have the video settings to maintain aspect ratios configured correctly, you should not experience any strecthing at all in full screen. It will just add the black bars to whichever side(s) are out of ratio. If you are talking about maintaining aspect during full screen scaling, then that will not be possible in RPG Maker until the software allows for multi-resolution video output.

Maybe in the next version *fingers crossed*
 

Engr. Adiktuzmiko

Chemical Engineer, Game Developer, Using BlinkBoy'
Veteran
Joined
May 15, 2012
Messages
14,682
Reaction score
3,006
First Language
Tagalog
Primarily Uses
RMVXA
They do stretch for me, non-Widescreen monitor... I don't mean the widescreen type of stretch, but the normal stretching that happens when a lower resolution object is shown on a higher resolution screen in FS mode...
 

Latest Threads

Latest Posts

Latest Profile Posts

would i get in trouble if i didn't take out the computer icons on my fake computer screen i had Discord, Messanger, and rpg maker up
Auto-Adjust Text Outline, Run Common Events on Transfer | RPG Maker News #111

I sweep the floor. My brother, "You didn't do a good job. There are dust bunnies everywhere." He sweeps the floor weeks later. "I just swept. Why are there dust bunnies everywhere?" Me," Guess you didn't do a good enough job."
Today, I tortured my internet by downloading 20 files at once and then I played a guessing game as to which would finish their download first :kaojoy:
Oh god, just watched HawkZombie's stream of my game and realised that *none* of the branching scenes work properly. One has no character graphic, one soft locks due to a passability issue, and one doesn't have its autorun set to the right trigger. I've got first prize in the bag, baby.

Forum statistics

Threads
113,791
Messages
1,077,510
Members
147,837
Latest member
Fenrir_
Top