Trouble importing custom sound effects. Can anyone please help me?

Discussion in 'RPG Maker MV' started by jjbones123, Jun 12, 2017.

Thread Status:
Not open for further replies.
  1. jjbones123

    jjbones123 Veteran Veteran

    Messages:
    54
    Likes Received:
    29
    First Language:
    English
    Primarily Uses:
    N/A
    I'm making a new project in RPG maker MV and was surprised to find out that MV doesn't support Mp3 files when the previous version of RPG maker (VX Ace) did.

    I've tried deleting the Mp3 file and importing it again but that didn't work. I even tried converting the Mp3 file to a .Ogg or M4A, but that didn't work either. The problem is I put the sound effect file (the Mp3) in my audio/se resources folder and no matter what name I give it or what file type I convert it to, it doesn't appear in the list of sound effects when I try to assign the sound effect to an event.

    Does anyone know why this is or can anyone help me?
     
    #1
  2. djDarkX

    djDarkX Retro & Remastered Music Guru Veteran

    Messages:
    2,699
    Likes Received:
    1,887
    Location:
    Currently unsure...
    First Language:
    Music
    Primarily Uses:
    RMMV
    That's odd. When you say convert, did you actually convert them using an audio editor like Audacity or did you just rename the files? If they were actually re-encoded to the new formats, they should appear and work since OGG and M4A are fully supported. MP3 is not due to licensing issues at the time and MP3 not fully being supported I think either with the PIXI.js engine, the Node.js framework or certain browsers.

    If you just renamed the extension, that won't work. You actually need to re-encode them in an audio editor. If you did, then that really is strange.
     
    #2
    jjbones123 likes this.
  3. Ms Littlefish

    Ms Littlefish Dangerously Caffeinated Global Mod

    Messages:
    6,431
    Likes Received:
    8,139
    Location:
    Detroit
    First Language:
    English
    Primarily Uses:
    RMMV
    Have you converted the files using software or by renaming the extension? Have you tried importing to a new project file? Also, are you importing an .ogg and a .m4a together? I think (...think) that .m4as have to be uploaded with a .ogg to show up in the resource directory.

    Edit: Ninja'd by @djDarkX
     
    #3
    jjbones123 and djDarkX like this.
  4. Andar

    Andar Veteran Veteran

    Messages:
    28,613
    Likes Received:
    6,568
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    The editor uses OGG format on the PC, so you'll always need that format.
    M4A is needed for some deployment options, because some mobile devices do not support OGG formats - but M4A alone will not be detected because the editor needs the OGG files for local play.

    So for full deployment options, both formats need to be available. If you're only working on a PC, then OGG is enough.

    EDIT:
    additionally, file access can be blocked if the directory path to that folder or the filename itself contains letters or symbols that are illegal under networking rules - and that includes spaces.
    So a file "song x by y.ogg" will never be usable, you'll need to rename it into "song_x_by_y.ogg"
     
    #4
    jjbones123 likes this.
  5. jjbones123

    jjbones123 Veteran Veteran

    Messages:
    54
    Likes Received:
    29
    First Language:
    English
    Primarily Uses:
    N/A
    @Andar
    Ah! that's what I was doing wrong. I removed the spaces from the name of the file and converted it from MP3 to OGG and it works. Thanks! :)

    To those wondering, I had tried both simply renaming the file (.ogg at the end instead of .mp3) and converting it using A.V.C; any video converter. As long as you don't have any spaces in the name of the files, it should work either way.

    Thank you for the help! :D
     
    #5
    djDarkX likes this.
  6. Ms Littlefish

    Ms Littlefish Dangerously Caffeinated Global Mod

    Messages:
    6,431
    Likes Received:
    8,139
    Location:
    Detroit
    First Language:
    English
    Primarily Uses:
    RMMV
    Awesome. Sounds like it's all peachy now! :)

    This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

     
    #6
    jjbones123 likes this.
Thread Status:
Not open for further replies.

Share This Page