Rigor Mortex

Mankind's Mirror
Veteran
Joined
Mar 14, 2012
Messages
65
Reaction score
4
First Language
English
Primarily Uses
Following a tutorial, I edited a song I've had for a while as a test run for looping (the attached file is the result) in Audacity. I did everything as instructed, and to the letter as far as I can tell. However, testing the song in MV, it plays up until a certain point I'm assuming is where I had set up the loop to begin, and then decides to start the song over. Testing it in VX Ace, I find that it works as I wanted it to and the tutorial suggested.


I got the edited rpg_core.js from here, and using F8 in MV playtesting states that LOOPSTART is set to 0, even though I know that I had set it to 2690779. Something is screwy, here, and it's really bothering me - especially since checking the track "Field1" shows its metadata for LOOPSTART is a value over 0. This should be working - what exactly am I doing wrong, if anything?


Removed the file. Wasn't aware of that rule for some reason.
 
Last edited by a moderator:

Arisa

probably dead
Veteran
Joined
Mar 6, 2016
Messages
490
Reaction score
1,749
First Language
English/Spanish
Primarily Uses
RMVXA
Hmm, could you like take the MV file (DO NOT DEPLOY!!!) And put it on Mediafire or something.
 
Last edited by a moderator:

djDarkX

Retro & Remastered Music Guru
Veteran
Joined
Jan 17, 2013
Messages
2,701
Reaction score
1,917
First Language
Music
Primarily Uses
RMMV
Tested the music myself in XMPlay using the OGG plugin to check the looping and it worked perfectly, but in MV it got to a certain time and would then loop back.  So, I removed the extra meta data and it worked perfectly.  When editing the metadata, removed the extra comments except for the LOOPSTART and LOOPLENGTH tags.  Also, restore your rpg_core.js to ensure it'll be working properly.


EDIT:


Side note, remove that music.  It's copyrighted music and it's not allowed to be posted here.  Just a heads up.
 
Last edited by a moderator:

Rigor Mortex

Mankind's Mirror
Veteran
Joined
Mar 14, 2012
Messages
65
Reaction score
4
First Language
English
Primarily Uses
Tested the music myself in XMPlay using the OGG plugin to check the looping and it worked perfectly, but in MV it got to a certain time and would then loop back.  So, I removed the extra meta data and it worked perfectly.  When editing the metadata, removed the extra comments except for the LOOPSTART and LOOPLENGTH tags.  Also, restore your rpg_core.js to ensure it'll be working properly.


EDIT:


Side note, remove that music.  It's copyrighted music and it's not allowed to be posted here.  Just a heads up.

Noted, removed the song.


Also feel really stupid for not considering that any metadata tags except the ones you're supposed to add may screw up looping (even if VX Ace didn't seem to care). This thread can be marked as resolved now.
 

djDarkX

Retro & Remastered Music Guru
Veteran
Joined
Jan 17, 2013
Messages
2,701
Reaction score
1,917
First Language
Music
Primarily Uses
RMMV
Happens to the best of us.  Glad I was able to help and good luck!
 

Latest Threads

Latest Posts

Latest Profile Posts

Custom sleep sequence done! :kaopride:
fuY8hyg.gif
The other day I posted a merchant airship tileset and said it was overflow from my Advent Calendar. @Avery said something like "that's one way to flex!" Well, this morning I woke up and realized THAT I MISCOUNTED AND AM SHORT BY ONE DAY. My face and palm are now perfectly fused together.
Shin Megami Tensei V is really fun... and the music is sooo good.
*Saw a video of myself*
*Opens google*
*Search "How to delete my personality"*
Me: "I should make a quick prototype of my system to test early"
Also me: "Eh, drawing the character is more fun than actually making the game"
FFhEfyfUcAMOLjF

Forum statistics

Threads
117,100
Messages
1,104,584
Members
153,118
Latest member
dedepece
Top