Trouble with sumrndm auto-updater Plugin

CorpseFather

Veteran
Veteran
Joined
Aug 5, 2018
Messages
30
Reaction score
5
First Language
English
Primarily Uses
RMMV
This is the error I get, does anyone have an idea what it could be?
 

Attachments

Oddball

Veteran
Veteran
Joined
Sep 4, 2014
Messages
1,883
Reaction score
521
First Language
English
Primarily Uses
N/A
Are the scripts clashing? I noticed multipule scripts on that list. Try testing them individually by turning off plugins as you need. If you still get errors, someone with scripting knowlage should handle this (I have none)
 

Poryg

Dark Lord of the Castle of Javascreeps
Veteran
Joined
Mar 23, 2017
Messages
4,122
Reaction score
10,613
First Language
Czech
Primarily Uses
RMMV
SumRndmDde's plugin is not mentioned in this call stack, so I'm not exactly sure that would be the problem. My guess would be either wrong plugin order or plugin incompatibilities. But for that we'd need to see the list of plugins your game has.

Also, it may not be of use to use SRD's auto updater anymore. SRD has left the community 2 years ago, so updates are quite unlikely.
 

CorpseFather

Veteran
Veteran
Joined
Aug 5, 2018
Messages
30
Reaction score
5
First Language
English
Primarily Uses
RMMV
Is there another plugin to use for an updater like that?
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,930
Reaction score
13,567
First Language
English
Primarily Uses
RMMV
you could just do it manually.

Auto updating is risky anyway. Latest plugins are usually for the latest version of the engine. Unless you want to manually update your project and all the plugins every time there's a new release, and go through the hassles of looking for incompatibilities, you're better off getting a stable version and sticking with it (and the versions of the plugin for that version of the engine).

SRD, in fact, has some plugins that are not compatible with the latest version of MV.
 

Poryg

Dark Lord of the Castle of Javascreeps
Veteran
Joined
Mar 23, 2017
Messages
4,122
Reaction score
10,613
First Language
Czech
Primarily Uses
RMMV
@Shaz the autoupdater is a plugin that serves for updates to the game when you make a new version of it, not to automatically update plugins etc. It's risky anyway though, because: Updating actors.json requires new game without question. Updating classes requires new game. Updating of a map requires a new game (adding a map does not). Deleting an item or equip in the database requires new game. Change in these may or may not require a new game, that depends on the consistency of the files. And the plugin is incapable of telling when it breaks saves and when it does not.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,930
Reaction score
13,567
First Language
English
Primarily Uses
RMMV
ah, I thought it was to update plugins. Forget everything I said then.

In that case I don't think it's got anything to do with the updater, but is probably an existing bug in the game that you just haven't encountered until now.

What were you doing immediately before the error occurred?
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Lots of cool changes for Battle Castle in the works! Not just reworked dialogue, but gameplay, combat, and possibly lore changes to make things weightier.
Actor2_2 added!

I started really going in on my project April of last year... I'm just now making starting the actual game... making assets (and not even all of them), whoooo... TIME SINK.


Imagine being a pleb and using --------------------.js :LZSwink:

Forum statistics

Threads
102,946
Messages
996,198
Members
134,410
Latest member
Kylion_Shadowwolf
Top