Status
Not open for further replies.

kiyasu

Professional Illustrator and Character Designer
Veteran
Joined
Aug 19, 2020
Messages
61
Reaction score
250
First Language
maybe English?
Primarily Uses
RMVXA
How to activate RPG Maker for earlier browser versions and OS (operating systems)

Written by Kiyasu Oka (@kiyasu) in December 2020.

kiyasu_tutorial_01.jpg
kiyasu_tutorial_06.jpg

NOTE: This tutorial is written and posted with consent from both @Archeia and @Wavelength. While this tutorial uses 32-bit Microsoft® Windows® XP and RPG Maker® VX Ace as demonstration, it also applies to RPG Maker® MV. This includes other operating systems (OS) such as Windows® Vista and Windows® 7. I only have the license for RPG Maker® VX Ace, RPG Maker® MV, and RPG Maker® MZ, but I am quite confident that the reasoning in this tutorial will also apply to other software such as RPG Maker® VX and RPG Maker® XP. In fact, I think this tutorial might even apply to other Degica products such as Visual Novel Maker, but this I have not confirmed myself!

This tutorial is aimed at Windows® computers because it seems that, for Macintosh® ("Mac®"), RPG Maker® products are ONLY for
Steam® and no standalone download. So, as long as your computer can open up Steam® properly, you probably won't have any activation problems. Steam® doesn't work on my 32-bit Windows® XP computer. Maybe there are be people out there who figured out ways to make Steam® work on 32-bit Windows® XP, but at least I don't know how to achieve this myself. However, even if this is a tutorial for Windows® computers, I am confident that this tutorial will most likely still have reasoning and logic that matches that of a Macintosh® ("Mac®")... at least if not for RPG Maker® products, then maybe some other products (Degica or not) you buy!

While you might can use Steam® on a Windows® computer, especially if your computer is capable of running software like RPG Maker® MV and RPG Maker® MZ, you might not like Steam® at all (or at least you don't want anything to do with it). Like me, I don't like the way Steam® does things, and I don't like the idea of having RPG Maker® (or any other game) be "a part of" Steam®, and with all that "how long I played this for" thing recording my time usage. I never really liked the idea of Steam® and I like standalone things here.

----------------------------------------------

Have you tried to activate your purchase of RPG Maker® software, all to find that you cannot activate it? Either you are directly taken to a "The page cannot be displayed" page, or a "Resource Not Found" message pops up before taking you to that page!

In this tutorial, I am going to tell you directly why this happens and teach you how to solve it. I will also tell you how to contact Technical Support ("Tech Support") to receive a Offline Manual Unlock code.


Why this activation problem happens (and things to know):

(This is assuming you made sure that things like Windows® Defender, Firewall, and Antivirus are not affecting this. Please turn off these kinds of things and test your activation. If after this, you still have the same problem, then I can quite confident the reason is most likely related to what I am going to tell you in this tutorial.)​

1. If you experience the "Page cannot be displayed" problem and/or "Resource Not Found" during activation, the simple answer is most likely that your version of Internet Explorer® doesn't have TLS 1.2 enabled. (The activation servers for RPG Maker products updated to requiring at least TLS 1.2 in order activate your product. The original thread where members of this forum talked about TLS 1.2 and potential workaround methods, including proxy addresses and some other solutions can be found here: Activation issues. You might can learn more details about various details of this issue there, but at the time of writing this, that thread is at least 8 pages long! I found that I had problem going through all those pages of reading and in the end still didn't have a clear solution, so I felt this tutorial is needed instead!)

2. Even if your default browser is set to, for example, Firefox®, the activation for RPG Maker® still uses Internet Explorer®. So, it doesn't matter if your Firefox® version has TLS 1.2 enabled; what matters is whether or not your Internet Explorer® version has it!

3. TLS 1.2 is an updated security feature. If it is not listed in the Internet Options > Advanced, then the Windows® version you are using is probably from a time before it was developed.
(It might be that all you need to do is simply upgrade your version of Internet Explorer® to a later version to have TLS 1.2 enabled, but for my case, this was not possible for my 32-bit Windows® XP computer, even after upgrading my IE version.)

kiyasu_tutorial_02.jpg
kiyasu_tutorial_03.jpg

From this "Enable TLS 1.2 in Internet Explorer 8, 9 or 10" page, here is some information about TLS 1.2:

kiyasu_tutorial_07.jpg
(I am not sure how accurate the information in the table above is, but thought to include it regardless!)

... And of course, there is no way (at least I don't know of any way) I could upgrade my browser version to Internet Explorer® 11 on my 32-bit Windows® XP computer! (Here is a link to a Internet Explorer® 11 (32-Bit) download page from the Microsoft® official site.)

Therefore, in order to activate your product, you either have to:

1) Use Offline Manual Unlock, or;

2) somehow figure out a way to get TLS 1.2 enabled, most likely through some "tricks."
(Note: This might be quite advanced and at the time of writing this, I have not tried this myself. However, if you still want to know or try, here is a link to a page called "Enable TLS 1.2 Encryption on Windows XP/2008/7/Windows 2008 R2," where people offered potential solutions to enable TLS 1.2. I also found this other page relating to TLS 1.2 but I don't quite understand it: "Enable TLS 1.1 and 1.2 in Windows XP correctly." And lastly, there is that "Enable TLS 1.2 in Internet Explorer 8, 9 or 10" page linked above.)

How to activate your product through Offline Manual Unlock:

kiyasu_tutorial_04.jpg
[the activation screen in Internet Explorer® 8 on 32-bit Windows® XP]

Activating your product through the Offline Manual Unlock option might seem quite obvious from the image above. However, this was NOT the case with my 32-bit Microsoft® Windows® XP computer here, as you can see from the image below:

kiyasu_tutorial_05.jpg
[the activation screen in Internet Explorer® 6 on 32-bit Windows® XP]

The problem above is that the Offline Manual Unlock link is NOT on the screen, and you might have tried to expand the window to hopefully see the "full page" of the screen. However, what happens is that the rest of the "page" is fully a black background. If enabling TLS 1.2 is not possible, this looks like a dead end!

kiyasu_tutorial_06.jpg

Upgrading or downgrading Firefox® versions is as easy as "download file -> launch file." However, this doesn't seem to be the case with Internet Explorer®. Manually upgrading or downgrading Internet Explorer® versions was something I never really directly did in my life, and the process doesn't look as straightforward as Firefox®. For Firefox®, all I need to do is either download an earlier or later version from here or download an earlier or later version from the Firefox® section at oldversion.com. (Oldversion.com is a site founded by my friend Alexander Levine in 2001, and has a long history, and I trust it.) But with Internet Explorer®, I was not exactly sure how to upgrade and downgrade...

So, what are you to do if you also have this dead end like mine? Well, how I managed to get the Offline Manual Unlock link to show up was by upgrading my version of Internet Explorer®, even after a failed installation attempt with IE8 and then another failed attempt with IE7 installation.

I am not exactly sure myself, but maybe for some people, it might sound like upgrading from Internet Explorer® 6 to Internet Explorer® 8 on 32-bit Windows® XP is some kind of impossible task, but I tried again with another download link for IE8, and it finally worked:

I just downloaded Internet Explorer 8 (IE8-WindowsXP-x86-ENU.exe) at https://www.manageengine.com/produc...ent_install_Internet-Explorer-8---32-bit.html (<-- again, no guarantees about the safety of this link or download, so please proceed with caution), and it successfully installed!! While this didn't fix the TLS 1.2 issue, it DID something miracle enough for me: the VX Ace activation window changed, and now one can finally see a "Offline Manual Unlock" option at the bottom left of the screen. Previously with Internet Explorer 6, the bottom is cut off... even when I try to stretch out the window (the cut-off parts would just be black background if you stretch or widen the window).
(Quoted from this post of mine on Page 8 of the "Activation issues" thread.)

NOTE: Even though the version I successfully installed is Internet Explorer® 8, I am quite confident that all you actually need is at least Internet Explorer® 7 for the Offline Manual Unlock link to finally show itself. IE7 and IE8 are a part of the same logo "series" below, and a part of the "same era":

kiyasu_tutorial_06.jpg

If you are uneasy about the download link for IE8 above, please try my friend Alex's oldversion.com site for various Internet Explorer versions downloads. I didn't try any of the downloads from my friend's site because I didn't realize I could go there until after I have solved the activation issue (silly me!). If any of the downloads don't work, then you might have to try that IE8 download link (<-- again, no guarantees about the safety of this link or download, but I installed this successfully). And of course, if you want to try the Internet Explorer® 11 (32-Bit) download page from the Microsoft® official site, I am including the download link here for convenience.

How to receive your Unlock Code (key) for Offline Manual Unlock:

kiyasu_tutorial_08.jpg
"If you encounter problems with online activation, please send the information below to Customer Support HERE.
We will provide you with the information needed to activate on this page.
Email Address
Product Key
Computer ID: B0CF-6877"
If you have tried to click on the "HERE" link above, you might have noticed it linked you to a http://www.rpgmakerweb.com/support/tech URL, which is a broken link. So, now you need to find the form directly on the site yourself. Go to www.rpgmakerweb.com and scroll all the way down to the bottom of the page, until you see something like this:


kiyasu_tutorial_09.jpg

Click on the "Contact us" link which will lead you to www.rpgmakerweb.com/contact-us (at the time of writing this tutorial in December 2020).

kiyasu_tutorial_12.jpg

Make sure you select "Technical Support" and "Product Activation."

kiyasu_tutorial_13.jpg

I have quite a lot of experience with reaching out to Technical Support ("Tech Support") because of my various computers! In fact, it feels like I talked to Technical Support so much that I am SO familiar with the process for Offline Manual Unlock keys!! (I feel as though I might just be the most experienced person when it comes to anything related to Offline Manual Unlock!) Here is what you need to know: contact Technical Support with your e-mail address, product key, and the Computer ID displayed. HOWEVER, let me elaborate on this....

kiyasu_tutorial_14.jpg

E-mail address: I don't know whether this is absolutely required or not, but apparently you really need to give the Technical Support staff the e-mail address used at the time of purchase. So even if your current e-mail address for your www.rpgmakerweb.com account is already updated to a different e-mail address, the information you provide to the staff person in charge still MUST be the e-mail address you used before you updated your account information. (Once again, I don't know whether this is absolutely required, but if you are concerned about your previous e-mail address being used or something, you can briefly tell the staff person in charge that "My current e-mail address is X, but the e-mail registered in the purchase database is Y" instead.)

You can also find your receipt details by logging into your www.rpgmakerweb.com account . (Sometime in August 2020, around when RPG Maker® MZ got officially released, it seems you need to visit old.rpgmakerweb.com in order to log in to your account, if you made your purchase before the change. Can't seem to find the login page from the new www.rpgmakerweb.com site, and I am not sure whether purchase e-mails are the same for orders made after that!)

Also, you can ask Technical Support to re-send a copy of your receipt(s) to your current e-mail address, and it will be the exact same e-mail you received back then, except to your new address! The images below are re-send mails of my receipts:


kiyasu_tutorial_10.jpg
kiyasu_tutorial_11.jpg

Product Key: This should hopefully be obvious, but in case if it is not, the images above explains it. VX Ace keys are the same as your receipt's Order Number, while MV and MZ keys are different keys.

Computer ID: I don't know whether the Computer ID changes with, for example, a change of user, logging users off, or restarting your computer. However, there was one time when my Computer ID changed on my Windows® 7 computer. I sent an ID to Technical Support, and by the time she replied me with my Offline Manual Unlock code, I then open up RPG Maker® and found that the code doesn't work because the Computer ID has already changed! Then, I needed to request a new code with the new Computer ID. Technical Support also doesn't know the answer to whether the ID would change, but it might be better to be open to the possibility that your Computer ID might not stay the same. (For example, if you fill out the Contact form, then turn off your computer or "Log off," maybe, just maybe, the Computer ID might not be the same... maybe.)

Technical Support will most likely get back to you with an e-mail that looks something like this:

kiyasu_tutorial_15.jpg

In regular activation, it looks like it doesn't matter what you put for your e-mail address as long as your product key is correct. However, for the Offline Manual Unlock code, the e-mail address you put MUST match whatever the Technical Support staff gave you in the e-mail. (So, your Offline Manual Unlock code can use any e-mail address, even ones you never used before, as long as that is the e-mail the staff provides you with the unlock code.) In this example, if I use the Gmail address with the provided unlock code, I will NOT be able to activate my product. (That Gmail address will only work if that happens to be the one the staff person chooses to use for this activation "session.")

Lastly, here are the various computers I currently own:

... in case if you need me to test things (for example)... but you don't know anyone with the computers to do it for you! There is no guarantee I will "have time" to test things for you when you ask, but I want to be open to this here, just in case. I currently own these computers:

kiyasu_tutorial_16.jpg
I like to use this software called Speccy® (from Priform®) when it comes to needing VERY detailed computer details...

kiyasu_tutorial_17.jpg
[Start Menu > Run > type "dxdiag"] The dxdiag solution can also give you some computer details... but probably NOT as detailed as Speccy®!

kiyasu_tutorial_18.jpg

1. "Windows XP Professional 32-bit SP3," (Windows® 7 -> Windows® XP), 14.1'' screen, 1280x800 screen resolution, Intel Core i5 560M @ 2.67GHz (cores: 2, threads: 4), 4.00GB Dual-Channel DDR3 @ 531MHz (7-7-7-20), Plug and Play Monitor (1280x800@60Hz), 931GB Seagate ST1000LM024 HN-M101MBB (SATA), MATSHITA DVD+-RW UJ8A2, IDT High Definition Audio CODEC... This is my main computer for basically everything, and the one used for demonstration in this tutorial! Because this XP computer is actually a modified Windows® 7 computer, a part of me is thinking that it might can play people's MV games even if I cannot install MV software. However, I rarely play MV games, so I have never tried this yet.

2. "MS Windows XP Home 32-bit SP3," "1024x768 compressed" screen resolution (1024x768 fitting onto a screen that is supposed to display 1024x600), Intel Atom @ 1.66GHz, 1.0GB Single-Channel DDR2 (4-4-4-12), Mobile Intel(R) 945 Express Chipset Family, 156GB Seagate ST9160310AS (SATA), "No optical disk drives detected," Realtek High Definition Audio... This is a EeePC Netbook (one of those very small "laptops")... and RPG Maker VX Ace games seem to NEVER run at anything past around 38 FPS. I can still run VX Ace games "properly" here, but they seem to run from 2 FPS ~ 38 FPS, depending on the game. Some games stay around 25 FPS ~ 38 FPS, while other games might be different.

3. Windows® 7 (32-bit) Service Pack 1, (Windows® Vista -> Windows® 7), 15.4'' screen, 1280x800 screen resolution, Intel® Centrino Duo (Intel® Core™ 2 Duo CPU, T7300 @ 2.00GHz), 2.00 GB RAM... I can install and open RPG Maker® MV properly on this computer, but I basically cannot really PLAY any MV games... and the "playtest" button in MV won't work. So, I can open the editor software, but unlike the Windows® XP Atom® Netbook that actually CAN run VX Ace games (though all at low FPS), this Windows® 7 one cannot really run an MV game, hence sort of "impossible" to play them. This was my "main" computer for making and playing VX Ace games from August to recently... though a Ransomware incident happened in September this year...

4. Windows ® Vista (32-bit), 1280x800 screen resolution, a SONY VAIO laptop that has been my main and only computer for 12+ years until March 2020. Always stayed as Vista all these 12+ years since I bought in 2008. Not sure about the specs, and while this computer still works quite well, there is a screen incident in March 2020 and I sort of can't use it any more for that reason since then. Unless if I can figure out a way to successfully copy the screen to a TV, then it's kind of the same as that I can't use this computer any more.

5. Mac® OS X 10.11.6... This is my only laptop at home (at this time of writing this in December 2020) that can run RPG Maker® MV software. I also mainly use this laptop to play people's MV games. It has some screen issues, but this is easily solved by connecting it to my TV. I can "install" RPG Maker® MZ into Steam here, but I cannot run MZ at all! (It will tell me that I need a higher version of Mac® OS X in order to install RPG Maker® MZ!)

6. Windows® 10 (64-bit)... This is an ASUS one that I let my friend "borrow forever," and one that I sort of hardly used myself because I didn't want to use it (yet still want to keep it at the same time). So, at the time of writing this in December 2020, I can only use this laptop if I happen to be at my friend's house. This is, of course, the only laptop I own that can actually run RPG Maker® MZ. Of course, I use this to play MV games when I have the chance (especially if the MV game doesn't come with a Mac® version). For some reason, I never played any MZ games, and I'm not sure whether I ever will, but at least I don't think there will be any problem with MZ games on this computer.

Tutorial Conclusion:

NOTE: I avoid using the words like "old," "ancient," or "legacy" because, in my shoes, I feel it at least carries some kind of negative connotation, some kind of assumption that "older" things are so-called "less than," and so much more! And maybe there are others in the same shoes as me. Also, maybe to someone, things like Windows® XP is NOT "old" at all, and is just as new as if it came out yesterday... in a person's heart and soul. So I don't like it when people say these things are "old." The idea these things are "old" kind of makes me a bit uneasy :'( They are earlier versions, sure, but they are NEVER an "old" or "older" version!

I hope you find this tutorial helpful! I think Offline Manual Unlock is the best way to approach this situation, but if you want to attempt enabling TLS 1.2, it might have its benefits too. KADOKAWA and DEGICA probably cannot and do not want to support earlier OS (e.g. XP, Vista). This might be because it could carry a lot of issues from a developer and money standpoint. So, of course, it may be wise to be prepared to face potential problems if you run into "harder situations." This tutorial is here to alleviate it, and to let you know that you don't have anything to worry about. If you are someone who, by any chance, doesn't want to upgrade your browser version just to "conform to society" or "get things to work," I feel I can understand your feelings about the on-going discrimination towards "older" versions. What I would recommend is that you first upgrade your browser version, activate your product, then downgrade it back to the version you were using... this seems to be the only easier way here, and I am sorry for this answer. Oldversion.com is a good place to download versions for upgrading and downgrading, and the URL of its Internet Explorer® page is here: http://www.oldversion.com/windows/internet-explorer/

I want to thank @Archeia and @Wavelength for letting me write a tutorial like this! I hope you find it helpful even if you might not run into this issue yourself!

Thank you for reading!

~ Kiyasu
 
Last edited:

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,384
Reaction score
15,844
First Language
Filipino
Primarily Uses
RMMZ
This thread is stickied in Tech Support because it is related to our DRM and for people are using WinXP ~ Win7. It will be much easier to access from here than looking at tutorials section. Please do not report it being in the wrong section.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

Let's continue making our game in MZ! Touchfuzzy is... still eventing... though this time we may be working on eventing some tutorial stuff for our players!

I work late on the game so I sleep in then I wake up late so I have to work hard to make up for sleeping in meaning I work late again and sleep in again... what a nasty cycle.
I just had my first real fire. Dad made burgers for lunch and the grill caught fire. He tried to get water but I told him you should never put water on a grease fire. So I got him the fire extinguisher under the sink and we managed to put it out. I can still smell a little of the smoke coming from the patio, but at least it's clearing. It sure was scary though.
was rendering a video and window decided to bsod on me :D fun
Could not for the life of me figure out how to implement the dual/triple techs in Touch the Stars in a player-friendly way. Was describing all the problems to my wife and just rubber-ducked a solution that should work brilliantly.

Forum statistics

Threads
113,842
Messages
1,077,893
Members
147,912
Latest member
RasenNinja
Top