paeyo

Villager
Member
Joined
Dec 23, 2020
Messages
6
Reaction score
0
First Language
Spanish
Primarily Uses
RMMV
Greetings. I'd like to apologise beforehand, since English is not my mother tongue and I might misspell a couple of things, but I hope you will anyway understand the issue I'm about to expone.
I last used RPG Maker MV (OS X) back in April this year, 100% legal (Steam), and didn't come across this problem back then. But now, almost every time I testplay, the screen goes black and this error pops up out of nowhere.

Captura de Pantalla 2020-12-23 a les 0.41.13.png

I did some research and I learnt that I had to check the console, which I did, and I believe I (somehow) managed to identify the error.

Captura de Pantalla 2020-12-23 a les 14.49.57.png

If I click on rpg managers.js:1756, the following information appears:

Captura de Pantalla 2020-12-23 a les 14.55.13.png

Captura de Pantalla 2020-12-23 a les 14.55.22.png

I know nothing of programming, so I am clueless as for what should I do to fix it. I hope I have provided you with enough information. Thank you in advance.
 

caethyril

^_^
Veteran
Joined
Feb 21, 2018
Messages
2,470
Reaction score
1,863
First Language
EN
Primarily Uses
RMMZ
There's a Yanfly Core Engine error message shown there. Does this problem disappear if you turn off all plugins in the Plugin Manager, then save your project and test? If so, make sure your Yanfly plugins are up-to-date and in the recommended order, listed here:

If turning off all plugins doesn't fix the issue, you could try updating your editor to the latest version (if it isn't already) and making a new project to see if the problem occurs there.

Edit: oh, the Core Engine warning is literally part of the core scripts... :kaoswt:
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,853
Reaction score
8,236
First Language
German
Primarily Uses
RMMV
The code of the plugins doesn't matter at the moment, the error is about something else and the code just shows the place where the computer first detected that error.

Does that error happen if you start a new game, or if you load a saved game, or in both cases?
Because 80% of all cases type errors are due to loading incompatible old savegames.
 

paeyo

Villager
Member
Joined
Dec 23, 2020
Messages
6
Reaction score
0
First Language
Spanish
Primarily Uses
RMMV
There's a Yanfly Core Engine error message shown there. Does this problem disappear if you turn off all plugins in the Plugin Manager, then save your project and test?

I turned off all the plugins: didn't work
I updated all Yanfly plugins: didn't work
I uninstalled RPG Maker MV and installed it back again: didn't work

Does that error happen if you start a new game, or if you load a saved game, or in both cases?
Because 80% of all cases type errors are due to loading incompatible old savegames.

I created a new game from scratch: the error was still there

If turning off all plugins doesn't fix the issue, you could try updating your editor to the latest version (if it isn't already) and making a new project to see if the problem occurs there.

My RMMV's last update was the 10th of this December (v1.6.3)

_______________

My guess is that the issue is within the main (?) .js files:

Captura de Pantalla 2020-12-23 a les 17.55.32.png

Either that or macOS Big Sur messed it all up real bad somehow.
 

paeyo

Villager
Member
Joined
Dec 23, 2020
Messages
6
Reaction score
0
First Language
Spanish
Primarily Uses
RMMV
I'm also adding a screenshot with the scripts list in-game, just in case it may be of any help.

Captura de Pantalla 2020-12-23 a les 18.07.19.png
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,853
Reaction score
8,236
First Language
German
Primarily Uses
RMMV
My RMMV's last update was the 10th of this December (v1.6.3)
your editor version is current, but your project might have a different version.
to check the project version you'll need to open the project's rpg_core.js file with a text editor and check the title line for the version number.

scripts list in-game,
I'm reasonable sure that the last two plugins from yanfly are in the wrong order.
wrong order of plugins can cause errors, but in this case it is unlikely to be the specific cause as the error message doesn't fit either of those plugins.
This is just for the future when you get past that error.
 

paeyo

Villager
Member
Joined
Dec 23, 2020
Messages
6
Reaction score
0
First Language
Spanish
Primarily Uses
RMMV
I'm reasonable sure that the last two plugins from yanfly are in the wrong order.

Thank you, I will check that.

your editor version is current, but your project might have a different version.

Captura de Pantalla 2020-12-23 a les 20.24.35.png

For what I see, I'm guessing the version here should correspond to that of the program itself. If it is so, how can I update my project?
 

caethyril

^_^
Veteran
Joined
Feb 21, 2018
Messages
2,470
Reaction score
1,863
First Language
EN
Primarily Uses
RMMZ
Instructions for updating your project's core scripts can be found in this announcement, under "Updating your Projects":

If that doesn't help: did you try a new project after reinstalling? Given the errors, I'd suggest using the Community_Basic plugin (present in new projects by default) and setting its renderingMode parameter to canvas (default is auto). Canvas is a CPU-based fallback renderer that ignores the GPU. Save your project to apply plugin changes, then test.

If the game runs OK in canvas mode, then the problem is related to WebGL. That might just mean you need to update your graphics drivers, maybe the OS update reset them. Or it might be a deeper problem...a while back I think MacOS were planning to drop support for OpenGL? :kaoswt2:
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,853
Reaction score
8,236
First Language
German
Primarily Uses
RMMV
For what I see, I'm guessing the version here should correspond to that of the program itself.
not automatically - that's why the updates are not automatical.

the project version should fit the plugin versions used - sometimes you need to stay at older versions because one of the plugins you want was not updated.
But 1.3.x is extremely old - most yanfly plugins require at least 1.4.x to even work correctly.
 

paeyo

Villager
Member
Joined
Dec 23, 2020
Messages
6
Reaction score
0
First Language
Spanish
Primarily Uses
RMMV
I had the chance to try to run RMMV with the same project on Windows (using a different PC) and it works just fine, haven't had a single problem whatsoever. I have no doubt now that the problem itself was running the program on MacOS.

Thank you so much for your help, I really appreciate it.
Merry Christmas!
 

Latest Threads

Latest Posts

Latest Profile Posts

I hate doing voice over videos but people said they like hearing about the details.
Modern Town Overworld, World of Solaria Dungeon, 80's Retro-Futuristic Font | RPG Maker News #73

I been slowing down and not focusing on project currently.
I had this idea for VTubers vs MOTHER and its a bunch of Vtubers finding eight melodies to fight a psychic alien and a fat kid. IDK, kinda find it hard to use RPG Maker for more than 15 minutes
Working on some wizard/magic bases:
TestChara-10-hover.gif

I mean, technically it's a flying base but I haven't made any wings yet, so magic hovering is it for now.

Forum statistics

Threads
112,300
Messages
1,067,191
Members
145,929
Latest member
longga1996
Top