TypeError Cannot read property 'get' of undefined

Discussion in 'RPG Maker MV' started by ls9405, Apr 12, 2018.

  1. ls9405

    ls9405 Warper Member

    Messages:
    2
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    So, this is my first bug report. I just added a quest system plugin (game_stailer94's quest plugin) and the Yanfly main menu manager plugin. So, I added a few quests using the quest system plugin and I wanted to test them out. I loaded up a new game, but once it loaded, I couldn't move. Pressing escape did nothing, clicking on the screen did nothing, it was completely unresponsive. Then, I loaded a save file that was in a city. I left the city, and then a TypeError occured. Every time I go to the world map from a location, the same thing happens. When you start a new game, the player's starting position is on the world map, but the typeerror doesn't occur, it's the one I mentioned before. I honestly have no idea how to recreate this error.
    Here's some screenshots that might reveal what the problem is. Please help, and thank you in advance.:smile: If anything else is needed (like more screenshots of things), be sure to ask as I will do exactly what is needed. f8.png f8.png pluginlist.png typeerror.png
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,448
    Likes Received:
    6,492
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    You already found the cause of the error: you loaded an old savefiles after installing a complex plugin.
    Adding a plugin almost always makes older savegames incompatible, with exactly those undefined errors as a result. Only minor Plugins might be able to handle older savefiles, but nothing like a quest plugin that needs its own data structure in the saves.

    You have to start a new game with the quest plugin, and if that has problems then follow those bugs but never errors from then incompatible old saves.
     
    #2
    ls9405 likes this.
  3. ls9405

    ls9405 Warper Member

    Messages:
    2
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    @Andar Thanks, that fixed the TypeError problem, but I found out what the problem with not being able to move was myself (it was a broken autorun event). Thanks for the help! I hope the rest of the community is as nice and helpful as you were. :wink:
     
    #3

Share This Page