RMMV TypeError: Cannot read property 'isMoving' of undefined

Tigertenaka

Warper
Member
Joined
Aug 23, 2018
Messages
2
Reaction score
0
First Language
English
Primarily Uses
RMMV
I'm trying to integrate Dragonbones into my project, and I've had some problems to say the least. I've been able to fix issues up to this point. Now when I start a battle, it will load properly, but when any actor or enemy does anything at all, I get this error:
error screencap.PNG
Which seems to reference anything to do with a spritesheet that checks if a character has moved, but I have no idea how to fix this. If I turn the Dragonbones plugin off, everything works fine, but I still want that plugin. I'm using version 1.07 of KELYEP_DragonBones, 1.6.1 of RPG Maker MV, and all up to date versions of plugins that I'm using. I know I'm using a lot of plugins, but every single one of them that I have turned on work perfectly with no compatibility issues.
plugins1.PNG
plugins2.PNG
plugins3.PNG
plugins4.PNG
 
Last edited:

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,888
Reaction score
1,024
First Language
Dutch
Primarily Uses
RMMV
did you installed teh dragonbones assets as well in the lib? edit the index?
which was provided to follow?

if yes, skip this, if no, check the site for those assets which are required and follow
it on how to install it,

if yes, can you show the note tag setting you used for this skill/enemy when this
error pops up?
 

Tigertenaka

Warper
Member
Joined
Aug 23, 2018
Messages
2
Reaction score
0
First Language
English
Primarily Uses
RMMV
Those assets in the libs folder being the dragonbones folder that contains the dragonBones.js and dragonBonesPixi.js, correct? If so, then yes, those are there. And I did copy the proper code from the plugin into the index.html, and formatted it to fit in with the rest of the code.
code.PNG
As for the enemy settings, I copied it from the Librarium Dragonbones Demo into my project.
<Attack animation: 7>

<DragonBone Settings>

Battler: SeaDragon

Scalex: -0.8

Scaley: 0.8

Width: 50

Height: 350



Ani Wait: Idle

Ani Walk: Idle

Ani Attack: Attack A

Ani Swing: Attack B

Ani Thrust: Attack B

Ani Missile: Attack C

Ani Skill: Attack C

Ani Chant: Attack C

Ani Spell: Attack C

Ani Item: Attack C

Ani Guard: Idle

Ani Evade: Idle

Ani Damage: Damage

Ani Abnormal: Idle

Ani Sleep: Idle

Ani Dying: Idle

Ani Dead: Damage

Ani Victory: Idle

Ani Escape: Idle



Replace Sprite

</DragonBone Settings>

However, the error occurs in all battles, not just ones with Dragonbone battlers in it. Even RTP assets Sideview enemies have this problem.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

SF_Monster6 added!

Wonder when the next theme contest is coming?
Long time no see. I'm aiming a vertical slice / tech demo for my game featuring a series of boss battles this month. I hope I could get some testers.
So which forum do I use if I want to showcase graphics? I've been using AML forum, but I'm not sure it's correct.

Forum statistics

Threads
105,781
Messages
1,016,459
Members
137,482
Latest member
mentalhealthawareness
Top