TypeError Issue

JoelMarler

Veteran
Veteran
Joined
Jun 30, 2018
Messages
61
Reaction score
11
First Language
English
Primarily Uses
RMMV
A TypeError (image four and five) is occurring about half the time I play a certain battle. The battle is troop 48 (image six), and begins when the top enemy is attacked, triggering troop 48's battle event (image six) and summoning troop 14 (image seven). Does anyone know why this is happening? This event has always worked perfectly up until last week, and even now it sometimes works.






 
Last edited:

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,665
Reaction score
13,276
First Language
English
Primarily Uses
RMMV
Please play to get the error, then hit F8 and go to the Console tab. Take a screenshot of that and post it here. That gives the full error. Your first screenshot isn't really helpful.

Also post screenshots of your plugin manager, so we can see all the plugins you're using.

Complete guess ... any chance you had an extra enemy in that troop at some stage, then deleted them from the Enemies tab? To check, you can go to your Troops tab and hit Clear, then add the enemies back again.
 

JoelMarler

Veteran
Veteran
Joined
Jun 30, 2018
Messages
61
Reaction score
11
First Language
English
Primarily Uses
RMMV
Please play to get the error, then hit F8 and go to the Console tab. Take a screenshot of that and post it here. That gives the full error. Your first screenshot isn't really helpful.

Also post screenshots of your plugin manager, so we can see all the plugins you're using.

Complete guess ... any chance you had an extra enemy in that troop at some stage, then deleted them from the Enemies tab? To check, you can go to your Troops tab and hit Clear, then add the enemies back again.
Alright, I've uploaded those images too. Just tried clearing the enemies and replacing them, but that didn't work unfortunately.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,665
Reaction score
13,276
First Language
English
Primarily Uses
RMMV
Your YEP plugins seem to be all over the place. Are they all in the correct order?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,401
Reaction score
7,222
First Language
German
Primarily Uses
RMMV
@JoelMarler your Yanfly plugins are definately in the wrong order. I spotted several cases of wrong order, so you need to go to yanfly's website and compare your order with the list he has there - they HAVE to be in exactly that order, you can only mix other plugins between them but not change their order.

After you change the order, you need to start a new game - changing the plugin order will make your old savefiles incompatible because some of the plugin data gets stored into your savedgames when playing.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,224
Reaction score
13,770
First Language
English
Primarily Uses
RMVXA

I've moved this thread to Plug-In Support. Please be sure to post your threads in the correct forum next time. Thank you.

 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Husband has roped me into playing one of his PSO2 characters. Productivity is now negative.
Tileset A is lava! Don't burn D:
as MZ come out what you guys think about.....Some particles engine :3c?
Who wants to sing this song with me?~

Decided to submit my games to the Monday Night Stream. Figured it might be a fun way to get some traction.

Forum statistics

Threads
100,703
Messages
978,544
Members
132,320
Latest member
LavaWave
Top