TypeError: undefined is not a function.

Discussion in 'Javascript/Plugin Support' started by Gustavo_Br, May 3, 2018.

    Tags:
  1. Gustavo_Br

    Gustavo_Br Veteran Veteran

    Messages:
    37
    Likes Received:
    23
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    Every time I start a battle this error shows up. I've seen that some of the action plugins needs to be updated, but even if I disable then the error continues. Can anyone help?

    [​IMG]
    [​IMG]
     
    #1
  2. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,784
    Likes Received:
    11,822
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA

    I've moved this thread to Plug-In Support. Please be sure to post your threads in the correct forum next time. Thank you.



    Check the version of your project. Not Mv, the project. You'll have to open the core file to see what it is, as it will be listed at the beginning. If you have plug-ins that your project core doesn't support, you will get this error until you either update your project files or downgrade to older versions of the plug-ins.

    Also make sure to test with a new game, not a saved game. Plug-ins change variables, and if you make a change to plug-ins then load a save game, you will get this error 99.999% of the time.
     
    #2
  3. Gustavo_Br

    Gustavo_Br Veteran Veteran

    Messages:
    37
    Likes Received:
    23
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    "rpg_core.js v1.6.0"
    Is this version that you're talking about?

    How do I know which version of plugins my project support?
    I really do not understand anything about plugins hahah
     
    #3
  4. Shaz

    Shaz Veteran Veteran

    Messages:
    37,358
    Likes Received:
    11,149
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    1.6.0 is very buggy. Either revert to 1.5.2 or up to 1.6.1 beta. Probably 1.5.2 as plugins would be more likely to support that version.

    Make sure your Yanfly plugins are all the correct version (obviously there's on there that isn't, and as it's the Core, it's probably going to cause other issues), and in the correct order, according to Yanfly's site.
     
    #4
  5. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,784
    Likes Received:
    11,822
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    Yeah, your plug-ins are for like version 1.3 or so of MV, so you will have to update them. Go to Yanfly's website and get the most current version of all of them, as there were major changes to how plug-ins work with 1.5, so plug-ins from before 1.5 won't work with MV above 1.5 well and vice versa.
     
    #5
    Gustavo_Br likes this.
  6. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,521
    Likes Received:
    959
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    Well you have warnings saying to update your plugins, so you should do that.

    But besides that, the screenshots that you have given are not consistent. The first screenshot shows an error in YEP_X_ActSeqPack2 but the second screenshot shows that plugin is turned OFF. So it's hard to help you unless you give consistent information.
     
    #6
  7. Gustavo_Br

    Gustavo_Br Veteran Veteran

    Messages:
    37
    Likes Received:
    23
    First Language:
    Portuguese
    Primarily Uses:
    RMMV

    Yes, I saw the ActSeqPack2 error and tried to leave it off to test, was when I take the screenshot!, sorry about that!
     
    #7
  8. Gustavo_Br

    Gustavo_Br Veteran Veteran

    Messages:
    37
    Likes Received:
    23
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    I'll try revert to 1.5.2... In this case, I'll need to create a new project and copy-paste my old one, right?
     
    #8
  9. Shaz

    Shaz Veteran Veteran

    Messages:
    37,358
    Likes Received:
    11,149
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    You could do that, or you could create a new project and copy everything in the js folder (except plugins.js and your plugins folder) into the old project. Also copy index.html

    Steps to update a project are in all the MV update threads. To "downgrade" a project, you'd follow exactly the same steps.
     
    #9
    Gustavo_Br likes this.
  10. Gustavo_Br

    Gustavo_Br Veteran Veteran

    Messages:
    37
    Likes Received:
    23
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    Thanks, I'll try that!
     
    #10
  11. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,521
    Likes Received:
    959
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    Regardless of what version of MV you decide to run, you should also make sure to have the current version of all Yanfly plugins. You can find the most up-to-date versions on their website.
     
    #11
    Shaz likes this.

Share This Page