Joined
Jan 22, 2016
Messages
613
Reaction score
223
First Language
English
Primarily Uses
I tried out the ItemBook and EnemyBook plugins recently in a new project. I was able to have it work fine with my test project, however, I've run into an issue with the ItemBook plugin.


If active, it gives me a TypeError of "cannot read property of '0' undefined". I found this strange as, if you'll observe the first and second pictures (the first is from my test project, the second is from my current project), I did my event almost exactly the same, save for no sound effects. Yes, I updated it to 1.01 as per Yanfly's instructions. Yes, I upgraded to the new version of MV, but this was happening BEFORE that, so it's not that update. I checked my items (I used to have an item equivalent of both but got rid of it), my variables, my common events, my Main Manager plugin from Yanfly, my switches and self switches... None of those have any trace of that plugin whatsoever.


Please help me solve this conundrum!

Screenshot 2016-03-03 23.25.44.png

Screenshot 2016-03-03 23.25.11.png

Screenshot 2016-03-03 23.25.04.png
 

Cjdgame

The Azure Falcon
Veteran
Joined
Dec 4, 2013
Messages
100
Reaction score
12
First Language
English
Primarily Uses
Did you change any of the parameters of the plugin at all? Where is it in the order of your plugins?


There may be a conflict with another plugin...most likely yanfly item core.
 
Joined
Jan 22, 2016
Messages
613
Reaction score
223
First Language
English
Primarily Uses
It's on the bottom of the list, and I already said that I updated to not have it conflict with Item Core. Parameters? Nope. Nothing really to change at all.
 
Last edited by a moderator:

Cjdgame

The Azure Falcon
Veteran
Joined
Dec 4, 2013
Messages
100
Reaction score
12
First Language
English
Primarily Uses
Well, sadly I can't be of much help for when I try to test it in my game I get a totally different error  :dizzy:
 
Joined
Jan 22, 2016
Messages
613
Reaction score
223
First Language
English
Primarily Uses
Maybe delete the plugin and redownload it off Yanfly's site?


Tried it. Nope. *sigh*
 
Last edited by a moderator:

ZServ

Veteran
Veteran
Joined
Jun 16, 2014
Messages
260
Reaction score
71
Primarily Uses
Screenshots aren't loading for me at the moment, so let me ask, when are you having the issue? Is it upon starting the playtest, picking up an item, using an item? What's the trigger here?


If you're trying to load an old save, don't do that. Make a new save file, see if it still crashes.
 
Joined
Jan 22, 2016
Messages
613
Reaction score
223
First Language
English
Primarily Uses
Starting the Playtest. I don't even see the title screen, just that error message.


I've not made any saves at all, been starting a new game every time, because I only have like 3 maps and no plotline yet.
 

ZServ

Veteran
Veteran
Joined
Jun 16, 2014
Messages
260
Reaction score
71
Primarily Uses
Can you provide a list of all the active scripts, in the order they are active? I've attached an example screenshot. Also, do you have the Steam version, or a different version?

View attachment example.png
 
Joined
Jan 22, 2016
Messages
613
Reaction score
223
First Language
English
Primarily Uses
I have the site version. I have tried connecting it to Steam, but that didn't seem to do anything special. *shrugs*


Hopefully I uploaded these pictures in the correct order, otherwise it'll look like I'm scrolling backwards not forwards. //rmwforums.s3.amazonaws.com/emoticons/default_tongue.gif


And I WOULD show you the last picture I took that shows the bottom of the list, but I can only upload 4.88 mb. This irritates me greatly.


View attachment Screenshot 2016-03-04 14.23.11.png


View attachment Screenshot 2016-03-04 14.23.19.png


View attachment Screenshot 2016-03-04 14.23.28.png
 
Last edited by a moderator:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,891
Reaction score
8,592
First Language
German
Primarily Uses
RMMV
@Little Adventurer Use [Alt]-[PrtScrn] instead of simple [PrtScrn] for your screenshots, that will limit them to the active window, resulting in better readability and smaller picture size.
 

Tome571

Veteran
Veteran
Joined
Oct 3, 2015
Messages
129
Reaction score
129
First Language
English
Primarily Uses
Any resolution on this? I just had this issue for the first time as well. Randomly happens when an Actor is hit in battle - property of 2 -  and when using skill counterattack - property of 18.
 

ZServ

Veteran
Veteran
Joined
Jun 16, 2014
Messages
260
Reaction score
71
Primarily Uses
What is your script setup, Tome? Or are you running a vanilla setup of just MV?
 

Latest Threads

Latest Posts

Latest Profile Posts

Ugh... 4:53AM over here and I can't sleep so why not just game make.
I just love the MV feature that allows you to create your own animations!
I typically ask this on my normal social media channels, but figured there may be good replies here. Anyone got any good horror movie recommendations? I've seen a lot, but I always love getting suggestions! Bonus points if you know which service it is streaming on (in the US) - bring on the spOoooOky!
 After a few distractions (and my annual rough second week of October), I’m getting back on track with my OMGC project.
 Am I overcomplicating it? Yes. Am I going to tone it down? Almost certainly not.
 At least the dialogue stuff is almost done. I need to do the map itself, and then all that’s left is combat.
 Getting there!

Forum statistics

Threads
115,910
Messages
1,093,894
Members
151,159
Latest member
rlawlsrjs3387
Top