v.1.6.0 broke MV for me

Discussion in 'RPG Maker MV' started by Parallax Panda, Feb 21, 2018.

Thread Status:
Not open for further replies.
  1. Parallax Panda

    Parallax Panda Got into VxAce ~2014 and never stopped... Veteran

    Messages:
    600
    Likes Received:
    989
    Location:
    Fukuoka, Japan
    First Language:
    Swedish
    Primarily Uses:
    VNM
    I'm using the steam version on an older HP laptop (running windows 8.1). The new update just installed itself and now I can't open/run the program anymore. When I try to open it though steam or the start menu nothing happens and if I try opening an old project manually I'll get this error message reading something like;

    "RPGMV.exe - system error. It's not possible to open the program because MSVCP120.dll is missing on this computer. You can try to fix the problem by re-installing the software".

    I'm paraphrasing because my windows language settings are in Swedish, but that's what it said. I haven't tried to re-install RPGmaker yet. I thought I should ask here first since whatever is wrong here happened in this update and it's possible more people than me have this problem.

    I'm using a HP ProBook 450 G2 with an Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz 2.40GHz, 8GB RAM (can't remember exact type) & a 64-bit Windows 8.1 Pro.
     
    #1
  2. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,538
    Likes Received:
    14,201
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Try using Verify Integrity first and/or reinstall.
     
    #2
    Parallax Panda likes this.
  3. Sauteed_Onion

    Sauteed_Onion Mmm Tasty Veteran

    Messages:
    554
    Likes Received:
    3,658
    Location:
    Perhaps on a steak or cheeseburger
    First Language:
    English
    Primarily Uses:
    RMMV
    Hmm can you load the previous version via steam like some have suggested panda? Meow.
     
    #3
    Parallax Panda likes this.
  4. Parallax Panda

    Parallax Panda Got into VxAce ~2014 and never stopped... Veteran

    Messages:
    600
    Likes Received:
    989
    Location:
    Fukuoka, Japan
    First Language:
    Swedish
    Primarily Uses:
    VNM
    @Archeia
    I'm going to try to re-install first. It'll take a couple of hours most likely with my internet speed. I'm not sure I understand what you mean with "Verify integrity"? But I'm willing to try it if this re-installation doesn't work.

    @Sauteed_Onion
    If nothing I else work I'll try to revert back to an older version as a last resort. But that would be more like a temporary fix since you'd want to have the latest bug fixes and such as well as access to future versions. So whatever is wrong here would have to be addressed sooner or later. But never the less, it's good that you pointed it out because I didn't really think about it. :)
     
    #4
    Sauteed_Onion likes this.
  5. cyanic

    cyanic Veteran Veteran

    Messages:
    105
    Likes Received:
    62
    Are you sure that's MSVCP120.dll and not MSVCP140.dll? Imports indicate that it should require MSVC++ 2015 redists, not 2013.
     
    #5
  6. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,538
    Likes Received:
    14,201
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Verify Integrity is basically recheck all files without reinstalling.
    upload_2018-2-21_16-4-32.png
     
    #6
    Sauteed_Onion and Parallax Panda like this.
  7. Parallax Panda

    Parallax Panda Got into VxAce ~2014 and never stopped... Veteran

    Messages:
    600
    Likes Received:
    989
    Location:
    Fukuoka, Japan
    First Language:
    Swedish
    Primarily Uses:
    VNM
    @cyanic
    Um... yeah I think I'm positive but since I've uninstalled and are (slowly) re-installing it again I can't double check it to be 100% positive. That being said, I was a bit distracted since I was simultaneously reading an e-mail with bad news. So you might be right... but I think I wrote it correctly.

    @Archeia
    Ah, I see. Thank you. If the re-install doesn't work. I'll try that. And if that doesn't work... I guess I try to revert back to the last version unless anyone else has any good ideas.
     
    #7
    Sauteed_Onion likes this.
  8. OmnislashXX

    OmnislashXX Veteran Veteran

    Messages:
    591
    Likes Received:
    3,635
    Location:
    Maryland
    First Language:
    English
    Primarily Uses:
    RMMV
    Reverting back to 1.5.1 I can launch MV. Turning Antivirus off, switching back to 1.6. Did the verify intergrity of files. 1.6 still fails to Launch.
     
    #8
    Sauteed_Onion likes this.
  9. GaryCXJk

    GaryCXJk Veteran Veteran

    Messages:
    88
    Likes Received:
    46
    Location:
    Zaandam, the Netherlands
    First Language:
    Dutch
    If reinstall doesn't work reverifying won't work either, since you've already got a fresh install.
     
    #9
    Parallax Panda and Sauteed_Onion like this.
  10. OmnislashXX

    OmnislashXX Veteran Veteran

    Messages:
    591
    Likes Received:
    3,635
    Location:
    Maryland
    First Language:
    English
    Primarily Uses:
    RMMV
    Uninstalled then reinstalled. 1.6 still fails to Launch. Sorry, but it's broke.
     
    #10
    Parallax Panda and Sauteed_Onion like this.
  11. SamJones

    SamJones Autorun Veteran

    Messages:
    113
    Likes Received:
    47
    First Language:
    English
    Primarily Uses:
    RMMV
    #11
  12. Parallax Panda

    Parallax Panda Got into VxAce ~2014 and never stopped... Veteran

    Messages:
    600
    Likes Received:
    989
    Location:
    Fukuoka, Japan
    First Language:
    Swedish
    Primarily Uses:
    VNM
    Ok, re-installing did not solve the problem. It's must be that the update itself is broken in one way or another.

    @SamJones

    I have not, I'll consider trying that next.
     
    #12
  13. Magusalfador

    Magusalfador Veteran Veteran

    Messages:
    195
    Likes Received:
    31
    First Language:
    English Spanish
    I have the same problem, rechecking integrity will not fix it nor reinstalling. I have the steam version an i was able to go back to 1.51 and it works fine. I guess we have to wait for them to re patch the update for us having the MSVCP140.dll problem. Sigh*
     
    #13
    Sauteed_Onion likes this.
  14. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,538
    Likes Received:
    14,201
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Hi please download
    VC++ 2015 and 2013 for good measure
     
    #14
    Magusalfador and Sauteed_Onion like this.
  15. Parallax Panda

    Parallax Panda Got into VxAce ~2014 and never stopped... Veteran

    Messages:
    600
    Likes Received:
    989
    Location:
    Fukuoka, Japan
    First Language:
    Swedish
    Primarily Uses:
    VNM
    A small second patch seems to have been issued though STEAM and after installing that I can once again launch MV. Whatever it was, it seemed to have fixed the issue for me.
     
    #15
    Sauteed_Onion likes this.
  16. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,409
    Likes Received:
    10,415
    First Language:
    English
    Primarily Uses:
    RMVXA

    This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

     
    #16
Thread Status:
Not open for further replies.

Share This Page