Variable Update in Skill Description Issue

rikucotton

Veteran
Veteran
Joined
Dec 22, 2013
Messages
36
Reaction score
2
Primarily Uses
So I'm eventing my own skill level up system via common events and what not. It works fine but ooooone little issue. I have it to where in the skill's description, it displays \v[1] to be the variable to showcase how many you need to level up the skill. Problem is, despite the skill adding to the variable and later leveling up the skill, it does not update at all in the description. No idea how to fix this, google lead to me to nowhere. If anyone can provide an answer, that'd be great.

 

BlackGoldSaw

Veteran
Veteran
Joined
Oct 10, 2017
Messages
61
Reaction score
31
First Language
English
Primarily Uses
RMMV
Really? I was testing this out myself and it seems to work fine. Can you show me how you have it set up? Also, are you sure Variable 1 isn't being used by something else, like a Plugin or something?
 

rikucotton

Veteran
Veteran
Joined
Dec 22, 2013
Messages
36
Reaction score
2
Primarily Uses
Really? I was testing this out myself and it seems to work fine. Can you show me how you have it set up? Also, are you sure Variable 1 isn't being used by something else, like a Plugin or something?
No plugins. Here's how I got it setup.

 

BlackGoldSaw

Veteran
Veteran
Joined
Oct 10, 2017
Messages
61
Reaction score
31
First Language
English
Primarily Uses
RMMV
Okay, can you show me the skill that has that variable in its description?
 

BlackGoldSaw

Veteran
Veteran
Joined
Oct 10, 2017
Messages
61
Reaction score
31
First Language
English
Primarily Uses
RMMV
Strange. I tried it out in battle in my project and a fresh one and it works fine. Have you tried it without any plugins active? It might be one of them causing the description box not to refresh.
 

rikucotton

Veteran
Veteran
Joined
Dec 22, 2013
Messages
36
Reaction score
2
Primarily Uses
Strange. I tried it out in battle in my project and a fresh one and it works fine. Have you tried it without any plugins active? It might be one of them causing the description box not to refresh.
Only one I have on is community basics
 

BlackGoldSaw

Veteran
Veteran
Joined
Oct 10, 2017
Messages
61
Reaction score
31
First Language
English
Primarily Uses
RMMV
Ah, okay. I think the default engine handles running common events strangely. Do you have the same problem if you update the variable outside of a common event?
 

rikucotton

Veteran
Veteran
Joined
Dec 22, 2013
Messages
36
Reaction score
2
Primarily Uses
Ah, okay. I think the default engine handles running common events strangely. Do you have the same problem if you update the variable outside of a common event?
outside of battle it updates normally. it's in battles that's causing the issue.
 

BlackGoldSaw

Veteran
Veteran
Joined
Oct 10, 2017
Messages
61
Reaction score
31
First Language
English
Primarily Uses
RMMV
Yeah, I see the problem. If I change the variable through a troop event it updates properly, but if I do it through a common event it doesn't. However, this works correctly while I'm using Yanfly's Action Sequence Plugins. It seems to be that that the default engine doesn't do this naturally.
 

rikucotton

Veteran
Veteran
Joined
Dec 22, 2013
Messages
36
Reaction score
2
Primarily Uses
Yeah, I see the problem. If I change the variable through a troop event it updates properly, but if I do it through a common event it doesn't. However, this works correctly while I'm using Yanfly's Action Sequence Plugins. It seems to be that that the default engine doesn't do this naturally.
Can you provide a link for it?
 

BlackGoldSaw

Veteran
Veteran
Joined
Oct 10, 2017
Messages
61
Reaction score
31
First Language
English
Primarily Uses
RMMV

rikucotton

Veteran
Veteran
Joined
Dec 22, 2013
Messages
36
Reaction score
2
Primarily Uses
Sure thing.

http://www.yanfly.moe/wiki/Battle_Engine_Core_(YEP)

http://www.yanfly.moe/wiki/Action_Sequence_Pack_1_(YEP)

http://www.yanfly.moe/wiki/Action_Sequence_Pack_2_(YEP)

http://www.yanfly.moe/wiki/Action_Sequence_Pack_3_(YEP)

I don't think the Core Engine Plugin is needed, but I could be wrong. Make sure to place them in that order.

In the Skill's Notebox I used this:

Code:
<Post-Damage Eval>
  $gameTemp.reserveCommonEvent(1);
</Post-Damage Eval>
engine core was required but it works now. this forum can be closed now!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

I'm currently being attacked by the RPG Maker Hydra: fixing one problem only to have two more rise to take its place.
Hey you! Yeah YOU! Whatcha doin' not backing up your projects? You a masochist or sumthin'? GO BACK UP YOUR PROJECTS! Sheeesh... Didn't think I'd hafta spell it out for yas.
now I need to determine, how MV determines if an auto tile is complete or not.
Edit:From what I can tell it uses Autotile kinds to do that.
Edit 2: The editor determines it and packs picture data for the engine....
Finished with the ground work for my class system, using Ellye's Class Change Equipment and Yanfly's Class Change Core plugins to implement an equip based subclass feature!
Hi people! I was wondering... Here in Brazil, we have a whats app group for we talk about rpg maker and our projects. A more informal way for we meet each other. Is there any whats app group out there? :)

Forum statistics

Threads
94,281
Messages
919,656
Members
124,020
Latest member
6264442
Top