SgtSalamander

Villager
Member
Joined
Sep 17, 2021
Messages
8
Reaction score
0
First Language
English
Primarily Uses
RMMV
I've tried everything and I can't load up the game, so I can't test anything. I have the plugins in order like they should be, I removed all the plugins except those 2, i removed both of those plugins and yet nothing worked. I can't make anymore progress on my game till this is fixed, it was working fine the other day so I don't know what happened.
 

Attachments

  • Screenshot (24).png
    Screenshot (24).png
    14 KB · Views: 10
  • Screenshot (26).png
    Screenshot (26).png
    200.4 KB · Views: 9
  • Screenshot (27).png
    Screenshot (27).png
    176.6 KB · Views: 2

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,688
Reaction score
15,295
First Language
English
Primarily Uses
RMMV

I've moved this thread to Plugin Support. Thank you.

 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,901
Reaction score
8,596
First Language
German
Primarily Uses
RMMV
please give a screenshot of the console (press F8 when the error message happens) to see the full error sequence.
most likely there is a third plugin involved, and the error trace will list that.
 

SgtSalamander

Villager
Member
Joined
Sep 17, 2021
Messages
8
Reaction score
0
First Language
English
Primarily Uses
RMMV
please give a screenshot of the console (press F8 when the error message happens) to see the full error sequence.
most likely there is a third plugin involved, and the error trace will list that.
i attached a third image , which i can't read very well XD
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,901
Reaction score
8,596
First Language
German
Primarily Uses
RMMV
I don't see the third image anywhere
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,901
Reaction score
8,596
First Language
German
Primarily Uses
RMMV
screenshot of the console
That is not the console - please check the tab selected on top.
you gave a screenshot of the elements section, not of the console
 

SgtSalamander

Villager
Member
Joined
Sep 17, 2021
Messages
8
Reaction score
0
First Language
English
Primarily Uses
RMMV
That is not the console - please check the tab selected on top.
you gave a screenshot of the elements section, not of the console
all the console shows is it trying to log into gamejolt and stuff
 

Attachments

  • Screenshot (28).png
    Screenshot (28).png
    119.5 KB · Views: 2

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,901
Reaction score
8,596
First Language
German
Primarily Uses
RMMV
Then please disable the gamejolt plugin and test the game locally.
you first have to solve all bugs with local play before you can add the many possible error causes on online play.
 

SgtSalamander

Villager
Member
Joined
Sep 17, 2021
Messages
8
Reaction score
0
First Language
English
Primarily Uses
RMMV
Then please disable the gamejolt plugin and test the game locally.
you first have to solve all bugs with local play before you can add the many possible error causes on online play.
 

Attachments

  • Screenshot (28).png
    Screenshot (28).png
    119.5 KB · Views: 2

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,901
Reaction score
8,596
First Language
German
Primarily Uses
RMMV
that is the wrong screenshot - if the gamejolt plugin is correctly disabled, it CANNOT try to access that website.

If you believe the plugin is disabled, then you made one of two other errors:
1) have you started a new game in playtest? Never load savefiles during bughunting because savefiles can contain old data, including previous plugin configurations.
2) when you go to "game / open folder" while your project is loaded in the editor, is there a folder www in the directory that comes up? (hope not)
 

SgtSalamander

Villager
Member
Joined
Sep 17, 2021
Messages
8
Reaction score
0
First Language
English
Primarily Uses
RMMV
that is the wrong screenshot - if the gamejolt plugin is correctly disabled, it CANNOT try to access that website.

If you believe the plugin is disabled, then you made one of two other errors:
1) have you started a new game in playtest? Never load savefiles during bughunting because savefiles can contain old data, including previous plugin configurations.
2) when you go to "game / open folder" while your project is loaded in the editor, is there a folder www in the directory that comes up? (hope not)
there is a www folder is there something wrong with that?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,901
Reaction score
8,596
First Language
German
Primarily Uses
RMMV
is there something wrong with that?
yes, because the www folder is deployment ONLY, and you must never deploy into your project folder.

basically a deployment into the project folder redirects the playtest to the last deployment, and all changes you do in the editor after that cannot be tested because they are ignored by the damaged playtest.

You need to repair your project folder, and make sure to NEVER deploy into the project folder again, deployment should always go to a different output folder.

1) make a backup copy of your existing project folder somewhere else. That is so you have a backup if something goes wrong.
2) make a new project somewhere else (it can be deleted later, you need one of its files)
3) delete the www folder in the project folder
4) copy the package.json file from the new project into the project folder, overwriting the wrong one there.

If you did everything correctly, the playtest should work with the latest project version again.
test to see what your errors are now.
 

SgtSalamander

Villager
Member
Joined
Sep 17, 2021
Messages
8
Reaction score
0
First Language
English
Primarily Uses
RMMV
yes, because the www folder is deployment ONLY, and you must never deploy into your project folder.

basically a deployment into the project folder redirects the playtest to the last deployment, and all changes you do in the editor after that cannot be tested because they are ignored by the damaged playtest.

You need to repair your project folder, and make sure to NEVER deploy into the project folder again, deployment should always go to a different output folder.

1) make a backup copy of your existing project folder somewhere else. That is so you have a backup if something goes wrong.
2) make a new project somewhere else (it can be deleted later, you need one of its files)
3) delete the www folder in the project folder
4) copy the package.json file from the new project into the project folder, overwriting the wrong one there.

If you did everything correctly, the playtest should work with the latest project version again.
test to see what your errors are now.
i always deploy it in a seperate folder, and besides, everything worked correctly with the same settings a few days ago, but i did what you said and it fixed it :D thank you SO MUCH! you saved my ass big time XD
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,901
Reaction score
8,596
First Language
German
Primarily Uses
RMMV
i always deploy it in a seperate folder
not always - you at least once made the mistake to deploy into your project folder, or the www folder would not be there.
and it had to be a very short time ago because otherwise you would have realised that the playtest always goes to an old version inside the www folder...
 

SgtSalamander

Villager
Member
Joined
Sep 17, 2021
Messages
8
Reaction score
0
First Language
English
Primarily Uses
RMMV
not always - you at least once made the mistake to deploy into your project folder, or the www folder would not be there.
and it had to be a very short time ago because otherwise you would have realised that the playtest always goes to an old version inside the www folder...
I've been up super late working on my game lately, so unintentionally i probably saved it wrong XD
 

Latest Threads

Latest Posts

Latest Profile Posts

Finally got my website fixed and the security sorted so it's been a productive day. Can I go to sleep now? I mean... I don't need to work right?
It's always a good idea to refresh yourself on what your plugins do. I'm working on a map with opening walls, and I was about to tear my hair out over how much image editing and hand-constructing of autotiles I'd have to do, when I looked again and saw @Shaz 's Tile Changer could copy areas from another map.
"sorry it took me so long to respond" - can we please agree not to say that anymore unless it actually took a long time?! (Like 36hrs at least) I mean, I'm running out of funny responses here xD
Ugh... 4:53AM over here and I can't sleep so why not just game make.
I just love the MV feature that allows you to create your own animations!

Forum statistics

Threads
115,919
Messages
1,094,017
Members
151,174
Latest member
sardin
Top