LamiaRay

Warper
Member
Joined
Oct 13, 2021
Messages
4
Reaction score
3
First Language
English
Primarily Uses
RMMV
Ok so this is more than likely the wrong spot, and I apologize for that, but i couldn't find a help spot for specifically MV *the one i'm using* where I'm getting this error.

It's probably some little thing i messed up by mistake, but i cant really figure out WHAT i could have done to cause the error, so i need some input so i can figure out and fix it *i did check the battle backs and they... seem to be fine image wise.


glitch1.jpgglitch2.jpg

*ignore the title screen, its filler while i try things out
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
2,717
Reaction score
1,601
First Language
English
Primarily Uses
RMMV
It looks like you might have a custom Window.png that's formatted incorrectly, so that when the engine is drawing a window it's looking at the places on the image that are supposed to be the back/edges/corners of the window and it's going into where you've drawn the arrows instead.

Or you have a plugin that's modifying how the windows are drawn.

Post your Window.png and a screenshot of your plugin manager.
 

LamiaRay

Warper
Member
Joined
Oct 13, 2021
Messages
4
Reaction score
3
First Language
English
Primarily Uses
RMMV
I apologize but im not sure what you mean by window.png, if it helps, Other than putting in some images for testing like the title screen, i haven't added in anything that wasn't rpg maker stuff.

as for the plugins That would be:

ActivePlugin.jpg

Theres a few others that are inactive, but its not many more than this, and as i said none are actually on.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,270
Reaction score
8,723
First Language
German
Primarily Uses
RMMV
in your project, in the system images there is a picture named window.png
that is the picture ATT_Turan was talking about, and that picture defines how your window will look like - exactly what is wrong in your screenshots.

so either that picture is damaged or replaced, or the entire engine is messed up. And you don't have any plugins that could mess up like that.

So even if you don't remember editing or replacing that window.png it is the most likely cause for yyour problem. If you post it here we can check how it is damaged or what else might be going on.
 

LamiaRay

Warper
Member
Joined
Oct 13, 2021
Messages
4
Reaction score
3
First Language
English
Primarily Uses
RMMV
huh.... yeah looking at it that DOES look like the issue, though i cant figure out HOW it got that way, i don't remember overwriting anything

as for the.png itself

....honestly no idea how that occurred lol
Window.pngg.png

Though i also have noidea how to fix it ether so, I mean its probaly something simple, but im sitll an amatur so.. lol
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,270
Reaction score
8,723
First Language
German
Primarily Uses
RMMV
that image got the wrong name, especially if you simply added it as-is from the project.
the correct, full name expected by the engine is window.png
but the attachment you gave is named window.pngg.png

most likely that was the result of a renaming or editing attempt at some time with the idotic setting where windows hides the type-part of the naming from the user.

make a new project elsewhere, delete that windowskin picture and copy the correct one from the new project to your old project.

due to the renaming simply copying will not work but result in two pictures, and you have to delete the wrong one first because likely you won't be able to tell the difference if you wait after you copy the correct one.
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
2,717
Reaction score
1,601
First Language
English
Primarily Uses
RMMV
So that does look to me like the original file, although as Andar said the name is screwy.

When you make a new project to copy the file over, also give it a test play - do your windows look like that in a new project?
 

LamiaRay

Warper
Member
Joined
Oct 13, 2021
Messages
4
Reaction score
3
First Language
English
Primarily Uses
RMMV
a bit late on the reply, but yep that was exactly what was wrong! i did a playtest just to be sure like was suggested, as well as copying it over, and that cleared everything up.

Thanks a ton for the help you two! I'm glad it ended up being a simple fix in the end, and i appreciate the help a lot ^^
 

Latest Threads

Latest Posts

Latest Profile Posts

Folks, if anyone sends you a message inviting you to add their API to your game, please report them. We don't want people spamming our members asking them to add stuff to their games for their own (or others') benefit.
I'm listening to iiluminaughtii talking about the secrets behind shady businesses and scams. Meanwhile I'm writing a fanfic about Sephiroth from FF7, one specifically for my stepmom. I'll get to give it to her, too, because my boss said I could take the holidays off! Dec. 22-27 I will be in Orlando, and maybe Fort Myers too, visiting my dad and stepmom!
Of course, I bought a handful of games on the Steam Black Friday sale. Will I try them? Will I complete any? Who knows...
I don't really have any neat updates today about how I screwed up programming... But if you want to observe the intensenes of me programming, then you can check out my stream :)
New Weapons.gif
No more spam from me today, I promise! Just wanted to upload this, people have been giving me feedback that my weapon sprites (which were RTP) clashed badly with my battlers for ages, so today I finally took the plunge and updated them! Really happy with how they came out :D :D

Forum statistics

Threads
117,012
Messages
1,103,797
Members
152,909
Latest member
ringoman
Top