Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
I recently picked up VisuStella's FrontView Battle UI plugin and it's ABSOLUTELY PERFECT for what I was wanting: a way to keep character portraits at the bottom of the screen without obscuring my characters due to custom screen resolutions. I'm actually using it for sideview battles, and merely taking advantage of the plugin's UI layout (which the plugin itself states is very possible), but I've had a few issues: It seemed like it would work on some battles, and then other times it would instantly crash the game on the exact same event, even without me fiddling with any plugins at all, which didn't make any sense... It was pure luck that I quickly noticed that the size of my party was somehow the deciding factor, and while it's possible that it could be the result of conflicts with settings in another Visustella plugin, I think this one could be an actual bug that needs to be addressed.

The title of my post sums it up pretty well: The plugin works perfectly fine as long as I have a party of four characters... But if I have less than that, the moment I step into battle it crashes and this pops up:

'Cannot read property "isInputing" of undefined'

...followed by an ".nwjs quit unexpectedly" error.

I'm using the Mac version of MZ, btw.
 
Last edited:

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
6,930
Reaction score
4,770
First Language
English
Primarily Uses
RMMV
Unfortunately, VisuStella obfuscates the code of their plugins. So unless you configured something incorrectly in the parameters or your game, there's not really anything anyone on these forums can do with this information.

VisuStella has bug-reporting instructions on their site you can follow.
 

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
606
Reaction score
342
First Language
English
Primarily Uses
RMMZ
in what situation do you have less than 4 members?
ive tested:
having less than 4 members starting from database - working fine
changing party size less than 4 in party system plugin - working fine
removing specific member (now less than 4) before calling battle - working fine

can you re-create this in a new project with only the frontview ui, core engine, and battle core?
 

Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
Yes, I've recreated it using only those plugins in a fresh project, and I've already sent a project file to Visustella to report it as a bug.
Are you using the PC version of RPG MAKER? Because I'm on Mac and the result is the same regardless of what battle system I'm using: If the Frontview UI plugin is turned on, I can't enter a battle with less than 4 players -- both on map Event battles and from within the database Battle Test, it crashes immediately.
 
Last edited:

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
606
Reaction score
342
First Language
English
Primarily Uses
RMMZ
Yes, I've recreated it using only those plugins in a fresh project, and I've already sent a project file to Visustella to report it as a bug.
Are you using the PC version of RPG MAKER? Because I'm on Mac and the result is the same regardless of what battle system I'm using: If the Frontview UI plugin is turned on, I can't enter a battle with less than 4 players -- both on map Event battles and from within the database Battle Test, it crashes immediately.
Yes, PC.
Have you tried the same project on a PC at all?
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
6,930
Reaction score
4,770
First Language
English
Primarily Uses
RMMV
If the Frontview UI plugin is turned on, I can't enter a battle with less than 4 players -- both on map Event battles and from within the database Battle Test, it crashes immediately.
Just to throw it out there as a thing to make sure - are you deleting the fourth party member from Starting Party on the System 1 tab of the database?

I've seen people delete the actor from the Actor tab of the database but not remove its line from Starting Party, which will result in crashes as the game tries to access a nonexistent fourth party member.
 

Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
I'm changing the party correctly, that's not the problem.

I don't have an actual PC, but I just tried it on my older MacBook Pro running Windows in Bootcamp mode, and it does the exact same thing. This time I was able to get an error report -- which I can't do on my main Mac because opening the Console in MZ also causes it to immediately crash with an nwjs error -- and this is what I got:

MZError.png
Maybe that info will help somebody identify my problem, but I'm too much of a layman to figure out exactly what any of that means or what to do about it...
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
6,930
Reaction score
4,770
First Language
English
Primarily Uses
RMMV
Is your version of MZ and the core scripts of your project the latest version? I'm just putting thoughts out there since NaosoX was unable to reproduce this behavior.
 

Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
Yup -- Core Script and plugins are all up to date, and I had the same behavior on two separate devices, running either Windows or Mac versions of the game... Doesn't make sense if we're using the same setup, so that leads me to wonder if maybe it could be related to the OS that I'm using on both Macs (Mojave). I mentioned previously that I had reported the issue to VisuStella, but I didn't have an error report until now, so I'll try sending that to them as well... Even if it's not the plugin's fault, maybe they can point to something in my system that might have some compatibility issues.

I might mention that earlier this year, updating a bunch of my plugins led to that problem with their CoreEngine, where I have to have "Open Console on Boot" set to false, or else it my test play will crash immediately upon startup with that nwjs error... And I had noticed that line about the Devtools / Chrome Extension was already appearing in the error report. I simply left that part turned off and went about my business, not sure if that's contributing to the problem or not, but I certainly don't think it's supposed to be happening.
 

Latest Threads

Latest Posts

Latest Profile Posts

Hi sweethearts! :kaoluv: Check out my review of @EntangledPear's totally oldskool The Stuff Fairy Tales Are Made Of!
When you spend all day at work distracted by things you want to work on or try in your project and then by the time you get home, you are too mentally tired to concentrate so you just browse the forum instead and think of more things you won’t get to work on for a while.
Time to write some enemy behaviors, here's the stream link for those interested.

Call of duty 1&2 had an interesting cheat prevention method. Between levels the game unloads and reloads the engine dll. If you ever employ this method, make sure to include at least an md5 hash check. Otherwise I can just edit that dll and implant cheats into it.
Hi-Fi Rush is one of the coolest games I've seen in a while. I don't have a way to play it so I watched a friend and wow... I really wish I had a powerful enough computer for it.

Forum statistics

Threads
128,277
Messages
1,193,258
Members
168,732
Latest member
Thot123
Top