[VXAce] [Khas' Message System] "\t[se]" command doesn't work.

Discussion in 'RGSSx Script Support' started by CarlosDavilla, Feb 23, 2019.

Thread Status:
Not open for further replies.
  1. CarlosDavilla

    CarlosDavilla The Insolent One Member

    Messages:
    28
    Likes Received:
    5
    First Language:
    Portuguese
    Primarily Uses:
    RMVXA
    Hi. This is my third post of the day.
    Yay? I swear I'm not doing this on purpose.

    Anyway, I have a problem with Khas' Message System. The \t[se] command is not playing any of the sounds that I put in there.

    I have a se file called "text.wav". It worked fine with Yami's Pop Messages. It doesn't work with Khas'.
    Even the files that come with the demo doesn't work when I use them.

    Am I doing something wrong here?
    Here's how I'm proceeding.

    [​IMG] [​IMG]
     
    #1
  2. Roninator2

    Roninator2 Gamer Veteran

    Messages:
    1,328
    Likes Received:
    257
    Location:
    Canada
    First Language:
    English
    Primarily Uses:
    RMVXA
    I though i had an idea, but it didn't work.
    You can just setup another line below "Man" and use the \a[Man] option
     
    Last edited: Feb 23, 2019
    #2
  3. CarlosDavilla

    CarlosDavilla The Insolent One Member

    Messages:
    28
    Likes Received:
    5
    First Language:
    Portuguese
    Primarily Uses:
    RMVXA
    I thought about that, but this just work for actors. I want it to work on events, otherwise, I'll have to register most of the npcs on the "actors" tab in the database.

    [​IMG]
     
    Last edited: Feb 23, 2019
    #3
  4. Roninator2

    Roninator2 Gamer Veteran

    Messages:
    1,328
    Likes Received:
    257
    Location:
    Canada
    First Language:
    English
    Primarily Uses:
    RMVXA
    After doing some more testing I found the issue.
    Line 727. The expression is wrong.
    it should be
    result.gsub!(/\et\[\w+\]/i,"")
    not
    result.gsub!(/\et\[\w*\]/i,"")
     
    #4
  5. CarlosDavilla

    CarlosDavilla The Insolent One Member

    Messages:
    28
    Likes Received:
    5
    First Language:
    Portuguese
    Primarily Uses:
    RMVXA
    Are you sure this is correct? I tried fixing it out but no luck whatsoever.
    I've even fixed in his own demo that there's no materials but his own, but it still doesn't work.


    [​IMG]
     
    #5
  6. Roninator2

    Roninator2 Gamer Veteran

    Messages:
    1,328
    Likes Received:
    257
    Location:
    Canada
    First Language:
    English
    Primarily Uses:
    RMVXA
    Sorry just realized that I had made one more change.
    Line 692 change the * to +
    @voice = text.slice!(/^\[\w+\]/)[/\w+/]
     
    #6
    CarlosDavilla likes this.
  7. CarlosDavilla

    CarlosDavilla The Insolent One Member

    Messages:
    28
    Likes Received:
    5
    First Language:
    Portuguese
    Primarily Uses:
    RMVXA
    Awesome, now it works fine.
    Thanks again for the help, Roninator.
    This thread can now be closed.
     
    #7
  8. Kes

    Kes Global Moderators Global Mod

    Messages:
    19,207
    Likes Received:
    9,839
    First Language:
    English
    Primarily Uses:
    RMVXA

    This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

     
    #8
Thread Status:
Not open for further replies.

Share This Page