poiuyt0418

Villager
Member
Joined
Jan 15, 2017
Messages
13
Reaction score
0
First Language
English
Primarily Uses
What is the gray section of the pie chart? I realize most of the memory used by my play tests are unlisted in task manager as well.


debugger.png


Edit: Removed tag chrome debugger as this is also a more generic problem with memory later in thread
 
Last edited by a moderator:

Crabs

Veteran
Veteran
Joined
Nov 26, 2016
Messages
153
Reaction score
110
First Language
Portuguese
Primarily Uses
I see that "sprites" are missing on the chart.


Sprites can be considered as an object, but 657kb is too few. I'm pretty sure it's not a system object. It's probably on the gray section.
 
Last edited by a moderator:

poiuyt0418

Villager
Member
Joined
Jan 15, 2017
Messages
13
Reaction score
0
First Language
English
Primarily Uses
But this snapshot is from a new project with nothing changed and opening the menu multiple times in a row. It ends up saying I use around 500 mb of memory total in all the playtest processes if you add up all them yet around 2gb of memory total is used from my memory. My laptop ends up hanging. Should sprites end up using this much memory just by opening menu?


This is just the default map made when making a new project, I added absolutely nothing at all. Memory usage used up 50% of 4gb of ram just by opening menu multiple times
 
Last edited by a moderator:

Crabs

Veteran
Veteran
Joined
Nov 26, 2016
Messages
153
Reaction score
110
First Language
Portuguese
Primarily Uses
Should sprites end up using this much memory just by opening menu?

It shouldn't =/


[edit]


Ok... what the...


My desktop just hanged after I opened the menu several times. Seems sth has used 100% of CPU reading/writing capacity.


I spammed the menu button to reproduce the glitch. Did you opened the menu many times in a short period of time?


Is your OS windows 10?


[edit 2]


Umm... tried again. Same issue. Interesting.


I'm going to create a more specific topic if nobody else answers.
 
Last edited by a moderator:

poiuyt0418

Villager
Member
Joined
Jan 15, 2017
Messages
13
Reaction score
0
First Language
English
Primarily Uses
Rpgmaker mv was working properly a while back when I last used it (maybe a month ago). Just using the refresh method in my plugin causes the memory usage to go straight to 99+%


Yes windows 10 and i spammed the menu button. I also posted some stuff on reddit as well but got no attention for it as it seemed to be just my plugin at first.
 
Last edited by a moderator:

Latest Threads

Latest Posts

Latest Profile Posts

Test game. Find something broken. Fix. Re-test game. Broken thing fixed but new thing broken that wasn't before. What?!?! Uhg! :kaoangry:
I watched this youtube video of this reporter that went to a Flat Earth Conference. And there was just a whole lot of stupid in one room.
What?! You want 2 more hours of a playthrough? Well you got it! Come hang out with us while we dive even deeper into the awesome game Kindred Novel by BirdBunch! :LZSjoy:
Well, shoot. I didn't mean for the title screen to be there in my previous post.
Can everyone here just forget about that until I'm actually ready to formally announce it?

Forum statistics

Threads
122,071
Messages
1,146,281
Members
160,350
Latest member
rayhanalka
Top