When i run test it says "File is not found, It may have been moved or deleted."

PolluX17

Villager
Member
Joined
Jul 18, 2018
Messages
5
Reaction score
1
First Language
English
Primarily Uses
RMMV
Whenever i try to run the game it says "File is not found, it may have been moved or deleted" I don't have any plugins installed and i also tried making a new project but it didn't work and says the same.
 

Poryg

Dark Lord of the Castle of Javascreeps
Veteran
Joined
Mar 23, 2017
Messages
4,125
Reaction score
10,637
First Language
Czech
Primarily Uses
RMMV
And what's the file?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,235
Reaction score
7,617
First Language
German
Primarily Uses
RMMV
then your filepath does not conform to networking rules.
what is the full path where you created your projects? from drive letter to index.html?
then we can tell you which folders to rename
 

PolluX17

Villager
Member
Joined
Jul 18, 2018
Messages
5
Reaction score
1
First Language
English
Primarily Uses
RMMV
C:\Users\arcid\Documents\Games\Test
 

PolluX17

Villager
Member
Joined
Jul 18, 2018
Messages
5
Reaction score
1
First Language
English
Primarily Uses
RMMV
then your filepath does not conform to networking rules.
what is the full path where you created your projects? from drive letter to index.html?
then we can tell you which folders to rename
It is C:\Users\arcid\Documents\Games\Test I had RPG MV Before and this never happened, i don't know why it happens now.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,235
Reaction score
7,617
First Language
German
Primarily Uses
RMMV
does the same happen if you start the game with another browser like firefox?
There are several possibilities here, but my second guess would be browser restrictions, and firefox default's are better for this specific case.
 

PolluX17

Villager
Member
Joined
Jul 18, 2018
Messages
5
Reaction score
1
First Language
English
Primarily Uses
RMMV
Well i mean in the older versions there wasn't anything like this i think, i never had problems with it, i tried opening the index with another browser it worked but if i try to do it with the playtest button it doesn't work.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,235
Reaction score
7,617
First Language
German
Primarily Uses
RMMV
yes and no - there have always been cases like this depending on the security setting of the default browsers.
It has to do with the fact that MV uses webtechnologies on local files, which might be mistaken for a virus on a website trying to infect a computer - and something that can be blocked by browser settings if they're set to one of the higher security settings.

The fact that it works in Firefox shows that the problem is not in the project (could have been damaged files instead for example or a few other possibilities).
So now you can use that as an emergency workaround and know that the project has no bug, until the real cause is solved - which was most probably an update to the browser triggered there.

Sorry, I can't help you further on that search.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,235
Reaction score
7,617
First Language
German
Primarily Uses
RMMV
@EdiLinkBoss
does the workaround given above work for you?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,235
Reaction score
7,617
First Language
German
Primarily Uses
RMMV
you start firefox and open the index.html of the game
or you simply doubleclick the index.html if firefox is your default browser.
 

bighoncho

Veteran
Veteran
Joined
Nov 10, 2016
Messages
76
Reaction score
52
Primarily Uses
I had the same problem after I upgrade RMMV to 1.61, it seems to have problem with chrome only.
I could open the game via index.html using microsoft edge and firefox. Not sure why it does not work
with chrome browser anymore.

It could be a problem because the game cannot be played on chrome browser if you export using
html web browser method?
 
Joined
Apr 23, 2019
Messages
9
Reaction score
0
First Language
English
Primarily Uses
RMMV
I figured it out! If those options about firefox and all that don't work. I have another solution. Copy and paste the folder that has your game or demo in a separate area. Then press play test button, if play button fails and gives you that same error message. You have to deploy your game. Go to file>deployment>windows. After game is deployed go to the folder and test out the game or demo. After the game comes up and plays correctly for like a minute. Exit out of it, and now go back to RPG Maker itself and press that PLAY TEST BUTTON! Viola it's there! Yay!
It's so weird I know, but that's how I fixed this problem and I literally spent 4 hours of my night trying to figure this bull crap out. So definitely THIS WILL WORK!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Pootscooter wrote on Pharonix's profile.
Hey @Pharonix, just wondering what you're up to lately and if you've had an opportunity to check out the LTBS thread in the past few days...(a couple of us could really use your expertise). Hope you are well and Happy Thanksgiving!
Anyone know the best size image to put in signature?
Well, the local collections agency is hiring... bleh. I'm not rude enough for them to hire me. Even the people they collect FOR don't like dealing with them. >.>
EA: "Kids are buying currency, not using money to gamble. It shouldn't be illegal!"
Me: "So... kids should be allowed into casinos to buy poker chips and not spend them at the blackjack table? Pretty sure, even buying currency used to gamble is illegal for children."
Been hard at work in photoshop working with MOG scripts for main menu & victory result screens, might do all my maps and Npc chatter this week too!

Forum statistics

Threads
105,499
Messages
1,014,209
Members
137,154
Latest member
Kurtkakes
Top