White Screen Fix (Driver Update)

Seriel

Veteran
Veteran
Joined
Aug 16, 2014
Messages
3,013
Reaction score
504
First Language
English
Primarily Uses
Other
If you load MV and you get a white screen, open the start menu and type System Information (Or type msinfo32 into a Run dialog).

Go to Components -> Display.

Where it says name, what does it say? If it says "Microsoft Basic Display Adapter" or "Standard VGA Graphics Adapter", then this fix is for you!

Simply put, you need to update your drivers.

How do you do this?

Here's how,

From start menu, Type Device Manager. Load it.

Double click Display Adapters. It should have Microsoft Basic Display Adapter where mine has an NVIDIA thing.



Right click it and select 'Update Driver Software'



Choose to search automatically.



Now wait.

After it's done, you should have the correct Drivers and MV should work.

I have tried this on as may different computers as I can get my hands on.

If you have a Microsoft Basic Display Adapter or Standard VGA Graphics Adapter as the name and it doesn't fix your problem, let me know and i'll see what I can do,

Have fun using MV!
 
Last edited by a moderator:

kaine

Veteran
Veteran
Joined
Sep 29, 2015
Messages
154
Reaction score
77
First Language
Italian
Primarily Uses
RM2k3
i fixed this issue downloading a missing dll called opengl32.dll

the video card drivers were already updated.
 

Kane Hart

Elmlor.com
Veteran
Joined
Jun 27, 2014
Messages
656
Reaction score
166
First Language
English
i fixed this issue downloading a missing dll called opengl32.dll

the video card drivers were already updated.
I assume the engine not bundling the dll's so if you don't have them on the system its no go? 
 

Seriel

Veteran
Veteran
Joined
Aug 16, 2014
Messages
3,013
Reaction score
504
First Language
English
Primarily Uses
Other
Wait... do I have a Pinned Topic?

I have ascended.... :o

Anyhoo,

Yeah if you don't have that DLL that can also cause a White Screen so watch out for that too!
 

RishWars

Villager
Member
Joined
Oct 24, 2015
Messages
21
Reaction score
2
First Language
Hinglish
thanks for posting My problem is solved!
 

Seriel

Veteran
Veteran
Joined
Aug 16, 2014
Messages
3,013
Reaction score
504
First Language
English
Primarily Uses
Other
Updated OP.

This fix also works if you have "Standard VGA Graphics Adapter"
 

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
124
i fixed this issue downloading a missing dll called opengl32.dll

the video card drivers were already updated.
This fix will not update OpenGL drivers on all systems. You must install the correct drivers from AMD, nVidia or Intel. As it is, you need OpenGL ES2 support to actually play the games with hardware acceleration. opengl32.dll is a system library and is NOT supposed to come with RPG Maker MV. If you downloaded a openGL32.dll file from somewhere, you risk exposing your system to malware.

If you see "Standard VGA driver" your system has never had the correct driver installed, and that will require more research to figure out what the computer has.

The full AMD Catalyst driver (10.9 and later, which is any driver dated 2011 or later), nVidia (Versions dated October 2015 specifically state OpenGL ES support), and Intel onboard graphics support can vary significantly from part to part.
 

YLivay

Villager
Member
Joined
Nov 13, 2014
Messages
5
Reaction score
2
First Language
English
Primarily Uses
The reason this might be happening is because RPG Maker doesn't fall back to using OpenGL with software if the native drivers dont catch it.

Unfortunately, this also means that this fix won't work for us Linux folks trying to run it in a VM.

I tested with VirtualBox 5.x on Fedora 22 with no luck.

On the huge bright side, it seems  to  work perfectly fine in Wine!

You have to  configure the app to use the msvcr120.dll library natively and you're ready to go.

I'll post a short tutorial of it soon :)
 

Pistolero

Warper
Member
Joined
Dec 31, 2015
Messages
1
Reaction score
0
First Language
French
Hello Jackus, I just downloaded MV and my problem is when I open the trial there is a gray screen but I see the panel at the top, and as soon as I click somewhere a small window appears and it says RPG maker mv has stopped working. I did as you asked but the name that is written in Components-Display is Mobile Intel® 4 Series Express Chipset Family. I don't understand what the problem is, can you help please? Thank you.
 

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
124
Mobile Intel 4 chipsets seem to use GMA 4500MHD or GMA X4500 which both just about support up to OpenGL 2.1/OpenGL ES 2.0 which is the absolute minimum for both QtQuick (used by RPG Maker's editor UI) and WebGL (used by the game runtime for displaying things).

Given Intel's history width mediocre drivers especially for their older hardware, it might be that your graphics hardware given it barely reaches the minimum feature set required isn't really up for the job...

Still, try updating the drivers. Just because it says the proper name in the settings doesn't mean you have the latest bugfixed graphics drivers. It just means you don't have the even more awful Microsoft default drivers. If you're lucky, it will fix things.
OpenGL 2.1 is not OpenGL ES 2.0. ES2 requires DX9 feature parity at the barest minimum for ANGLE to work. This is why OpenGL 4.x is considered feature parity for ES2 since it's also feature Parity for DX11 and wouldn't need ANGLE to operate. As it is, only Ivy Bridge and Haswell parts (i3/i5/i7-3000 and 4000 series) have capable iGPU parts. The GMA parts are not capable parts, and even if you have the right drivers, it's likely the GPU+CPU combination is too weak to operate.
 

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
124
Obviously, but that chipset is indeed claimed to support OpenGL ES 2.0. Why did you think I listed both separately? ;)

Also again as I wrote above, that bare minimum is probably not enough (as you seem to agree). But I found it indeed listed as allegedly supporting OpenGL ES 2.0.

Also I believe RPG Maker might run even without proper WebGL support (albeit slowly with the canvas fallback). Only QtQuick's OpenGL requirement should be an actual hard requirement to run the editor
All the Intel GPU's before Sandy Bridge have single or double-digit passmark numbers. They are functionally incapable of playing anything new... let alone anything 10 years old without it being a painful experience. So that suggests the user has a Intel CPU of 2008 vintage or older. Also I'm not sure where you're seeing ES2 support, not that it would be used anyway.

This comes back around to the debug thread where I stated

A combination of weak CPU + weak GPU (Single-thread Passmark below 800, or GPU Passmark below 500) will no doubt experience poor frame rate and audio stuttering.
Unfortunately people look at mobile games (See the recent FF6 port) and go "why can't I do that?", since those games are written against OpenGL ES2 as well and perform better than MV does, forgetting the fact that MV is a HTML5 game which has the overhead of a web browser that the previous XP/VX engines didn't.
 

Krazymouse

Villager
Member
Joined
Jun 1, 2015
Messages
12
Reaction score
2
First Language
English
Primarily Uses
I've been using RPG Maker MV to make my game, but I'm getting the White Screen bug whenever I try to playtest the game. It did not do this before, but it is doing it now.


I have a Nvidia GT 970 and my drivers are updated, but the bug still happens, and on different devices too. What should I do?
 

DjinnScythe

Warper
Member
Joined
Jan 2, 2017
Messages
2
Reaction score
1
First Language
English
Primarily Uses
Hello, I'm new to using RMMV, so I have also same problem for white screen.


I have two video graphics.


PRIMARY: Intel(R) HD Graphic 5500


SECONDARY: NVIDIA GeForce 940M


(Processor: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz, 2394 Mhz, 2 Core(s), 4 Logical Processor(s) )


MICROSOFT WINDOWS 10 HOME 64 bit (1366x768 60 hertz)


I have no idea what should I do. I checked on System Information, I don't see any "Microsoft Basic Display Adapter" or "Standard VGA Graphics Adapter".
 

Users Who Are Viewing This Thread (Users: 0, Guests: 2)

Latest Threads

Latest Profile Posts

Working on a Patch to integrate AlphaABS into random generated Dungeons. Was a bit tricky, but the outcome is a real Life Changer!!

Will release it the next days!
Been pretty busy... but I got a better headset for recording and listening today. Dad says that he'll consider taking me to Great Wolf Lodge for the first time once I finish summer classes (my final semester!) I'll be taking my plushie friends with me: Bendy, Lolbit, and Helen Henny. (I WUV PLUSHIES!)
SF_Monster3,4 added!


My only regret is the portal mirror effect is too subtle to show up in these GIFs. It probably just needs more sparkles. :LZSwink:
Microsoft: Hey, let's waste money advertising the Xbox Series X when nobody has any in stock, we don't seem to be making more, we aren't taking preorders and you can't get on a waiting list. BEST. IDEA. EVER.

Forum statistics

Threads
105,647
Messages
1,015,261
Members
137,324
Latest member
milancete
Top