Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
I have tiles set out, and yet when I playtest it it's as if there's nothing?
 

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
257
Reaction score
138
First Language
English
Primarily Uses
RMMZ
Are u starting on the correct map?
Are there any events which run as you start?
Share a screenshot of the map where your character starting position is set, pls.
 

Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
Sure it's correct, no events. And I'm not sure what you want screenshot when it's just blank...
 

Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
This might not make sense, but surely everything should be displayed in a game?
RPGMZ_AL9LPKUbF3.png
 

clownbf

Villager
Member
Joined
Oct 11, 2021
Messages
12
Reaction score
36
First Language
English
Primarily Uses
RMMV
Are you pressing the green button that says “Playtest?” If you’re trying to test in the event editing mode, it will most likely put your character in a completely black room (if that’s the case)
 

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
257
Reaction score
138
First Language
English
Primarily Uses
RMMZ
The image you provided is just a bunch of pixels.. can you show us your editor before running a playtest?

If you create a band new project and without doing anything run a play test.. does it appear fine?
 

Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
My playtest button is blue, not green. And I didn't think it matters which mode it's in, before it playtested many times successfully when I was in event-editing mode... and it appears fine if I use different maps, it's just this one doesn't...
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,086
Reaction score
15,501
First Language
English
Primarily Uses
RMMV
Please show a screenshot of your map in the editor, and when you playtest. I'm not sure what that screenshot up above is of - a single tile, zoomed way in, the map, playing? It doesn't look like anything, and it's not black/dark. Is that what your map is meant to look like, or what it does look like when you play, or something else?

Is this tileset one you've used on other maps? Is it one you created / added yourself?

Is your starting spot on this map or are you transferring there from another map? If the latter, if you change your starting spot to be on this map, does it appear correctly?

Quite a few questions there - please make sure you answer all of them, or I'll just have to ask them again :)
 

Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
I start the game there (but tried transferring, and still blank). I don't use it on other maps, but I tried replacing some others now and it's still blank, and it's an image I got online, but not sure how that matters as I thought the engine should load everything as long as there's something (blank is usually those white squares while editing). Think it's zoomed in because it's too large for it otherwise. That is the map in the editor, in-game it's just black as if there's nothing. What I don't get is why it's not loading it, as usually it loads everything...
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,266
Reaction score
8,722
First Language
German
Primarily Uses
RMMV
That is the map in the editor,
no, it was not - because the editor is nowhere visible in the screenshot.
when we say "map in editor" we mean the screenshot INCLUDING the editor framework with the buttons to get a better reference of what is shown.
 

Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
What difference does the editor make? It's not any options around affecting it, either, it's specifically when the maps are changed, but anyway, here:
RPGMZ_ammhE1R6Gk.png
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,086
Reaction score
15,501
First Language
English
Primarily Uses
RMMV
Where did you get the image? It doesn't look at all like a tileset to me, and you definitely don't have it in the right spot. Also, did you resize the screenshot and make it more narrow? That selection box doesn't look square to me.

Please give us a link to where you originally got it, and say what it's meant to be. Even viewing in the editor, I still can't figure out what it is.

Can you also add a screenshot of what it looks like when you play the game? Make sure you have an actor in the party, and the System tab is not set to start with them transparent.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,266
Reaction score
8,722
First Language
German
Primarily Uses
RMMV
What difference does the editor make?
it shows us the scale of what the "pixels" are.
and in addition to Shaz' comments above it shows that there is something seriously wrong with your tileset and tilesheet definitions, in addition to a distorted monitor resolution.
Can you give a screenshot of yout tileset definition in the database?

Do you know that there are six different formats for tilesheets, and that each slot in the tileset definition ONLY allows the use of a tilesheet in the specific format intended for that slot?
Placing a tilesheet formatted for B into the A1 slot will massively distort the tiles, but even that is not enough to explain what you're showing in the screenshot.

EDIT:
just got the post above.
Those are BACKGROUNDs, they are NOT Tiles.
You CANNOT use them as tiles at all.

Please read the help file for the asset standards, those pictures can be used for example for Battlebacks or parallax mapping, but never as tiles.
 

Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
Even if it should be used as a parallax image, though (which I tried, but then the character couldn't move about...) - it doesn't explain why the result is blank, does it?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,266
Reaction score
8,722
First Language
German
Primarily Uses
RMMV
it doesn't explain why the result is blank, does it?
yes it does
the picture is simply too big to be loaded by the engine as-is, so you only see the blank background without any tiles in game.
because even used as parallax, the size of the parallax has to be set compatible to the map itself. There are rules for that (for a parallax map, size of background in pixel = number of tiles in the map multiplied by 48. So a 50x50 tiles map needs a parallax background of 2400x2400 pixel.
Your pictures are much bigger than that.
 

Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
So I can't even use them as parallax?
 

C64_Mat

System Masters
Veteran
Joined
Apr 3, 2021
Messages
90
Reaction score
76
First Language
English
Primarily Uses
RMMV
@Nereid With the greatest of respect, please try your best to read the advice you're been given! You're coming across a little combative and a smidgen uncooperative!

When we're trying to help you, we need the most information we can get. So if someone asks for a shot of the editor, it's the full thing we need. That's what helps us to ascertain where things are going wrong.

There are a lot of tutorials on how to use parallax images as maps and have your character be able to move about.

Also, no, the image you've got isn't useless - you just need to scale it properly in something like GIMP so it fits your map. Again, there are plenty of tutorials for this!

It also appears that you have a misunderstanding of how tiles work. The tabs - especially the A tab, and within that A1 specifically, have properties for autotiling, which is something you must wrap your head around if you're using custom tiles. Again, there's plenty of information out there that's far more verbose and detailed than anything we could cram into this post.

When it comes to using custom images as your map, there isn't a one size fits all solution, as each person has different needs, based on map size, character movement, eventing etc. So when you get asked to provide something specific so we can help you, even if you don't understand the reason for the request, please provide it - we're asking for a reason!

I hope this information is helpful.
 

Nereid

Veteran
Veteran
Joined
Sep 22, 2021
Messages
193
Reaction score
60
First Language
none
Primarily Uses
RMMZ
Links to these tutorials? I have Gimp, but it's so complex...
 

Latest Threads

Latest Posts

Latest Profile Posts

I don't really have any neat updates today about how I screwed up programming... But if you want to observe the intensenes of me programming, then you can check out my stream :)
New Weapons.gif
No more spam from me today, I promise! Just wanted to upload this, people have been giving me feedback that my weapon sprites (which were RTP) clashed badly with my battlers for ages, so today I finally took the plunge and updated them! Really happy with how they came out :D :D
So Facebook fraudulently took money from me. They even went through my PayPal accounts to find a card that had the money on it. Thinking about deleting my Facebook account because this doesn't happen on twitter, not even close.
Today the 2nd part of the RPGMakergame "A Thief's voyage" came out.


Go show DutchPowerCreations some love.
love it when you forget to put a certain thing in the movement route and suddenly a character starts spinning at 10000 rpm

Forum statistics

Threads
116,992
Messages
1,103,661
Members
152,888
Latest member
WallyBalljacker
Top