Why does RPG Maker VX Ace not respond when I try to play test in full screen?

jjbones123

Veteran
Veteran
Joined
Aug 2, 2016
Messages
54
Reaction score
30
First Language
English
Primarily Uses
N/A
So, I am operating on windows 10 and my graphics card is a NIVIDIA GeForce GTX 650 Ti.


When trying to play test the game i'm making in RPG Maker VX Ace, I attempt to make the game full screen so I can see the small details in the game better. But when I push Alt + Enter at the same time, the play test window just freezes and it's says (Not Responding) in the top left of the game window. If I leave it alone long enough, it seems to just give up and continue playing in a windowed resolution.


While I am aware of Fullsceen++ and have been using it for awhile now. I would like to find an actual solution to the problem rather than a work around. That and this is my game that i'm making by myself; I wouldn't feel right in using someone else's script. Speaking of script, there are no custom scripts that would prevent the game from launching in full screen. The only custom script that was in the game was the previously mentioned Fullscreen++ but I have since removed that and found that it still refuses to open at a full screen ratio.


Does anyone know why this problem occurs and how to fix it please?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,000
Reaction score
6,678
First Language
German
Primarily Uses
RMMV
1) check compatibility settings and make sure that you disabled any special W10 function.


I don't know if W10 added new functions for the keyboard, but if it does and tries to redirect that alt-enter to a different function, it could explain such behaviour.


Set compatibility to XP or W7 if possible, that should clear that up.


2) try to use yanfly's core and increase the screen size to Ace' maximum of 640x480, then test again.


The default screen size of Ace is NOT a standard screen size, and some graphic drivers might get problems trying to maximize that. 640x480 is an officially supported screen size and should always work.


3) try reinstalling the editor, and test if this happens only on playtest or also on launching the game with the game.exe
 

jjbones123

Veteran
Veteran
Joined
Aug 2, 2016
Messages
54
Reaction score
30
First Language
English
Primarily Uses
N/A
1) check compatibility settings and make sure that you disabled any special W10 function.


I don't know if W10 added new functions for the keyboard, but if it does and tries to redirect that alt-enter to a different function, it could explain such behaviour.


Set compatibility to XP or W7 if possible, that should clear that up.


2) try to use yanfly's core and increase the screen size to Ace' maximum of 640x480, then test again.


The default screen size of Ace is NOT a standard screen size, and some graphic drivers might get problems trying to maximize that. 640x480 is an officially supported screen size and should always work.


3) try reinstalling the editor, and test if this happens only on playtest or also on launching the game with the game.exe
I tried changing the comparability to both XP and 7, neither worked. It does the same thing both times: Alt+Enter, window says: (Not Responding) and then it seems to just give up and remain small windowed mode.

I also tried reinstalling RPG Maker, but it also makes no difference.

I have yet to try your second suggestion as I am not familiar with what you mean? 

I do appreciate the help though. :)
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,000
Reaction score
6,678
First Language
German
Primarily Uses
RMMV
Ace has a default screen size of 544x416. If you check the windows display settings, you will not find those numbers there, the smallest windows screen size is 640x480.


That is why there are usually black borders around the RM-Games in full-size.


However, it might be that your display driver has problems handling that non-standard screen size on full screen. To test that, you need to change the screen size of your game to 640x480 (which is the maximum that Ace can handle).


That change can only be done by scripts, and yanfly's core engine is one of several scripts that have that option (you'll need to edit its configuration part to change to 640x480, that is not automatic).


Increasing the screen size on a game that was not intended for the larger size can result in map-looping, but ignore that for now. This test is just to check if it is the display driver having problems with the screensize, and if it freezes even on 640x480 then we have to search elsewhere for the cause.
 

jjbones123

Veteran
Veteran
Joined
Aug 2, 2016
Messages
54
Reaction score
30
First Language
English
Primarily Uses
N/A
Okay, I applied the Yanfly's core script and set the resolution to 640x480, but it still reacts the same way. Its weird because the script is clearly taking effect on the play test window but it only seems to make a black border on the inside of the play test window? (I'll add a picture so you can see what I mean)

Even if I go into the properties of the play test window and force it to open in full screen, any attempt always goes the same way: Tries to launch in fullscreen > (Not Responding) / freezes and then after awhile of waiting, the play test window gives up trying to launch in full screen and remains a small windowed mode.

I can't think of what's stopping it. there aren't any custom scripts (except the now applied Yanfly's core script). I don't think the fact that i'm displaying it on my TV through use of a HDMI cable instead of a monitor would make much of a difference...would it? 

Stranger still, the Full screen ++ script does work and will even force the play test window to launch in full screen should I set it to do so in the properties. What else can I try? 

new resolution black border.png
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,000
Reaction score
6,678
First Language
German
Primarily Uses
RMMV
As said, the black borders are normal for that because you increased screen size. The important info was that increasing the size didn't solve the screen.


However, that the use of the fullscreen++ script does work, indicates it is something in the script and that the fullscreen script simply overrides the error...


Try the following:


Make a backup of the project, then make a new project.


Copy all default scripts from the new project into the backup, overwriting the default scripts in the backup.


This is a lot of copy&paste, but the only way to test if something damaged the original scripts of the engine.


If that doesn't help, please give a screenshot of your script editor where all scripts you've installed can be seen (I hope you used their original names?),
 

jjbones123

Veteran
Veteran
Joined
Aug 2, 2016
Messages
54
Reaction score
30
First Language
English
Primarily Uses
N/A
Okay so, rather than copy and paste all the files, I tried launching older projects i've made in full screen. These projects were back when I just messed around with RPG Maker, so none of them have any custom scripts. I even tried creating a brand new project just to test it, but the same thing still happens: Alt+ Enter > (Not Responding) and after awhile gives up and remains in windowed mode.


As for the scripts in "That game i'm making demo" (really got the creative juices flowing for that one huh?) I removed full screen ++ before I posted this question, so the only custom script I have for this project is Yanfly, "Font" Which is used to set a custom font for the games text and "Window" which while the name might make you think it's related, is just to make the window black and a solid color. Everything else it the same so here is a screenshot showing the custom script section:

still no workie.png
 

jjbones123

Veteran
Veteran
Joined
Aug 2, 2016
Messages
54
Reaction score
30
First Language
English
Primarily Uses
N/A
I have also discovered that games iv'e made in RPG Maker that could previously launch in full screen before no longer do. I haven't added any script or altered anything so why is this happening now? 

I've done some research and found that a common reason why some people have this issue is due to their video cards being outdated. Could that be why? and how do I know my video card is outdated?? 
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,000
Reaction score
6,678
First Language
German
Primarily Uses
RMMV
if the other games have the effect without any change, then it is definitively something non-RM related on your computer.


As for graphic drivers outdated, no, that can't happen with your Ace games - it was a problem with MV (the newest engine) and graphic drivers that were several years old while MV needed a more modern version.


It could be that your graphic driver has been damaged, and because of that I suggest updating to the newest driver anyway - it can't hurt.


Unfortunately I'll give that only a fifty-fifty chance at max, and if it isn't the graphic driver you need to search every other program on your computer for which might cause problems
 

jjbones123

Veteran
Veteran
Joined
Aug 2, 2016
Messages
54
Reaction score
30
First Language
English
Primarily Uses
N/A
Okay, i'll look into it. Thanks for the help. :)
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Why is it so hard to accept existential stoicism? To insist stoics must be deterministic is like insisting God couldnt create evolving animals. Drop the dogmas and concider the compatible mechanics
I just had a duel at Duel Links, and started right away with a fusion monster... felt like an actual yugioh main character :3
Now listen closely... Here's a little lesson in trickery, This is going down in history...
So the four of my friends are singing a song and I'm like... ohoho I don't know this song. Better act like I do!
A boss that spams confuse, blind, silence, oil and slow on all party members? Good idea FF12 *headdesk*

Forum statistics

Threads
93,511
Messages
913,113
Members
123,046
Latest member
califert
Top