XS - Menu Delux

Alcortiza

Villager
Member
Joined
Aug 24, 2012
Messages
25
Reaction score
5
Primarily Uses
Gotta add a create_background below the create_menu_animations.

So it would look like this.

Code:
     @actor = $game_party.menu_actor    if SceneManager.scene_is?(Scene_Menu)    @backgrounds = []    @animations = []    # create_menu_backgrounds    # create_menu_animations      create_background
 

Tofuffalo

Veteran
Veteran
Joined
Oct 21, 2012
Messages
33
Reaction score
0
First Language
English
Primarily Uses
Oh man I had no idea, thanks very much Alcortiza, it works perfectly now!
 

PlsDontAbductMe

Villager
Member
Joined
Dec 24, 2012
Messages
26
Reaction score
0
First Language
Engrish
Primarily Uses
Fantastic!

This is really making my stuff look appealing, now.
 
Last edited by a moderator:

No1434

Villager
Member
Joined
Mar 2, 2013
Messages
15
Reaction score
3
First Language
Indonesian
Primarily Uses
I got nothing to say for this script.

It look fantastic.

:D
 

tehmooncow

Warper
Member
Joined
Mar 14, 2013
Messages
1
Reaction score
0
First Language
English
Primarily Uses
Hey, quick question: I set the menu to custom because I wanted to be able to have the menu options

unlock during certain events but I'm not quite sure exactly where I'm supposed to put the script for

menu custom and if there's a certain order or way to put the script in, if I want to have them come in 

one by one in different events. I'd appreciate the help :D , cheers.
 

anavn

Veteran
Veteran
Joined
Feb 24, 2013
Messages
279
Reaction score
2
First Language
French
Primarily Uses
No there is no special order .through you will cause a crash if you make to many extra events becerful.

I have also a question the script work but I would like to allow the costume evens (script calls) to select the character before starting like the equipment.
 

Raine Fallon

Stark
Veteran
Joined
Apr 7, 2012
Messages
95
Reaction score
17
First Language
Norwegian
Primarily Uses
Don't know if it just me, but I seriously can't download the core script nor the script at all...seems like the links themselves are outdated. What a shame, I really wanted to give this script a go!
 

gpgekko

Nevermind me, I'll just cast shadows on your walls
Veteran
Joined
Jan 23, 2013
Messages
114
Reaction score
7
First Language
Dutch
Primarily Uses
Don't know if it just me, but I seriously can't download the core script nor the script at all...seems like the links themselves are outdated. What a shame, I really wanted to give this script a go!
I'm afraid it's just you, the links work for me... Sorry :/

You could try and see if you can reach this page, all his scripts are in there: http://niclas-thornqvist.se/rpg/scripts/ace/
 
Last edited by a moderator:

Blackstarwolf

Villager
Member
Joined
Mar 14, 2012
Messages
27
Reaction score
18
First Language
German
Hello, I have a little problem with the journal script, it doesn't work for me.
I only get many errors x.x

Have somebody a idea?
Sry my english isn't so good x.x
 

Nosleinad

Storyteller
Veteran
Joined
Dec 12, 2012
Messages
351
Reaction score
28
First Language
Portuguese
Primarily Uses
Hello Blackstar,

  Are you talking about the journal script from the Xs series? If so there's another topic for it.

  But even so, plz try to describe the error messages that you're getting, and when they occur.
 

Blackstarwolf

Villager
Member
Joined
Mar 14, 2012
Messages
27
Reaction score
18
First Language
German
Okay where is it o.o?
I have many to many errors x.x
I tried things like :quest => ["Notizen", "Load your saved progress.", 4165, true, false, Scene_Journal] or :Scene_Journal => ["Notizen", "Load your saved progress.", 4165, true, false]

And always other error messages x.x
 

Blackstarwolf

Villager
Member
Joined
Mar 14, 2012
Messages
27
Reaction score
18
First Language
German
Okay, a new little graphic problem.
The menu background is to dark, but I can't find settings for the color.

I though I can change the opacity too, but here I miss also the settings.
Somebody a idea?
 

ct_bolt

Creator
Veteran
Joined
May 3, 2012
Messages
656
Reaction score
188
First Language
Javascript
Primarily Uses
RMMV
Okay, a new little graphic problem.

The menu background is to dark, but I can't find settings for the color.

I though I can change the opacity too, but here I miss also the settings.

Somebody a idea?
You could try and set this line from XS Core:

USE_TONE = trueto false like this:

USE_TONE = falseCheck out the rest of XS - Core, it might help. :)
 

Blackstarwolf

Villager
Member
Joined
Mar 14, 2012
Messages
27
Reaction score
18
First Language
German
Now I have no color.
But the background is still very dark.

And I have only the Core and the Menu Delux.
 

sanul17

Villager
Member
Joined
Mar 18, 2013
Messages
11
Reaction score
0
First Language
Indonesia
Primarily Uses
Hey there! such an amazing script! everything work properly, until i realized that...

when i set menu custom to be "true", the load window from continue in title screen, was hidden, even though i cant hear the SE, but i the loadwindow its totally disappear,

but, when i set it back to be false(default), its became to normal...

second point, if saved my game, and restart it, my "pre-title"(i take it from you too) its didnt appear/skipped

why? and how to fixed it? i tried several time to know why
 

Camelslayer

Hates All of Camelkind
Veteran
Joined
May 1, 2013
Messages
35
Reaction score
0
First Language
English
Primarily Uses
Wonderful script.

I do have a problem though-

The TP doesn't display at all.
 

Nicke

Fortune seeker
Veteran
Joined
Apr 4, 2012
Messages
539
Reaction score
535
First Language
Swedish
Primarily Uses
RMMV
Wonderful script.

I do have a problem though-

The TP doesn't display at all.
Are you using a script that changes the menu or the TP in some way perhaps?

If not, try to install this script in a fresh project and add the scripts you have to see which one is in conflict.
 

Camelslayer

Hates All of Camelkind
Veteran
Joined
May 1, 2013
Messages
35
Reaction score
0
First Language
English
Primarily Uses
Are you using a script that changes the menu or the TP in some way perhaps?

If not, try to install this script in a fresh project and add the scripts you have to see which one is in conflict.
Nope.

I installed the menu and core scripts unedited into a new project. The menu TP stayed locked at 0. Even when I had TP. So it might be something up with the base script.
 

ct_bolt

Creator
Veteran
Joined
May 3, 2012
Messages
656
Reaction score
188
First Language
Javascript
Primarily Uses
RMMV
Nope.

I installed the menu and core scripts unedited into a new project. The menu TP stayed locked at 0. Even when I had TP. So it might be something up with the base script.
There is a setting for that in the database to preserve tp. Other>Special Flag>Preserve TP (Normally tp gets reset after each battle)

You might have already known that though... :)
 
Last edited by a moderator:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

I just noticed the minigame challenge. Now considering...
My project just started lagging during battletest and I haven't been able to figure out why...
Oh, Google is now warning users against installing extensions on Edge Chromium
on my plate today- animation.
"Your service has been identified as part of an outage. This is expected to be restored by 7pm IN SEVEN DAYS!!!" Guess I won't be around as much over the next week :(

Forum statistics

Threads
94,471
Messages
921,161
Members
124,311
Latest member
cadenm1223
Top