Yami Skill Equip issues

Discussion in 'RGSS3 Scripts (RMVX Ace)' started by Kevin Eontrainer, Sep 5, 2016.

  1. Kevin Eontrainer

    Kevin Eontrainer Veteran Veteran

    Messages:
    95
    Likes Received:
    5
    First Language:
    English
    Guys, I'm currently trying to use Yami's skill equip scripts, but there are some issues.


    Note that I'm using  Expanded Skill Description script by Soulpour777.


    The first time I use Yami's script, I put it BELOW the ESD (Expanded Skill Description) script. then  it shows this error message when I opent the "Skills" menu..


    error 1.png


    Then I tried to put it ABOVE the ESD, I thought it worked at firt but I realize that the menu shows up but does absolutely nothing.


    Like this...


    error 1.png


    So I thought... The ESD script is the culprit, right? (Actually yes, I created a new project and installed both Yami and ESD, this happens BUT when I remove the ESD Yami's script works)


    So, I remove the ESD script. So, I only have Yami's script without the ESD. This error occurs when I open "Skills" menu. error2.png


    I also use: Yanfly's Battle Engine, Yanfly's Menu Engine, Yanfly's Ace Status Menu, BlackMorning Status script


    Please help, guys... I really want this system to be implemented in my game.. Thanks in advance.
     
    #1
  2. HexMozart88

    HexMozart88 The Master of Random Garbage Veteran

    Messages:
    1,686
    Likes Received:
    3,035
    Location:
    A small hut in the forest
    First Language:
    English
    Primarily Uses:
    RMVXA
    OK, so i just installed the script into a new project. I tried it out and it worked fine, so it has to be a problem with one of your scripts. If I had to guess, I think it would be Yanfly's Menu Engine. Comment each of the scripts you have one by one and test after each. When you've commented one and the script works, you know that's the culprit. After that, you may need to play around with the positioning of the scripts or ask for a compatibility patch. 
     
    #2
  3. Kevin Eontrainer

    Kevin Eontrainer Veteran Veteran

    Messages:
    95
    Likes Received:
    5
    First Language:
    English
    I think what I really need is a compatibility patch.. Because I can't afford to remove any of the scripts I've used.. Especially  Yanfly Menu Engine
     
    #3
  4. HexMozart88

    HexMozart88 The Master of Random Garbage Veteran

    Messages:
    1,686
    Likes Received:
    3,035
    Location:
    A small hut in the forest
    First Language:
    English
    Primarily Uses:
    RMVXA
    You know what, I'm going to install all of those scripts you mentioned, try them out myself and see which one is causing the problem. If I can, I will try to make them compatible. 


    EDIT: Seems to be BlackMorning that's causing the problem. I didn't download it (I've downloaded a bit too much lately, not much was good for my computer), but without it, the whole thing works fine (except for a glitch with the numbers on the health bar). So, yeah. Although, in the description, it does say that it's not compatible with Yanfly's status. Maybe the problem is not with Yami's script at all.  
     
    Last edited by a moderator: Sep 6, 2016
    #4
  5. Kevin Eontrainer

    Kevin Eontrainer Veteran Veteran

    Messages:
    95
    Likes Received:
    5
    First Language:
    English
    I tired removing BMStatus and the error persists... Although I havent removed the BMBase
     
    #5
  6. HexMozart88

    HexMozart88 The Master of Random Garbage Veteran

    Messages:
    1,686
    Likes Received:
    3,035
    Location:
    A small hut in the forest
    First Language:
    English
    Primarily Uses:
    RMVXA
    Try that then, I guess. 
     
    #6
  7. Kevin Eontrainer

    Kevin Eontrainer Veteran Veteran

    Messages:
    95
    Likes Received:
    5
    First Language:
    English
    @HexMozart88 I tired it and it still works fine... So BM is not the culprit...
     
    Last edited by a moderator: Sep 6, 2016
    #7
  8. HexMozart88

    HexMozart88 The Master of Random Garbage Veteran

    Messages:
    1,686
    Likes Received:
    3,035
    Location:
    A small hut in the forest
    First Language:
    English
    Primarily Uses:
    RMVXA
    OK then. I don't really know why it's working for me and not for you, as I have about a million other scripts in my editor. But, perhaps it has something to do with the order of your scripts. But I think when I put in the scripts, I put Yami's at the bottom if that has anything to do with it. 
     
    #8

Share This Page