Yanfly Jump Skill Sequence (gravity? don't know her)

Discussion in 'Javascript/Plugin Support' started by captainproton, Jan 5, 2019.

  1. captainproton

    captainproton Dangerously Nifty Veteran

    Messages:
    1,271
    Likes Received:
    576
    Location:
    Missouri
    First Language:
    english
    So, i'm trying to implement a Final Fantasy Dragoon-style Jump attack, and i'm following the instructions listed out here:
    http://yanfly.moe/2016/07/02/tips-tricks-jump-final-fantasy-4-rpg-maker-mv/

    I have followed every instruction, installed every plugin, and put in every code into the correct note boxes.

    AND YET.

    When i have my monk use the Jump skill, the camera does its thing and the sprite does indeed jump off the screen
    Monk is unselectable the next turn, still off the screen. Good.
    Same thing next turn.
    Then, the Jump state expires on the 3rd turn, and Monk just...doesn't come down. He's still up there, the Land skill never gets used, and he is still selectable. I can even make him use Jump again! While he's still up in the air!

    Help!

    EDIT: Someone in another forum suggested also including the Target Core script from yanfly, but when i have that installed and On, I get this error when it comes around to the "jump"ing Monk's turn:
    Capture.PNG
     
    Last edited: Jan 5, 2019
    #1
  2. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,193
    Likes Received:
    757
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    Whenever you get an error message, please include a screenshot of the full error message from the Console. You can open the Console by pressing F8 during playtest.

    That being said, the "require(...).Window.get(...).isDevToolsOpen is not a function" error is explained by Yanfly here.
     
    #2
  3. captainproton

    captainproton Dangerously Nifty Veteran

    Messages:
    1,271
    Likes Received:
    576
    Location:
    Missouri
    First Language:
    english
    Tried this, and it doesn't work. All that shows up is a window asking if i want to connect my computer to a projector or a second monitor.

    After going through and making sure all the scripts were updated, it finally functions properly.
    Thank you!

    EDIT: Wellp! It DID work when i did a battle test in the troop tab, but when i tried it in a proper playtest, I keep getting a "There was no effect" message in battle when i select the skill. It doesn't even go through the animation and say it misses, it just "has no effect."
    I've tried it with multiple enemies with no resistances or immunities, and just the same message.
    Help me, I'm dying.
     
    Last edited: Jan 8, 2019
    #3

Share This Page