RMMV Yanfly Message Core - Name Box issues

MerlinCross

Veteran
Veteran
Joined
Jun 8, 2015
Messages
208
Reaction score
88
First Language
English
Primarily Uses
Hello, I'm having some trouble with this. A rather weird bug is happening when I use the command for nameboxes. It looks fine and all but there's a couple problems. Namely that the boxes will vanish.

As an example;
\n<Merchant?> So what are you buying?

Will show up in the small namebox but afterward talking to the NPC again and the name box won't show up. Other problems is that map changes seems to have it break, and swaping characters around. So.... what am I doing wrong?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,921
Reaction score
7,450
First Language
German
Primarily Uses
RMMV
please show us screenshots of the event with the command that does not work, and screenshots of your plugin manager to see the order of your plugins.
 

MerlinCross

Veteran
Veteran
Joined
Jun 8, 2015
Messages
208
Reaction score
88
First Language
English
Primarily Uses
20200926021110_1.jpg20200926021113_1.jpg
Plugins. Messagecore is right below Core which is where it should be as I understand it. However perhaps some other plugin is bothering it.
20200926021359_1.jpg20200926021754_1.jpg













And screenshot of the command which was in the OP anyway. Just \n<Name I wish to use>

Talking to the Guard(Left one) doesn't break the Merchant's Textbox but Merchant's event will end up breaking the guard's textbox. And just to also be clear, it breaks when changing maps among other issues.
20200926022146_1.jpg
And just to dot my i's and cross my t's here, an example of the door/transfer events I use. Which is just MV's standard transfer. Even if it isn't it doesn't add in any text at all, plugin orders, or script commands.
 

Tiamat-86

old jrpg gamer
Veteran
Joined
Dec 5, 2017
Messages
503
Reaction score
196
First Language
english
Primarily Uses
RMMV
i doubt this is causing the issue but going to throw it out there because i see it.
why do you have auto passive states twice?

item core and skill core should be switched places.
everything under auto passive states should be rearranged too.
all yanfly plugins should be in the same order that they appear on yanfly's website.
 
Last edited:

MerlinCross

Veteran
Veteran
Joined
Jun 8, 2015
Messages
208
Reaction score
88
First Language
English
Primarily Uses
20200926130726_1.jpg
Secondary Statecore is deleted. Skill and Item swapped. And Yanfly reorganized to I believe up to the list. And the error keeps happening.

Edit; I think I have found the problem. Well the source of it. It's OrangeAntiLag. Something about it seems to break the name boxes.
 
Last edited:

Tiamat-86

old jrpg gamer
Veteran
Joined
Dec 5, 2017
Messages
503
Reaction score
196
First Language
english
Primarily Uses
RMMV
from what i can tell the plugin is up to date, and dont see anything wrong with the event itself.
try turning off all plugins except message core and running a test to see if the problem is still there.
if not turn on the other yanfly plugins and test again.
then turn on the other plugins for a final test.

my best guess is that 1 of the other plugins just isnt compatible with yanfly's so it would just require some trial and error to figure out which 1.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,921
Reaction score
7,450
First Language
German
Primarily Uses
RMMV
And the error keeps happening.
have you started new playtest or did you load a saved playtest?
part of the plugins is stored in the savegames, so any change in the plugin manager should make you star new playtests as otherwise the loaded savefile can contain incompatibilities.

an antilag plugin should not cause such an effect, that would be strange - but the error has to be something in the plugins as I don't see anything wrong with the events either
 

MerlinCross

Veteran
Veteran
Joined
Jun 8, 2015
Messages
208
Reaction score
88
First Language
English
Primarily Uses
have you started new playtest or did you load a saved playtest?
part of the plugins is stored in the savegames, so any change in the plugin manager should make you star new playtests as otherwise the loaded savefile can contain incompatibilities.

an antilag plugin should not cause such an effect, that would be strange - but the error has to be something in the plugins as I don't see anything wrong with the events either
from what i can tell the plugin is up to date, and dont see anything wrong with the event itself.
try turning off all plugins except message core and running a test to see if the problem is still there.
if not turn on the other yanfly plugins and test again.
then turn on the other plugins for a final test.

my best guess is that 1 of the other plugins just isnt compatible with yanfly's so it would just require some trial and error to figure out which 1.
It has to be the anti lag. I've attempted to figure this out by turning everything off and flipped on one by one. Even if it's not anti lag itself, it must have a hand in it somehow. Removing it/turning it off seems to have fixed the issue though still unsure as to why?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Woke up on an awful nightmare of being banned here because some mod didn't liked me in a super-heroes freeform round robin RP where I used throwing normal hammer as power and it was qualified being too OP. XD Nice to read you all guys. Will not wait next nightmares.
Staring at all the RPG Maker versions I have and realizing that my project has been a long time coming. But, I finally feel like I have the knowledge and experience to make it into something good.
We're almost done with the jam game! :D
I get scam calls all the time so today I gave them a piece of my mind. They hung up on me. Sweet revenge.

Forum statistics

Threads
104,321
Messages
1,005,561
Members
135,844
Latest member
andrewshetty123
Top