Yanfly Quest journal system help

Status
Not open for further replies.

vivec360

Villager
Member
Joined
Jan 12, 2020
Messages
11
Reaction score
2
First Language
english
Primarily Uses
RMMV
I'l preface with I have very little code knowledge so if the fix is simple I apologise for taking up peoples time.

Installed the yanfly quest journal plugin. I was following he tutorial just now to try it out. When I was testing it out in game merely scrolling onto the quest would give me this error.
buglog.png
I'm hoping someone knowledgeable could tell me how I've broken it already.
 

Attachments

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,156
Reaction score
707
First Language
Dutch
Primarily Uses
RMMV
can you turn off "ItemUpgradeSlots" and see if its working?
because that one require ItemCore plugin.

as for the error further, I'm not sure it's the plugin doing at all, I think it's
more the quest event setup incorrectly.

can you screenshot your event with the quest that activate it?
(can be type in the plugin command/scriptcall).
 

vivec360

Villager
Member
Joined
Jan 12, 2020
Messages
11
Reaction score
2
First Language
english
Primarily Uses
RMMV
I've disabled the upgradable equipment thing, I didnt realize I was missing its parent.
The event itself has been in the game for months. I've only just begun the process of adding in the quest system.
Did you mean a screenshot like this?
quest.png
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,156
Reaction score
707
First Language
Dutch
Primarily Uses
RMMV
if you just add it, did you start a game from "New Game" (fresh start)
or from a save file?

from a save file will be invalid whenever you add a new plugin or make changes
in the database.

plugin command is correct.

if new game also gives an error or did this already, check if the plugin in the correct order.
you can also try to put OFF community basics or if you want to use it, put
YEP_EngineCore above those 2.

otherwise, I dont know where the error exacly come from.
 

vivec360

Villager
Member
Joined
Jan 12, 2020
Messages
11
Reaction score
2
First Language
english
Primarily Uses
RMMV
if you just add it, did you start a game from "New Game" (fresh start)
or from a save file?

from a save file will be invalid whenever you add a new plugin or make changes
in the database.

plugin command is correct.

if new game also gives an error or did this already, check if the plugin in the correct order.
you can also try to put OFF community basics or if you want to use it, put
YEP_EngineCore above those 2.

otherwise, I dont know where the error exacly come from.
Aye its why i thought to make a post, was genuinely unsure what I'd done to bungle things. I started a new file to test it since this was going to the first quest in game. I've now turned every plugin off besides core and the journal one. Still the same error so I guess the plugins are unrelated. I'll keep messing with things. Thank you for the feedback dude.
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,156
Reaction score
707
First Language
Dutch
Primarily Uses
RMMV
YEP_EngineCore and YEP_QuestJournal ON as only ones should work.
while its no compability issue.

so I have 2 questions.

1) is "Quest Add 1" also on autorun event and later triggered again that you accidentally
activated it twice?

2) does the game work or intro BEFORE getting the quest is added?

else someone else can take a look for you that is familair with the plugin.
 

vivec360

Villager
Member
Joined
Jan 12, 2020
Messages
11
Reaction score
2
First Language
english
Primarily Uses
RMMV
YEP_EngineCore and YEP_QuestJournal ON as only ones should work.
while its no compability issue.

so I have 2 questions.

1) is "Quest Add 1" also on autorun event and later triggered again that you accidentally
activated it twice?

2) does the game work or intro BEFORE getting the quest is added?

else someone else can take a look for you that is familair with the plugin.
Yes, thats literally what was happening, I had it autorun in the initial game boot event I made and forgot. then added it into the post I showed you. thing is, i got rid of the first event and it was still busted, but then i tried removing that quest all together and made a new one without changing any of the default info. That quest popped up in game no problems. So I'm guessing my problem was both having it turn on twice and changing something in the quest data without realising.
Either way its not crashing now so I'm gonna be careful and hope for the best. Thank you for being helpful, I really appreciate the effort.
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,156
Reaction score
707
First Language
Dutch
Primarily Uses
RMMV
anytime :)

if your problem is solved, report your firts post as solved.

Good luck on your project.
 

MushroomCake28

KAMO Studio
Global Mod
Joined
Nov 18, 2015
Messages
3,416
Reaction score
4,479
First Language
English
Primarily Uses
RMMV

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Got inspired and started writing a simple tower defence battle system last night :o
Good news! I have located an amazing 3D website called SketchFab that has rotatable renderings of famous statues!
Picked up a physical copy of Megadimension Neptunia VII for the PS4 today. It's pretty good. I'm having a lot of fun with it.
The only upside of this remote semester was the plenty of funny photoshop material those facecams provided. Not that I would do that. Ever.

Forum statistics

Threads
100,516
Messages
976,702
Members
132,080
Latest member
nwr
Top