Yanfly Sideview Battlers Not Working

Discussion in 'Javascript/Plugin Support' started by Devgirl Neko, Sep 20, 2016.

Thread Status:
Not open for further replies.
  1. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    Hi, I'm trying to get Yanfly's Animated Sideview Battlers to show an SV_Actor as an enemy. When I add the notetag <Sideview Battler: Vedemyn> and launch the battle, I get the error, "TypeError: Cannot read property 'setup' of undefined".


    Screenshots:

    [​IMG][​IMG][​IMG]

    Can anyone tell me what's wrong here?
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,312
    Likes Received:
    6,437
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    1) have you started a new game after entering the plugin? it won't work with an incompatible old savefile


    2) is your order of the plugins correct? Please give us a screenshot of your plugin manager if you don't know how to check the order (they have to be in the order given on yanfly's website)


    And please give a link to the website of the plugin as well
     
    #2
  3. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    #3
  4. Andar

    Andar Veteran Veteran

    Messages:
    28,312
    Likes Received:
    6,437
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    OK, further searching neccessary...


    1) does the same battle work if you try it ingame? (just make a quick event with a battle processing on the starting map to test)


    2) which version of RMMV is your editor, and which version is your project based on?


    In some cases, you'll need the correct version of the plugin for the project version, there are some incompatibilities between plugins for 1.2.0 and 1.3.1.
     
    #4
  5. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,891
    Likes Received:
    12,013
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    Do you actually have a file in the  img/sv_actors/  folder named Vedemyn, capitalized and spelled exactly like that? If not it will throw an error as it cannot find the file for your sideview battler.
     
    #5
  6. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    Yes, I have the file named exactly like that in img/sv_actors.


    1) I get the same error in-game as in the troop testing.


    2) My project is in 1.3.1 and my editor is 1.3.1. My version of Yanfly's Animated SV Battlers is 1.13. Another thing that should be noted, is that the static battlers follow the animation settings of the plugin, so the plugin must be working. It's only when I try to make the enemies use SV_Actor sprites that I run into trouble.
     
    #6
  7. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,891
    Likes Received:
    12,013
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    If it is working without the sprite, then the error is in the sprite. Try changing your notetag to <Sideview Battler: vedemyn> (it's the same as your tag but I replaced the V with a lowercase v) instead on the enemy tab in the database and see if it works. If so it was the capital V that was throwing it off.


    If neither work, also make sure the sprite has all the needed sideview frames. You may wish to post a screenshot of the sideview sprite you are trying to use.
     
    #7
  8. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    This is what my folder looks like.


    [​IMG]


    The file is Vedemyn.png with a capital "V".


    [​IMG]


    When I use the static battlers in the sv_enemies folder, the plugin shows the enemy doing the breathing animation included in the plugin.


    [​IMG]


    Like so:


    [​IMG]


    This "TypeError" that I'm getting only happens when I use any file from sv_actors as a battle sprite.
     
    #8
  9. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,891
    Likes Received:
    12,013
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    All looks in order to me from here. Still, just try it with a lowercase v in the notetag once and see what happens. Worst that happens is it doesn't work.
     
    #9
  10. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    Tried it and it's still giving me: "TypeError: Cannot read property 'setup' of undefined".
     
    #10
  11. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,891
    Likes Received:
    12,013
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    Afraid I'm out of ideas, then. Sorry. Hopefully someone else knows how to fix this one, as I'm still on ACE so all I know is the common errors and common things to check that I see posted here.
     
    #11
  12. Leon Kennedy

    Leon Kennedy Restaff Novice Restaff

    Messages:
    613
    Likes Received:
    468
    Location:
    Chicago
    First Language:
    english
    Primarily Uses:
    RMMV
    Well if it's acting as an enemy and that plugin enables animated battlers have you tried maybe placing it in sv_enemies as well? Maybe since it's technically an enemy you want to display as you say in first post it's looking in sv_enemies and not finding it @Devgirl Neko
     
    #12
  13. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    That doesn't work either. Yanfly's plugin says to put it in sv_actors specifically. I did everything that the plugin said to, and even watched the video. I'm stumped.
     
    #13
  14. Leon Kennedy

    Leon Kennedy Restaff Novice Restaff

    Messages:
    613
    Likes Received:
    468
    Location:
    Chicago
    First Language:
    english
    Primarily Uses:
    RMMV
    Hmm only last thing I can think of is it's somewhat odd your game folder is repeated usually its something like games>project>img>sv_actors but yours seems to repeat game name twice and then img/sv_actors. @Devgirl Neko
     
    #14
  15. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    That's just because it's in its own folder in my One Drive.


    It goes One Drive>ToS2(All related ToS2 stuff)>ToS2(Actual RPGMV Project Folder)


    [​IMG]
     
    Last edited by a moderator: Sep 21, 2016
    #15
  16. Johnboy

    Johnboy Veteran Veteran

    Messages:
    317
    Likes Received:
    104
    Location:
    Canadia
    First Language:
    English
    Have you by chance changed any of the sprite options in the battle engine core? Ones like sideview anchor, etc?
     
    #16
  17. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    No, I haven't.
     
    #17
  18. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    Does anyone know what I'm doing wrong? I can't find anyone else with this problem anywhere.
     
    #18
  19. Johnboy

    Johnboy Veteran Veteran

    Messages:
    317
    Likes Received:
    104
    Location:
    Canadia
    First Language:
    English
    Screenshot your entire list of plugins and post it up here. I'm willing to bet it's a plugin incompatibility.
     
    #19
  20. Devgirl Neko

    Devgirl Neko Villager Member

    Messages:
    11
    Likes Received:
    0
    First Language:
    English
    [​IMG]


    [​IMG]


    They're all Yanfly's except for the MadeWithMv which I've tried on and off without it working. They're all in the order that Yan's site says to put them in. @Johnboy
     
    #20
Thread Status:
Not open for further replies.

Share This Page