SumonoskexXx

Villager
Member
Joined
Sep 5, 2020
Messages
8
Reaction score
1
First Language
English
Primarily Uses
Other
Hello, I'm currently working on RPG Maker MV and have been having some troubles with animated enemies. I'm using the same actor for party and enemy using the same skill as an attack with the same notetags. While the party actor is able to change motions from standing to attacking, the enemy actor won't do the same. The enemy actor moves forward with any movement tag but wont perform custom motions itself. I'm wondering if there are other notetags to use when it comes to enemy actors.

This is the notetag for the current skill being used:


<target action>
custom motion prep: user
motion wait: user
wait: 45
death break
action effect: target
custom motion swing: user
motion wait: user
wait: 40
motion return: user
</target action>

Any help would be appreciated!
 

Attachments

  • 1.png
    1.png
    1.2 MB · Views: 5
  • 2.png
    2.png
    897.8 KB · Views: 5

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
2,210
Reaction score
1,175
First Language
English
Primarily Uses
RMMV
Your thread title is about sideview enemies, but you only show the action sequence, not any sideview enemy notetags.

What are these custom motion commands you're using? I can't find them in any of Yanfly's plugins - where are they from, and why not use the regular commands?
 

SumonoskexXx

Villager
Member
Joined
Sep 5, 2020
Messages
8
Reaction score
1
First Language
English
Primarily Uses
Other
Hi, Turan! Thanks for reaching out. These are the notetags for the enemy in question:



<Sideview Battler: Banda>
<Sideview Anchor X: 0.5>
<Sideview Anchor Y: 1.0>
<Sideview Battler Frames: 16>
<Sideview Battler Speed: 12>
<Sideview Battler Size: 210, 210>
<Sideview Height: 210>
<Sideview Width: 210>
<Sideview Battler Weapon: false>



<Sideview Battler Motion>
Name: walk
Index: 0
Loop
Frames: 16
Speed: 6
</Sideview Battler Motion>


<Sideview Battler Motion>
Name: swing
Index: 1
Frames: 16
</Sideview Battler Motion>

<Sideview Battler Motion>
Name: thrust
Index: 1
Frames: 16
</Sideview Battler Motion>

<Sideview Battler Motion>
Name: missile
Index: 1
Frames: 16
</Sideview Battler Motion>

Important that I forgot to mention is that I'm also using YED_SideviewBattler by Dr.Yami that supports Yanfly's Sideview Enemies. The custom motion is currently for testing, which works for the party actor. I have also changed to the default swing motion that works for the party actor, but not for the enemy actor.

I can edit the walking animation for the enemy actor just fine, but anything else just doesn't seem to show
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
2,210
Reaction score
1,175
First Language
English
Primarily Uses
RMMV
On a cursory search I can't find that YED plugin outside of a pack that I'm not going to download just for these purposes.

Does that say it's supposed to have compatibility with the action sequences like this? But if you've replaced it with standard motion commands and you still see nothing...I don't know why.

(why do you have a death break before anything happens?)
 

C64_Mat

System Masters
Veteran
Joined
Apr 3, 2021
Messages
71
Reaction score
31
First Language
English
Primarily Uses
RMMV
I have been having the same issue for weeks on end, with no solution in sight. It's frustrating I can't seem to get in touch with Yanfly himself, despite paying for his full plugin pack.
Here's my (still unresolved) thread:

 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
2,210
Reaction score
1,175
First Language
English
Primarily Uses
RMMV
Well, @SumonoskexXx and @C64_Mat I don't know what to tell you.

1) I made a new project, put just the Battle Engine Core and Animated Sideview Enemies plugins into it.

2) I assigned the bat to sideview Actor1_1 and it showed up.

3) I did a battle with the plugin default attack motion set to thrust, then to swing.

4) I left the plugin default at swing, added the sideview attack motion to thrust via notetag, and the bats did the thrust animation at me correctly.

Are you using the current version of the battle core and the sideview enemies? Versions that are mismatched either with each other or with your MV project version can cause unexpected behavior.

If you're sure you have the latest versions installed, and you're sure you have all plugins in Yanfly's recommended order, then I suggest you duplicate the steps I outlined above. If you can start a new project like that and those steps work correctly, then you know it's something else in your project that's conflicting.

If you can't get those results in a new project, then you know something is wrong with how you're configuring the plugins or perhaps corrupted in the plugins or your MV installation.
 

SumonoskexXx

Villager
Member
Joined
Sep 5, 2020
Messages
8
Reaction score
1
First Language
English
Primarily Uses
Other
I repeated the same steps and redownloaded all the scripts. It turns out a few were outdated (Included the battle engine and sideview enemies) and that seemed to do the job! Thank you so much!
 

Latest Threads

Latest Profile Posts

Finally got my website fixed and the security sorted so it's been a productive day. Can I go to sleep now? I mean... I don't need to work right?
It's always a good idea to refresh yourself on what your plugins do. I'm working on a map with opening walls, and I was about to tear my hair out over how much image editing and hand-constructing of autotiles I'd have to do, when I looked again and saw @Shaz 's Tile Changer could copy areas from another map.
"sorry it took me so long to respond" - can we please agree not to say that anymore unless it actually took a long time?! (Like 36hrs at least) I mean, I'm running out of funny responses here xD
Ugh... 4:53AM over here and I can't sleep so why not just game make.
I just love the MV feature that allows you to create your own animations!

Forum statistics

Threads
115,914
Messages
1,093,993
Members
151,172
Latest member
ShuBun-Kin
Top