Yanfly Visual State Effects - icons aren't above actors heads

Discussion in 'Javascript/Plugin Support' started by Muffel, May 13, 2018.

  1. Muffel

    Muffel Veteran Veteran

    Messages:
    75
    Likes Received:
    24
    First Language:
    German
    Primarily Uses:
    RMMV
    Hey guys, it's me. Nobody knows me. =(

    I have an issue where the state icons don't show above the actors, but below (?) and I don't know if I messed up or missed something.
    I tested this on a new project and it's the same.
    It works with the enemies though.

    Yanfly Visual State Effects Plugin

    needs core engine, battle engine core and buffs state core

    [​IMG]
    [​IMG]

    How can I change the State Icon Position so it's above the head, like it is with the enemy?

    Thanks in advance.
     
    Last edited: May 14, 2018
    #1
  2. JamesRyan

    JamesRyan Game Designer Veteran

    Messages:
    572
    Likes Received:
    169
    Location:
    Vietnam
    First Language:
    Vietnamese
    Primarily Uses:
    RMMV
    This should be from YEP Buffs & States Core, not from Visual State Effects. There is a parameter called "Show Enemy Icons". Set it to false and see if it works.
     
    #2
  3. Muffel

    Muffel Veteran Veteran

    Messages:
    75
    Likes Received:
    24
    First Language:
    German
    Primarily Uses:
    RMMV
    Now there's no state icon above enemy and no state icon by the actors at all. °~°;
     
    Last edited: May 13, 2018
    #3
  4. JamesRyan

    JamesRyan Game Designer Veteran

    Messages:
    572
    Likes Received:
    169
    Location:
    Vietnam
    First Language:
    Vietnamese
    Primarily Uses:
    RMMV
    Ah, sorry! My bad. I thought you wanted to turn off those icons. Just turn it back on. I'm not sure if this is caused by YEPs or other plugins, because i'm also using them and haven't encountered this problem.
     
    #4
  5. Muffel

    Muffel Veteran Veteran

    Messages:
    75
    Likes Received:
    24
    First Language:
    German
    Primarily Uses:
    RMMV
    No problem. I thought it would be other plugins as well, that's why I made a new project with only yep core, battle, buffs and that visual state effects plugin. Well, it works, but only as u can see in the picture.
    I can live with it, but it looks... kinda... you know... right?
    I wish this sort of thing would be a default setting in RMMV (like many other things), but you can't have it all it seems.
     
    #5
  6. Jeremiah Eastman

    Jeremiah Eastman Gladiator Veteran

    Messages:
    411
    Likes Received:
    177
    First Language:
    English
    Primarily Uses:
    RMMV
    I use those plugins myself and have never had that problem so something is definitely causing it. A couple things I would check first, if you haven't already is. Make sure the plugins are in the correct order. Make sure they are updated, is your mv properly updated? It can be tricky to update, simply updating through steam or however doesn't do it, you then have to go copy the right files to your project. Also are you using 1.6.1? If so it is really buggy still, I would suggest using the 1.5.2 version for now.

    I hope this maybe helps you figure it out, best of luck.
     
    #6
  7. Muffel

    Muffel Veteran Veteran

    Messages:
    75
    Likes Received:
    24
    First Language:
    German
    Primarily Uses:
    RMMV
    Oh... I'm still using 1.5.1 version. I'm afraid that might be the cause of problems. Will update it soon.
    I totally forgot about the 1.5.2 patch and didn't want to update anymore (1.6.0 messed up my project really bad). Thanks for the reminder.

    Will edit this post.

    Edit: updated to 1.5.2, created new project, downloaded plugins from yanfly's website, it's still the same.
    [​IMG]
    This should be the correct order, right?
    [​IMG]

    I probably didn't update it correctly to 1.5.2 ... will edit again soon.
     
    Last edited: May 14, 2018
    #7
    Jeremiah Eastman likes this.
  8. Jeremiah Eastman

    Jeremiah Eastman Gladiator Veteran

    Messages:
    411
    Likes Received:
    177
    First Language:
    English
    Primarily Uses:
    RMMV
    #8
    Muffel likes this.
  9. Muffel

    Muffel Veteran Veteran

    Messages:
    75
    Likes Received:
    24
    First Language:
    German
    Primarily Uses:
    RMMV
    Alrighty... this is kinda... I seriously don't know what I am doing wrong.

    I uninstalled rmmv, rebooted PC, installed RMMV, made a new project, used the downloaded plugins to install them in the new project. Problem is still there.

    [​IMG]
    [​IMG]

    I seriously am at my witt's end if it's something related to the software...
    but thanks for pointing out things that could be the issue.
     
    #9
  10. Muffel

    Muffel Veteran Veteran

    Messages:
    75
    Likes Received:
    24
    First Language:
    German
    Primarily Uses:
    RMMV
    bump
     
    #10

Share This Page