Status
Not open for further replies.

Muffel

Veteran
Veteran
Joined
Feb 1, 2018
Messages
75
Reaction score
24
First Language
German
Primarily Uses
RMMV
Hey guys, it's me. Nobody knows me. =(

I have an issue where the state icons don't show above the actors, but below (?) and I don't know if I messed up or missed something.
I tested this on a new project and it's the same.
It works with the enemies though.

Yanfly Visual State Effects Plugin

needs core engine, battle engine core and buffs state core

19978ad77f07fc9713076bca414c20f4.png

fb568fb98309811aab62b1c58e12e991.png

How can I change the State Icon Position so it's above the head, like it is with the enemy?

Thanks in advance.
 
Last edited:

JamesRyan

Game Designer
Veteran
Joined
Sep 13, 2014
Messages
734
Reaction score
242
First Language
Vietnamese
Primarily Uses
RMMV
This should be from YEP Buffs & States Core, not from Visual State Effects. There is a parameter called "Show Enemy Icons". Set it to false and see if it works.
 

Muffel

Veteran
Veteran
Joined
Feb 1, 2018
Messages
75
Reaction score
24
First Language
German
Primarily Uses
RMMV
Now there's no state icon above enemy and no state icon by the actors at all. °~°;
 
Last edited:

JamesRyan

Game Designer
Veteran
Joined
Sep 13, 2014
Messages
734
Reaction score
242
First Language
Vietnamese
Primarily Uses
RMMV
Ah, sorry! My bad. I thought you wanted to turn off those icons. Just turn it back on. I'm not sure if this is caused by YEPs or other plugins, because i'm also using them and haven't encountered this problem.
 

Muffel

Veteran
Veteran
Joined
Feb 1, 2018
Messages
75
Reaction score
24
First Language
German
Primarily Uses
RMMV
No problem. I thought it would be other plugins as well, that's why I made a new project with only yep core, battle, buffs and that visual state effects plugin. Well, it works, but only as u can see in the picture.
I can live with it, but it looks... kinda... you know... right?
I wish this sort of thing would be a default setting in RMMV (like many other things), but you can't have it all it seems.
 

Jeremiah Eastman

Gladiator
Veteran
Joined
Apr 24, 2017
Messages
561
Reaction score
349
First Language
English
Primarily Uses
RMMV
I use those plugins myself and have never had that problem so something is definitely causing it. A couple things I would check first, if you haven't already is. Make sure the plugins are in the correct order. Make sure they are updated, is your mv properly updated? It can be tricky to update, simply updating through steam or however doesn't do it, you then have to go copy the right files to your project. Also are you using 1.6.1? If so it is really buggy still, I would suggest using the 1.5.2 version for now.

I hope this maybe helps you figure it out, best of luck.
 

Muffel

Veteran
Veteran
Joined
Feb 1, 2018
Messages
75
Reaction score
24
First Language
German
Primarily Uses
RMMV
Oh... I'm still using 1.5.1 version. I'm afraid that might be the cause of problems. Will update it soon.
I totally forgot about the 1.5.2 patch and didn't want to update anymore (1.6.0 messed up my project really bad). Thanks for the reminder.

Will edit this post.

Edit: updated to 1.5.2, created new project, downloaded plugins from yanfly's website, it's still the same.
b1324b5ffc8c01f54fb553ff1df31836.png

This should be the correct order, right?
9b544bf52b930418999f4113afbab4e3.png

I probably didn't update it correctly to 1.5.2 ... will edit again soon.
 
Last edited:

Muffel

Veteran
Veteran
Joined
Feb 1, 2018
Messages
75
Reaction score
24
First Language
German
Primarily Uses
RMMV
Alrighty... this is kinda... I seriously don't know what I am doing wrong.

I uninstalled rmmv, rebooted PC, installed RMMV, made a new project, used the downloaded plugins to install them in the new project. Problem is still there.

e04f66efa19e0103c0601173d5d35d21.png
05bfc37c25556740578966c8aff1d032.png

I seriously am at my witt's end if it's something related to the software...
but thanks for pointing out things that could be the issue.
 

jglag

Veteran
Veteran
Joined
Jan 6, 2017
Messages
36
Reaction score
1
First Language
English
Primarily Uses
Did this seriously never get resolved? Because I'm having the same issue in 2020.
 

Heliolater

Villager
Member
Joined
Oct 15, 2021
Messages
5
Reaction score
1
First Language
English
Primarily Uses
RMMV
Just resolved this in 2021. I was using exclusively Yanfly plugins for the most recent version of MV.
My issue was caused by 1. missing dependencies and 2. improper sequencing.
Action Sequence Packs 1-3 and Animated Sideview Enemies were added between working and not working, so one or more of those was required.
The sequencing still needed to be fixed and my plugins are currently in this order:
Core
Battle EngineCore
BuffsStatesCore
ActSeqPack 1-3
AnimatedSVEnemies
VisualStateFX

Further, if it helps, I have the remaining core plugins, CTB battle system plugin, and visual HP gauge below this.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,102
Reaction score
15,523
First Language
English
Primarily Uses
RMMV

@Heliolater, please refrain from necro-posting in a thread. Necro-posting is posting in a thread that has not had posting activity in over 30 days. You can review our forum rules here. Thank you.

 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

1638168263130.png
Crossover Inn is getting very crowded, and I love it
Climbing to the top #mapping
1638160732198.png
I've started the first steps of the final few maps that I need to make for B:ms. I haven't been able to say that in a really, really long time. It'd probably be a good idea to blog about this or something.
Question for the Mods: What am I supposed to do when I can't make a synopsis 350 words long? (for project recruitment thread) @Shaz @mlogan
The game is meant to be more on the simple side in order to be achievable so I'm a bit stuck...

Forum statistics

Threads
117,043
Messages
1,104,071
Members
152,981
Latest member
FromVillage
Top