Yanfly Weapon Animation Plugin not working at all [solved]

Status
Not open for further replies.

ALink95

Villager
Member
Joined
Feb 25, 2020
Messages
5
Reaction score
0
First Language
French
Primarily Uses
RMMV
Hello, at first i want to apologize for my bad english, and i don't really know if i've posted in the right section.

So, i'm using this Yanfly's plugin to make my characters attack with some custom weapons i designed by myself, but even with doing it all like in the tutorial it doesn't seem to work.

So i'll put a list with the order of the actions i've made :
-Put the plugin in the plugin pannel, below all the other plugins as Yanfly says in the tutorial (Battle Engine Core, Sequence packs...)
-Created a new file in img\ named weapons\
-Put my custom wepaon image in the folder named "Baguette.png" and designed with the correct proportions (W: 288 H:64)
-Created a new spear type weapon in database, and inserted the tag <Weapon Image : Baguette>

And when i make a basic attack with the character equipped with this weapon it just show the basic spear animation, as if i had installed no plugin...

I need some help plz, i purchased this plugin and i can't seem to make it work :/
 

Zekken

Programmer? Pro-Gamer? Pro-Grammar?
Veteran
Joined
Aug 29, 2019
Messages
105
Reaction score
24
First Language
Indonesian
Primarily Uses
RMMV
i think the image should in the img/weapon/
 

ALink95

Villager
Member
Joined
Feb 25, 2020
Messages
5
Reaction score
0
First Language
French
Primarily Uses
RMMV
Hello,

The image is in this folder :/
 

MushroomCake28

KAMO Studio
Global Mod
Joined
Nov 18, 2015
Messages
2,589
Reaction score
3,780
First Language
English
Primarily Uses
RMMV

I've moved this thread to Javascript/Plugin Requests. Please be sure to post your threads in the correct forum next time. Thank you.

 

Zekken

Programmer? Pro-Gamer? Pro-Grammar?
Veteran
Joined
Aug 29, 2019
Messages
105
Reaction score
24
First Language
Indonesian
Primarily Uses
RMMV
Make sure you put the image like this : img/weapons/Baguette.png
And then put this notetag in the weapon note section in the database :
<Weapon Image: Baguette>
<Weapon Motion: swing>

if still didn't work, try to take a look once again on the plugin order.
the plugin order should be like this :
 

ALink95

Villager
Member
Joined
Feb 25, 2020
Messages
5
Reaction score
0
First Language
French
Primarily Uses
RMMV
Hey, i've done it all right but it's still not working...

Plugin order.PNGWeapons informations.PNGImage location.PNG
 

Zekken

Programmer? Pro-Gamer? Pro-Grammar?
Veteran
Joined
Aug 29, 2019
Messages
105
Reaction score
24
First Language
Indonesian
Primarily Uses
RMMV
That's a confusing problem, because as long as I using YEP_WeaponAnimation it works just fine. But why you put Community basic, made with MV, and SRD_CameraCore above of YEP_Core Engine? I think YEP_CoreEngine Should be always in the top of plugin manager.

Maybe you can disable other plugin one by one to check that there is compatibility issue.

Did you check the console log? Press F8 while playtesting and can u send the screenshot here?

Can u screenshot you YEP_WeaponAnimation plugin parameters?

If still didn't work. I have a little trick.
Put your image in the img/system/
and then rename it to Weapon3 and then <Weapon Image: 25>
 

ALink95

Villager
Member
Joined
Feb 25, 2020
Messages
5
Reaction score
0
First Language
French
Primarily Uses
RMMV
Hello again,
So i tried disabling all plugins but not the Weapon Animation one, it still doesn't work..
I also tried your little trick, but still don't work (placing image in the img/system folder and renaming it Weapon3)
I already had tried a thing like placing it in this folder but calling it Weapon4, and putting the notetag <Weapon Image : 37>.
So for the logs screenshot i can't really give you anything i don't understand what i need to watch in the window ^^'
There's the screenshot for my plugin parameters.PLugin parameters.PNG
 

glaphen

Veteran
Veteran
Joined
Jan 13, 2019
Messages
286
Reaction score
104
First Language
English
Primarily Uses
RMMV
It's because you're writing <Weapon Image : 37> not,
Code:
<Weapon Image: 37>
There is no spaces between image and :
 

ALink95

Villager
Member
Joined
Feb 25, 2020
Messages
5
Reaction score
0
First Language
French
Primarily Uses
RMMV
Ok man i love you but in the same time i just hate me for no even thinking of this possibility, and it's strange cuz i even just copy/pasted the yanfly's command and it wasn't working too...
But ok it's solved thank you a lot :hswt:
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
6,158
Reaction score
4,296
First Language
Dutch
Primarily Uses
RMXP

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

wishing that everyone stays safe at this time
Ami
4 days im not using my laptop to waiting someone to reinstall (sigh)
Stream will be live shortly with some Donkey Kong 64! Feel free to drop by!
Working on a test Boss for the new No Travel Game Jam
- Name Plugin by Moghunter -
Free RPG Maker Ready Charging Up Animation

Enjoy -No Credit Needed But Appreciated -
Download it at https://lvgames.itch.io/free-charging-up-pixel-animation-fx-rpg-maker-ready

Forum statistics

Threads
95,490
Messages
929,548
Members
125,740
Latest member
Smeinela
Top