Yanfly's animated sv enemies are invisible

Discussion in 'Javascript/Plugin Support' started by UniqueName, Dec 4, 2018.

  1. UniqueName

    UniqueName Veteran Veteran

    Messages:
    38
    Likes Received:
    5
    First Language:
    Russian
    Primarily Uses:
    Other
    Everything worked fine before. But then for some reason animated sideview enemies became invisible while static ones are visible. I created new project with only CoreEngine, BattleCore and SideviewBattler to check. This time animated enemies are visible but the main character's troop isn't.
    Can anyone tell me what could possibly cause this problem?
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,646
    Likes Received:
    6,584
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    not without more info from you.

    best guess it could be
    1) wrong folder sequence - the engine has problems loading files (including pictures) if there is something in the path that does not follow networking rules for file and folder names (which means latin letters only, no spaces and a few more rules).
    2) mixup in plugin compatibility, either order or a new plugin added in.
     
    #2
  3. UniqueName

    UniqueName Veteran Veteran

    Messages:
    38
    Likes Received:
    5
    First Language:
    Russian
    Primarily Uses:
    Other
    That's screenshot of the problem and plugin list. Though I checked it in new project with no other plugins and main character sprites disappeared instead.
     

    Attached Files:

    #3
  4. Andar

    Andar Veteran Veteran

    Messages:
    28,646
    Likes Received:
    6,584
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    wrong order of yanfly plugins, and you didn't say anything about your filepath to the project even if that is the more likely cause. What is your full filepath from drive letter to index.html?
     
    #4
  5. UniqueName

    UniqueName Veteran Veteran

    Messages:
    38
    Likes Received:
    5
    First Language:
    Russian
    Primarily Uses:
    Other
    fullpath to index.html is C:\Users\user\Documents\Games\ArcaneMagic
    and to sv_actors folder is C:\Users\user\Documents\Games\ArcaneMagic\img\sv_actors
     
    #5
  6. Andar

    Andar Veteran Veteran

    Messages:
    28,646
    Likes Received:
    6,584
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    you called your profile "user"?
    If that is not a replacement text to hide your username then the path is OK, so try again after you correct the plugin order to the one required for yanflys plugin and start a new game with the correct order.
     
    #6
  7. UniqueName

    UniqueName Veteran Veteran

    Messages:
    38
    Likes Received:
    5
    First Language:
    Russian
    Primarily Uses:
    Other
    I found it! That time when I checked it in new project I actually forgot to check if sideview mode was on
    So everything actually worked perfect in new project.
    I copied all plugin from my current project to the new one and checked again
    Same error occured, so I found out the problem is in plugins compability.
    By turning off each plugin one by one I figured out that the problem was because I moved "MoreStatesOverlay" plugin below Yanfly's
    The problem is solved!
    And tnx for help
     
    #7

Share This Page