YEP: Action Sequence Packs not Working after BattleEngineCore Update

LappenLike

Villager
Member
Joined
Dec 8, 2013
Messages
15
Reaction score
1
First Language
German
Primarily Uses
Hello there,

to use some other new Scripts I need to update Yanfly's BattleEngineCore.
However, as soon as I do just that, all the Action Sequence Scripts stop working (I did a lot with those Action Sequences so they probably get called all the time).
The Error appears whenever a battle is starting. (Error attached)

I tried using the newest versions of all of these Scripts, but the Error persists.
Is there anything I probably could've overlooked or does it just not work?

Thanks for the help!
 

Attachments

  • erroryep.PNG
    erroryep.PNG
    535.7 KB · Views: 11

Aloe Guvner

Walrus
Veteran
Joined
Sep 28, 2017
Messages
1,628
Reaction score
1,152
First Language
English
Primarily Uses
RMMV
Can you post a screenshot of the full error message in the Console (press F8 during playtest) as well as a screenshot of your Plugin Manager?
 

LappenLike

Villager
Member
Joined
Dec 8, 2013
Messages
15
Reaction score
1
First Language
German
Primarily Uses
There seems to be a lot, but this happens just after changing the BattleCoreEngine, nothing else.
 

Attachments

  • errors1.PNG
    errors1.PNG
    226.5 KB · Views: 8
  • plugg.PNG
    plugg.PNG
    323.2 KB · Views: 6

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,751
Reaction score
8,964
First Language
German
Primarily Uses
RMMV
your yanfly plugins are in the wrong order - anything can happen if you don't correct that order.
All of yanfly's plugins (especially if a lot of them are used) have to be in exactly the order given on his website.

so first reorder them, then start a new game to see if that alone solves your problem (do not load a saved file, those will be incompatible).

If that alone is not enough, a project update might be required as well.

And third, some of your errors sound as if you have incomplete plugins or incomplete script commands - have you always downloaded plugin files as is or did you sometime create them by copy&paste into a text editor?
 

Aloe Guvner

Walrus
Veteran
Joined
Sep 28, 2017
Messages
1,628
Reaction score
1,152
First Language
English
Primarily Uses
RMMV
To assist with Andar's suggestion #1 reordering your YEP plugins, you can follow the link in my signature to a tool I created called "YEP Plugin Order Checker". It will read your YEP plugins and tell you the correct order.
 

LappenLike

Villager
Member
Joined
Dec 8, 2013
Messages
15
Reaction score
1
First Language
German
Primarily Uses
Thanks for your responses!
So eventhough I didn't use the exact order, I already ordered them so they should be working. However, I just used Aloe's Tool to rearrange everything so it's definitely in the right order now. Sadly it didn't solve the problem.

I'm also pretty sure I downloaded all the Files as they are. All of them are working fine if I just switch back to the old BattleEngineCore, the problem only appears when using the actual version.

If a project update is required I just gotta accept this as impossible, it's a pretty old project and there are many thing's I can't get to work on the new Version, already tried that.

Still thanks for the help so far.
 

Aloe Guvner

Walrus
Veteran
Joined
Sep 28, 2017
Messages
1,628
Reaction score
1,152
First Language
English
Primarily Uses
RMMV
What version are your core files? If you open up rpg_core.js, what version does it display at the top?

Plus, you have a bunch of other errors in the console that are probably giving you trouble too.
 

LappenLike

Villager
Member
Joined
Dec 8, 2013
Messages
15
Reaction score
1
First Language
German
Primarily Uses
To be honest I can't find any version-info at the top at all?
If it helps, the file is dated 2015//10/20.
 

Attachments

  • rogcore.PNG
    rogcore.PNG
    27 KB · Views: 4

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,751
Reaction score
8,964
First Language
German
Primarily Uses
RMMV
Then your project core is 1.0 and you need to update your project as well.
Most yanfly plugins in todays versions require a minimum of 1.3.0, some even require 1.6.1 to be able to function correctly.

So you can either go back to the old versions (and the core of pre-1.4 had a lot of memory leaks, not a good idea to keep it) or update your project core and hope that all plugins you use have updates as well.
 

Latest Threads

Latest Profile Posts

Ugh, can't decide what to make next!
The Dystopia
ikW0BYF.png
Recently got RPG Maker MZ. A bit slower with my current PC but I will be getting a new one soon.
evening progress; pretty happy where this is at so i'll take the rest of the night to myself =w=
5NJGyKY.png
It would seem learning JS is not a know it all for making plugins. While it has enabled me to understand what I'm looking at, I still have to find the relevant information in the core scripts. This is much harder than learning JS IMO.

Forum statistics

Threads
118,403
Messages
1,115,673
Members
155,343
Latest member
sograyish
Top