LunaFamiliar

Veteran
Veteran
Joined
Jan 24, 2021
Messages
49
Reaction score
6
First Language
English
Primarily Uses
RMMV
Hi everyone!
First of all this is like my second post ever so I hope I put it in the right spot ><
I've been having this issue with my project for months now and I've put off trying to fix it because I have no idea where to start. I have C# knowledge but zero Java experience.

Using Yanfly's Animated SV Enemies plugin, I seem to be having issues where animations are not playing Centered on battlers. It always seems to play the animation a margin higher above the centre, which looks really really bad for some specifically shaped enemies. I want all animations to play at the middle point of battler.

Key Things I've Tried Before
1. Editing the image file of battlers in GIMP.
  • I've tried adding space at the bottom to reposition the centre of the actual creature to align with the centre of image, but this A: doesn't make a significant difference, and B: messes with the Yanfly HP bar script (which generates from the bottom of the image [yes i've tried adjusting that too but there's still the issue of battler images now being generally weirdly proportioned across the board]).
2. Shifting the position of all animations themselves in the Animations tab
  • Doing this creates several problems. Enemies that use the same animations now are position lowered on the players, because this glitch seems to only occur on static battlers. (side note on that: Animated SV Enemies created from a Character Generator spritesheet do not seem to suffer from this issue, and have animations played on them centered fine, so shifting the animations position in the animations tab will also make these enemies now off centre lol).
As you can see by the video below, I have created a battler that is 200x200 pixels in size, and marked where the centre of it is (as well as its border).
You can see that by playing a simple Hit and Slash animation (that have only had their sizes reduced in the animations tab, but are still perfectly aligned to the centre in that animation tab test window) it shows the animation above the centre.


Does anybody else have this issue and does anyone know how to solve it? It's been plaguing me for months and it just breaks immersion and makes the game look so sloppy.

Thank you for any help! ^_^
 
Last edited:

zhonghuaguoge

Warper
Member
Joined
Apr 23, 2019
Messages
1
Reaction score
0
First Language
Chinese
Primarily Uses
RMMV
Oh, sorry, the translation plugin automatically converted the English I wrote into Chinese


Have you installed KELYEP_DragonBones.js?
In the default settings of this plugin, Default Height = 100, This will cause the animation position to be too high.
QQ图片20210329012219.png
 
Last edited:

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,715
Reaction score
15,838
First Language
English
Primarily Uses
RMMV
Hi @zhonghuaguoge, can you please translate your post to English?
 

LunaFamiliar

Veteran
Veteran
Joined
Jan 24, 2021
Messages
49
Reaction score
6
First Language
English
Primarily Uses
RMMV
@zhonghuaguoge you absolute legend thank you so much!
Reducing that variable down from 100 to 50 fixed the problem straight away ^_^

I honestly would never have guessed that was the cause... as I assumed those variables only affected DragonBones-Designed Battlers, and the monsters it wasn't working on were simple static battlers, but I suppose the plugin has an effect on everything (except character-generated anim SV enemies)

Thank you so much!
 

Latest Threads

Latest Posts

Latest Profile Posts

Going to try my luck with Rust programming language. C++ is just way too gosh darn frustrating.
Phew. Finally fixed all of the tileset and event issues in this demo. And now, it's time to release another, finished game. Stay tuned!

Forum statistics

Threads
121,880
Messages
1,144,879
Members
160,137
Latest member
Shiresu
Top